LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   How to disable to Desktop effect in Feisty? (http://www.linuxquestions.org/questions/ubuntu-63/how-to-disable-to-desktop-effect-in-feisty-581238/)

ussr_1991 08-31-2007 10:11 AM

How to disable to Desktop effect in Feisty?
 
I was tempted to try the Desktop effect on a Duron PC with 319 MB of RAM. In the end, it is hardly respond and I pressed the reboot button, only to see I cannot even see the login screen. What should I do WITHOUT reinstall the Ubuntu again. (Yucks!, It takes a donkey hours to do the upgrading from Dapper to Feisty!!!)
I can boot both OS, Windows XP and Feisty, only Feisty cannot see the login screen because it took a donkey years to load (Keep turning the mouse like usual loading cursor but, even the background colour is black while mine settings for default colour is the one set in default! , Definitely not black, everyone knows.)
However, my Windows XP Professional is working perfectly all right. No affected by this setting from Linux. Can boot, can login and can ask questions at LinuxQuestions.org

jolphil 08-31-2007 01:32 PM

Hello
If you can,after ubuntu loads, try pressing ctrl-alt F3 and see if you can get a logon screen..if so log in as user then su - ...If you can do that,
try entering init3 as root and use your favorite editor to bring up/etc/X11/xorg.conf file to examine the file and make changes ..Look in the monitor section for anything you see as wrong...
It looks to me that your Xorg conf got hosed...If you are lucky enough to have an nvidia card and you still have your driver on the hard drive,
try to install it again..To get out press ctrl-alt-delete or type in
shutdown -h now and your unit will shut down and you can start over again..Most experts will doubt you have to reinstall but I guess you never know..Goodluck,
jolphil

dasy2k1 08-31-2007 06:08 PM

you need to use

sudo su -
to get a root shell but otherwise taht should work

ussr_1991 09-01-2007 04:39 AM

This is my /etc/X11/xorg.conf shown by Explore2fs when log onto Windows XP Professional. Which part of it is wrong? My Graphic card's driver is SiS 650_651_M650_M652_740 shown in the device manager on Windows XP Professional.
Quote:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Silicon Integrated Systems (SiS) 65x/M650/740 PCI/AGP VGA Display Adapter"
Driver "sis"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "5En"
Option "DPMS"
HorizSync 30-54
VertRefresh 50-120
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems (SiS) 65x/M650/740 PCI/AGP VGA Display Adapter"
Monitor "5En"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

ussr_1991 09-01-2007 05:44 AM

Partially works.
 
Quote:

Originally Posted by jolphil (Post 2877051)
Hello
If you can,after ubuntu loads, try pressing ctrl-alt F3 and see if you can get a logon screen..if so log in as user then su - ...If you can do that,
try entering init3 as root and use your favorite editor to bring up/etc/X11/xorg.conf file to examine the file and make changes ..Look in the monitor section for anything you see as wrong...
It looks to me that your Xorg conf got hosed...If you are lucky enough to have an nvidia card and you still have your driver on the hard drive,
try to install it again..To get out press ctrl-alt-delete or type in
shutdown -h now and your unit will shut down and you can start over again..Most experts will doubt you have to reinstall but I guess you never know..Goodluck,
jolphil

The part on Ctrl-Alt + F3 works and I log in as root.
However the init3 command was not found!
I does not use Nvidia Graphics. Mine is an intergrated graphical card by SiS.

jolphil 09-01-2007 07:21 AM

I think you need a space between init and 3 init 3

PS sorry for my typo and I am unfamiliar with the SIS chipset but
I would first see if your monitor section agrees with the specs for your monitor..Look at both the horizontal and vertical frequencies
and compare then to the actual specifications of your monitor...
Perhaps someone with that chipset can jump in and help..
jolphil

ussr_1991 09-01-2007 08:15 AM

Thank you everyone!!
 
Thank you everyone especially jolphil who said that something is wrong in Xorg
Quote:

Originally Posted by jolphil
It looks to me that your Xorg conf got hosed...If you are lucky enough to have an nvidia card and you still have your driver on the hard drive,

but I had fixed the problem myself. Just simply googling for extfsd (Ext2 File System Driver for Windows) which could write/read ext3 files for me in Windows XP Professional. Then assign a letter to mount into Windows like F:\ if you have 2 hard disk or partition etc (Do it accordingly to various partitioning.)By the way, when installing, you must select the option for force write in ext3 partition or otherwise, you may not be able to write in ext3 drives.Then search for /etc/X11/Xorg.conf and its backups. Delete all if you does not sure which file is working or just copy the WORKING backup to paste on its Xorg.conf file. Note: The backup is usually Xorg.conf(Date with year,time and date) without the brackets, () .
Restart the computer. There it works!!
Note for Mac users: These apps written above is meant for Windows, For Macs, please try to mount it by hard or try googling but the deletion of the original copy or copy the working backups of Xorg.conf is a must.


Serious Warning: After which, your system might become like mine and start cannot logon to Windows and possibly a change of screen resolution like mine, from 800*600 resolution to 1024*768 which is one of the supported resolution but the system did not recognize this initially after installed Ubuntu. This is especially true when you delete the Xorg.conf and I am not sure whether if this applies to a copy paste from a working backup copy because this second method is my assumption as from this first method of deleting files (Xorg.conf) showed that it is likely that some part of the file is wrongly set. Please go to this link to show how to add Windows on Grub
http://www.linuxquestions.org/questi...20#post2877720

jolphil 09-01-2007 03:39 PM

Good Job...You are quite welcome for my input, but you did it yourself..
What I usually do is to make a backup copy of my working xorg.conf file incase I hose it..as root
cp /etc/X11/xorg.conf_/etc/X11/xorg.conf.bak then to do it the otherway
around when I need to..
cp /etc/X11/xorg.conf.bak_/etc/X11/xorg.conf

note The underscore is a space..
Goodluck,
jolphil


All times are GMT -5. The time now is 01:45 PM.