LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-07-2006, 03:49 PM   #1
the1wraith
Member
 
Registered: Oct 2005
Distribution: Kubuntu 7.10
Posts: 33

Rep: Reputation: 15
how do you change the default sound card in (K)ubuntu?


The sound is playing fine...I can see that on my screen, I just can't hear anything because it is trying to play the sound through the speaker on my motherboard...which doesn't work.

Here are my soundcards:
Intel 82801BA-ICH2 (default)
USB Audio
SBLive! Value [CT4871] (the one I want)

Other information, I am running a 6.10 distribution of Kubuntu, and I have googled all over for the answer to my problem, but came up with nothing.

Cheers,
wraith
 
Old 11-18-2006, 12:40 AM   #2
Roklobsta
LQ Newbie
 
Registered: Nov 2006
Posts: 1

Rep: Reputation: 0
I too was vexed by this problem. My preferred soundcard is my SBLive! but I use the VIA chipset based soundcard on my motherboard for VoIP stuff. Kubuntu was always making my VIA soundcard the default.

The solution is a bit obscure but it works.

Do:

sudo asoundconf list

I got back:

Names of available sound cards:
Live
V8237

I then did:

sudo asoundconf set-default-card Live

followed by a reboot to test.

Sure enough, the Live is now set to default. It'd be nice if there was a simple config app in the KDE configuration panel that did this.
 
Old 11-18-2006, 08:54 AM   #3
the1wraith
Member
 
Registered: Oct 2005
Distribution: Kubuntu 7.10
Posts: 33

Original Poster
Rep: Reputation: 15
Thank you so much! It would be nice if that was in KDE...or in a tutorial somewhere that was easy to find. Maybe I'll submit it to ubuntuguide.org or something.

Anyways, again thank you very much.

Cheers,
wraith
 
Old 12-13-2006, 11:17 PM   #4
yedidyah
LQ Newbie
 
Registered: Nov 2006
Distribution: suse 10.0
Posts: 15

Rep: Reputation: 0
thank you

Roklobsta I want to thank you for this post. I love Kubuntu and have been running linux distros for about a year now. But it seems like I waste A LOT OF TIME trying to figure simple things out. This post saved me hours. Thanks for the info.
 
Old 12-13-2006, 11:53 PM   #5
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Didn't work for me in Debian, but looking at the man page, I think there could be several reasons for that. The man page also suggests than Ubuntu may be using the asoundconf command in different ways than Debian. At any rate, this is the solution I use. It keeps both cards available for use, but sets snd-card-0 as the default. "snd-ca0106" and "snd-atiixp" are the respective modules inserted by alsa depending on which card I want to use.

I edit /etc/modprobe.d/sound to look like this:
Code:
## Creative
alias snd-card-0 snd-ca0106
options snd-ca0106 index=0
## On-board
alias snd-card-1 snd-atiixp
options snd-atiixp index=1
 
1 members found this post helpful.
Old 03-20-2007, 11:32 AM   #6
cyb3rj
LQ Newbie
 
Registered: Feb 2007
Posts: 3

Rep: Reputation: 0
Smile Thank you so much

This EXACT set of steps worked for my Audigy card (registered as a CA0106).

I've found the best help for all of my linux questions from the Unbuntu/Debian crowd.


Quote:
Originally Posted by Roklobsta
I too was vexed by this problem. My preferred soundcard is my SBLive! but I use the VIA chipset based soundcard on my motherboard for VoIP stuff. Kubuntu was always making my VIA soundcard the default.

The solution is a bit obscure but it works.

Do:

sudo asoundconf list

I got back:

Names of available sound cards:
Live
V8237

I then did:

sudo asoundconf set-default-card Live

followed by a reboot to test.

Sure enough, the Live is now set to default. It'd be nice if there was a simple config app in the KDE configuration panel that did this.
 
Old 03-31-2007, 09:18 AM   #7
lordgreggreg
LQ Newbie
 
Registered: Mar 2007
Distribution: Kubuntu Edgy
Posts: 6

Rep: Reputation: 0
Thumbs up Thank You!

Hey, I really appreciate your help. That is exactly what I needed to get my sound working! Thank you! (The whole asoundconf stuff).
 
Old 05-22-2007, 04:36 PM   #8
rambutan
LQ Newbie
 
Registered: May 2007
Location: Ridgeland, WI USA
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
Thank you

$ sudo asoundconf list
showed:
I82801BAICH2
Live
$ sudo asoundconf set-default-card Live
worked for me.

Thanks for showing me where the configuration is.
 
Old 01-11-2008, 01:25 PM   #9
deiwi
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Unhappy it didnt worked for me :(

Quote:
Originally Posted by rambutan View Post
$ sudo asoundconf list
showed:
I82801BAICH2
Live
$ sudo asoundconf set-default-card Live
worked for me.

Thanks for showing me where the configuration is.
i'm migrating to ubuntu 7.10 and my soundcard doesn't work
i tried several time to do the sudo asoundconf "set-default-card Live" thing but it didnt work
this is what i do...

deiwi@SION:/etc/modprobe.d$ sudo asoundconf list
Please note that you are attempting to run asoundconf as a privileged superuser, which may have unintended consequences.

Names of available sound cards:
V8237
SAA7134
Audigy2

...where Audigy2 is my f...ing card and v8237 is the onboard soundcard and the SAA... card its my tv capture card, but i insert the command

$ sudo asoundconf set-default-card Audigy2 ...and it tells me ...


Please note that you are attempting to run asoundconf as a privileged superuser, which may have unintended consequences.
deiwi@SION:/etc/modprobe.d$

i'm newbie in ubuntu and i'm really thinking to dropped it away but i really dont want to, PLEAAASE HEEEELP ME!!!!!
 
Old 04-29-2008, 10:17 PM   #10
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
It looks like you're not supposed to run it as superuser... try again, but leave out the "sudo".
You could also disable the sound-on-board in the bios.


- This is your first post on this forum, and you're already thinking about giving up?

Last edited by oskar; 04-29-2008 at 10:20 PM.
 
Old 07-28-2008, 04:16 PM   #11
Cess209
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
Smile Thanks Guys...

Im totally new to Linux, and have just installed Ubuntu and trying to get away from Windows, and this sound problem was buggin. But, I did what you folks suggested and problem Fixed. Thanks so Much.
 
Old 07-28-2008, 04:18 PM   #12
Cess209
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by the1wraith View Post
The sound is playing fine...I can see that on my screen, I just can't hear anything because it is trying to play the sound through the speaker on my motherboard...which doesn't work.

Here are my soundcards:
Intel 82801BA-ICH2 (default)
USB Audio
SBLive! Value [CT4871] (the one I want)

Other information, I am running a 6.10 distribution of Kubuntu, and I have googled all over for the answer to my problem, but came up with nothing.

Cheers,
wraith
I just did this for my Ubuntu 8 install and Worked like a Charm!! Thanks so much, took me a while to find the right solution, I totally appreciate it so much, Im totally new to Linux, and already cant wait to spread the word about Linux.
 
Old 07-27-2009, 01:09 AM   #13
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Rep: Reputation: 51
Quote:
Originally Posted by Cess209 View Post
I just did this for my Ubuntu 8 install and Worked like a Charm!! Thanks so much, took me a while to find the right solution, I totally appreciate it so much, Im totally new to Linux, and already cant wait to spread the word about Linux.
~$ asoundconf list
Quote:
Names of available sound cards:
default
default_1
Quote:
asoundconf set-default-card default_1
I tried with root and non root (debian machine)
still cant swap those 2.

not working, because those are 2 usb.

dmesg
Code:
 4.092022] usb 3-2: new full speed USB device using ohci_hcd and address 2
[    4.304535] usb 3-2: New USB device found, idVendor=0556, idProduct=0001
[    4.304538] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    4.304540] usb 3-2: Product: AK5370          
[    4.304542] usb 3-2: Manufacturer: AKM             
[    4.304605] usb 3-2: configuration #1 chosen from 1 choice
[    4.608022] usb 3-4: new full speed USB device using ohci_hcd and address 3
[    4.612547] hdc: host max PIO5 wanted PIO255(auto-tune) selected PIO4
[    4.612644] hdc: UDMA/66 mode selected
[    4.612777] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[    4.627650] ide1 at 0x170-0x177,0x376 on irq 15
[    4.630889] sata_nv 0000:00:0a.0: version 3.5
[    4.631159] ACPI: PCI Interrupt Link [LTID] enabled at IRQ 21
[    4.631163] sata_nv 0000:00:0a.0: PCI INT A -> Link[LTID] -> GSI 21 (level, low) -> IRQ 21
[    4.631195] sata_nv 0000:00:0a.0: setting latency timer to 64
[    4.631249] scsi0 : sata_nv
[    4.631341] scsi1 : sata_nv
[    4.631767] ata1: SATA max UDMA/133 cmd 0xf80 ctl 0xf00 bmdma 0xe000 irq 21
[    4.631770] ata2: SATA max UDMA/133 cmd 0xe80 ctl 0xe00 bmdma 0xe008 irq 21
[    4.817536] usb 3-4: New USB device found, idVendor=0d8c, idProduct=0201
[    4.817540] usb 3-4: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[    4.817542] usb 3-4: Product: PnP Audio Device        
[    4.817607] usb 3-4: configuration #1 chosen from 1 choice
[    5.270300] ide-gd driver 1.18
[    5.270327] hda: max request size: 512KiB
[    5.273628] ide-cd driver 5.00
[    5.273637] hda: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=16383/255/63
[    5.273885] hda: cache flushes supported
[    5.273921]  hda: hda1 hda2 < hda5 hda6 hda7 > hda3
[    5.355428] ide-cd: hdc: ATAPI 48X DVD-ROM DVD-R/RAM CD-R/RW drive, 2048kB Cache
[    5.355434] Uniform CD-ROM driver Revision: 3.20
[    5.942795] PM: Starting manual resume from disk
[    6.001186] kjournald starting.  Commit interval 5 seconds
[    6.001196] EXT3-fs: mounted filesystem with ordered data mode.
[    7.471514] udevd version 125 started
[    7.785678] Linux agpgart interface v0.103
[    7.787944] agpgart-amd64 0000:00:00.0: AGP bridge [10de/00e1]
[    7.787969] agpgart-amd64 0000:00:00.0: aperture size 4096 MB is not right, using settings from NB
[    7.787973] agpgart-amd64 0000:00:00.0: setting up Nforce3 AGP
[    7.803865] agpgart-amd64 0000:00:00.0: AGP aperture is 512M @ 0xc0000000
[    7.913079] i2c-adapter i2c-0: nForce2 SMBus adapter at 0x5000
[    7.913092] i2c-adapter i2c-1: nForce2 SMBus adapter at 0x5040
[    8.003712] processor ACPI_CPU:00: registered as cooling_device0
[    8.003741] processor ACPI_CPU:01: registered as cooling_device1
[    8.013187] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[    8.013193] ACPI: Power Button [PWRF]
[    8.013262] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input3
[    8.013265] ACPI: Power Button [PWRB]
[    8.528985] input: USB Optical Mouse USB Optical Mouse as /devices/pci0000:00/0000:00:02.0/usb1/1-1/1-1:1.0/input/input4
[    8.529043] a4tech 0003:09DA:0006.0001: input,hidraw2: USB HID v1.10 Mouse [USB Optical Mouse USB Optical Mouse] on usb-0000:00:02.0-1/input0
[    8.725870] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    8.758221] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[    8.835133] input: PC Speaker as /devices/platform/pcspkr/input/input5
[    9.005818] k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141
[    9.386503] Linux video capture interface: v2.00
[    9.488877] bttv: driver version 0.9.18 loaded
[    9.488881] bttv: using 8 buffers with 2080k (520 pages) each for capture
[    9.488915] bttv: Bt8xx card found (0).
[    9.489155] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 19
[    9.489164] bttv 0000:02:09.0: PCI INT A -> Link[LNKB] -> GSI 19 (level, low) -> IRQ 19
[    9.489172] bttv0: Bt878 (rev 2) at 0000:02:09.0, irq: 19, latency: 32, mmio: 0xfbffe000
[    9.489197] bttv0: detected: FlyVideo 98 (LR50)/ Chronos Video Shuttle II [card=35], PCI subsystem ID is 1851:1850
[    9.489200] bttv0: using: Lifeview FlyVideo 98 LR50 / Chronos Video Shuttle II [card=35,autodetected]
[    9.489203] IRQ 19/bttv0: IRQF_DISABLED is not guaranteed on shared IRQs
[    9.489237] bttv0: gpio: en=00000000, out=00000000 in=008dff00 [init]
[    9.489284] bttv0: FlyVideo_gpio: unknown tuner type.
[    9.489286] bttv0: FlyVideo Radio=no  RemoteControl=yes Tuner=-1 gpio=0x8dff00
[    9.489289] bttv0: FlyVideo  LR90=no  tda9821/tda9820=no  capture_only=no 
[    9.489291] bttv0: tuner type unset
[    9.489326] bttv0: registered device video0
[    9.489343] bttv0: registered device vbi0
[    9.489359] bttv0: PLL: 28636363 => 35468950 .. ok
[    9.898866] usbcore: registered new interface driver snd-usb-audio
[   11.609948] Adding 289128k swap on /dev/hda7.  Priority:-1 extents:1 across:289
 
Old 07-28-2009, 06:06 AM   #14
rambutan
LQ Newbie
 
Registered: May 2007
Location: Ridgeland, WI USA
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
Quote:
not working, because those are 2 usb.
I don't have a USB sound device but maybe udev rules could help...
http://ubuntuforums.org/showthread.php?t=168221
I use udev rules to define how USB card readers mount.
 
  


Reply

Tags
audio, kubuntu, sound, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Breezy No Sound on Audigy Sound Card rjcmi Ubuntu 14 03-10-2009 11:19 PM
Change default sound card Dankles Debian 2 03-08-2006 09:49 AM
Sound problems with ubuntu 4.1 and a realtek sound card linux-novice Linux - Newbie 1 02-18-2006 11:44 PM
specify default sound card joelescoulie Slackware 2 07-12-2005 03:43 PM
Change default sound card with 2 cards kev Linux - Hardware 5 05-04-2004 09:54 AM


All times are GMT -5. The time now is 10:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration