LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 11-24-2006, 12:50 PM   #1
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Rep: Reputation: 21
How - auto startx, and restart computer


Last night I installed and used Automatix for the first time. It's on a fresh install of Kubuntu Dapper. When finished, I was supposed to reboot. However, the "start" menu had only a logout option, and using it, only logged out back to a fill-screen terminal window - ie, logged out of X.

Not only that, but the first time I did reboot, it didn't auto startx as I had set up to do.

One of my Automatix seelctions was updating KDE, so I'm guessing that's probably the root of the problem.

I've posted to the Automatix Dapper forum, but traffic seems slow, and no replies so far.

Can anybody tell me how to set it up to automatically startx? I also set the convenience option to auto-login, but I think I know how to do that from Dapper.

Also, what do I need to do to get the "turn off computer" and "restart computer" options when I logout?

Thanks!
Optiker
 
Old 11-24-2006, 02:42 PM   #2
statyk
Member
 
Registered: Aug 2003
Location: US
Distribution: Debian
Posts: 77

Rep: Reputation: 15
strange

I've never been asked to reboot after installing automatix so thats a a bit strange to me. Did you intall automatix or automatix2? Also which version of *buntu are you using ... 6.06 or 6.10?
 
Old 11-24-2006, 05:14 PM   #3
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
I am not sure what Automatix...2 I think. The reboot was because of the nVidia component I think.

This is Dapper, 6.06. Tried Edgy on this very old machine and had a ot of trouble. Dapper was fine till I did Automatix.

I wou ldhave guessed that the startup and shutdown would be some settings someplace, or at worst, editing a config file...no?

Still no replies on the Automatix forum...slow day I guess.

Thanks!
Optiker
 
Old 11-25-2006, 02:29 PM   #4
mcmillan
Member
 
Registered: Jul 2005
Distribution: Arch
Posts: 489

Rep: Reputation: 30
Take a look to see if there's a file called /etc/inittab. One of the first lines should read something like id:5:initdefault: If the number is 3 then it will default to the command line, 5 is for graphics.

I'm not totally sure about this, since when I went to look at this in my edgy setup the file wasn't there. I know ubuntu changed some stuff with init scripts which may be why this got changed, so it might be the standard way still in dapper. I do find it bizarre that they would change such a significant configuration file.

I've only seen the missing shutdown and restart options for the menu when I've been logged into the X server from a command line. If you can get it to automatically start in X the options should be back I'd think.
 
Old 11-26-2006, 12:03 PM   #5
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by mcmillan
Take a look to see if there's a file called /etc/inittab. One of the first lines should read something like id:5:initdefault: If the number is 3 then it will default to the command line, 5 is for graphics.

[...]

I've only seen the missing shutdown and restart options for the menu when I've been logged into the X server from a command line. If you can get it to automatically start in X the options should be back I'd think.
Great...even with my limited expertise, I can try that. Will do and report back.

Thanks!
Optiker
 
Old 11-26-2006, 12:21 PM   #6
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by mcmillan
Take a look to see if there's a file called /etc/inittab. One of the first lines should read something like id:5:initdefault: If the number is 3 then it will default to the command line, 5 is for graphics.
OK...It was set to 2, but I've changed to 5. Here's the script as it now stands. I'd appreciate it if you could take a look and see if there's anything else out of line, but in the meantime, I will try to reboot and see what happens.

Thanks!
Optiker

------------------------------------------------
# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.
id:5:initdefault:

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.
si::sysinit:/etc/init.d/rcS

# What to do in single-user mode.
~~:S:wait:/sbin/sulogin

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin

# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

# Action on special keypress (ALT-UpArrow).
#kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let this work."

# What to do when the power fails/returns.
pf:owerwait:/etc/init.d/powerfail start
pn:owerfailnow:/etc/init.d/powerfail now
po:owerokwait:/etc/init.d/powerfail stop

# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
# <id>:<runlevels>:<action>:<process>
#
# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
#
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

# Example how to put a getty on a modem line.
#
#T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS3
-----------------------------------------------
 
Old 11-26-2006, 12:38 PM   #7
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
OK...tried it reset to 5 rather than 2. Still came us as before, in command line mode, but this time, never did compolete X startup. It headed in that direction, but stopped at a blue screen - not the same shade blue as a Windows blue screen!

So, I guess that's not the answer.

See anything alse in the inittab?

In the meantime, Arnieboy on the Automatix forum asked that I post back with the Automatix activity.log, so will try to get at it and do that as well.

Thanks!
Optiker
 
Old 11-26-2006, 03:58 PM   #8
mcmillan
Member
 
Registered: Jul 2005
Distribution: Arch
Posts: 489

Rep: Reputation: 30
I don't see anything obvious in there. One thought was to try setting the run level to 3 and 4 to see what that does, since the comments say all of these are multi-user runlevels. Other than that, I'd also be interested in seeing that automatix log since it seems odd that it would be affecting something like this anyway.
 
Old 11-26-2006, 11:14 PM   #9
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
Still trying to find the Automatix activity.log. He said to enter a line in the CL, but I don't understand the syntax anad don't know where to find the /.Automatix/ directory, so waiting for an answer from him on that.

The last time I tried to boot into it, I got in with the same CL, but this time it didn't hang at the blue screen after startx, but continued to boot into X. So, I am back where I was. Haven't tried 2 or 3 in place of 5 yet in thre inittab, but will, and will post /.Automatix/activity.log when I find it.

Thanks
Optiker
 
Old 11-26-2006, 11:26 PM   #10
mcmillan
Member
 
Registered: Jul 2005
Distribution: Arch
Posts: 489

Rep: Reputation: 30
For the automatix log, I'd guess it's in your home folder, since a file or directory name starting with a period usually (always?) is a hidden file in your home directory.
 
Old 11-27-2006, 09:14 AM   #11
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
OK - will check my home folder when I get home tonight. I tried searching "/" including subdirectories for "/Automix" but zero hits - probably wrong syntax, so not conclusive. Will look tonight.

Thanks!
Optiker
 
Old 11-27-2006, 10:40 PM   #12
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by mcmillan
[...snip...] I'd also be interested in seeing that automatix log since it seems odd that it would be affecting something like this anyway.
Here you go...here's a URL to the activity.log. Hope it's of some use.

http://tinyurl.com/y34fmr

Thanks!
Optiker
 
Old 11-28-2006, 12:40 AM   #13
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,281

Rep: Reputation: 61
Quote:
Originally Posted by Optiker
OK...tried it reset to 5 rather than 2. Still came us as before, in command line mode, but this time, never did compolete X startup. It headed in that direction, but stopped at a blue screen - not the same shade blue as a Windows blue screen!

So, I guess that's not the answer.

See anything alse in the inittab?

In the meantime, Arnieboy on the Automatix forum asked that I post back with the Automatix activity.log, so will try to get at it and do that as well.

Thanks!
Optiker

if the /etc/inittab was set to 2, then it was setup as a single user mode. As stated ealier you need to set it to either 4 or 5. This will depend on what distro it is based on.

If Xserver is failing to start up, it will most likely be to do with your /etc/X11/xorg.conf file. It probably is not setup with the right driver loaded.

look for a section like this:

Code:
# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "nv"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection
Look for the line

Code:
Driver      "nv"
And depending on what card you have in there, you might need to slect a different drive:

for Nvidia:

Code:
Driver      "nv"
For ATi:
Code:
Driver      "ati"

or 

Driver      "radeon"
If all else fails you maybe able to get away with

Code:
Driver      "vesa"

or

Driver      "vga"
 
Old 11-28-2006, 09:08 AM   #14
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
fotoguy...I can check that when I get home tonight. The card is an nVidia, but since part of the Automatix installation was the nVidia driver, I don't understand how it could be wrong - though just because I don't understand it doesn't mean it's not so.

Enjoyed your lawyer anecdote in yoru signature enough to send it to a lawyer friend who collects lawyer jokes.

Thanks!
Optiker
 
Old 11-28-2006, 09:40 AM   #15
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,281

Rep: Reputation: 61
Quote:
Originally Posted by Optiker
fotoguy...I can check that when I get home tonight. The card is an nVidia, but since part of the Automatix installation was the nVidia driver, I don't understand how it could be wrong - though just because I don't understand it doesn't mean it's not so.

Enjoyed your lawyer anecdote in yoru signature enough to send it to a lawyer friend who collects lawyer jokes.

Thanks!
Optiker
With a Nvidia card there is actually to drivers for it, if you use the driver that is built into the kernel you use the:

driver "nv"

If you download and install the driver supplied from the Nvidia site, or most likely the ones that the distro developers supply, it would then be:

driver "nvidia"

I should have mentioned that as well.


Glad you like the joke.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service to auto restart jamiehenderson Linux - Software 3 08-08-2005 02:44 PM
Auto Restart HiJack Fedora 2 07-27-2005 12:38 PM
auto restart service st3reo Linux - Newbie 4 12-07-2004 01:46 PM
unknown Auto restart RJL Linux - General 1 10-11-2004 02:22 AM
Auto-login and auto-restart... TankerKevo Red Hat 2 10-04-2003 08:52 AM


All times are GMT -5. The time now is 07:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration