LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Help using 2 sound cards Ubuntu 10.04 (http://www.linuxquestions.org/questions/ubuntu-63/help-using-2-sound-cards-ubuntu-10-04-a-913716/)

VA3OG 11-15-2011 05:25 PM

Help using 2 sound cards Ubuntu 10.04
 
I have a setup where I am using a PCI sound card, which works fine. I want to use a USB sound card with certain applications, keeping the on board one for "default' type situations - music/system sounds/video, etc.

I have to admit I've always found Linux sound to be a bit of a mystery.

When I open Sound Preferences, I can get either card to work fine. But, whichever card I am controlling then handles all audio. I cannot figure out how to direct some (my Amateur Radio) programs to use the USB card, while everything else uses the PCI card. It seems it is all or nothing.

The answer is probably straightforward, but I haven't come up with a solution after looking through all the threads here and on other Linux sites.

Any help would be appreciated.

VA3OG 11-15-2011 07:24 PM

I should have mentioned that I want both cards to be active at the same time - the on board card handling normal audio, and the USB one handling only certain programs.

widget 11-16-2011 06:00 AM

I am not sure you can have both active and have the OS support it that way. It certainly won't if your bios don't support such a setup. I would start by looking at that and the options there. You will probably need to read the manual for your MB.

orgelman 11-16-2011 07:24 AM

On the Ubuntu forums , section Multimedia & Video there is a very handy guide on how to set things up in Ubuntu the way you want. Just search there for "multiple sound cards" and it should pop up.

Good luck

VA3OG 11-17-2011 11:22 AM

Widget - thanks for the response. Yes, the MB does support the use of both cards at once. In fact, on my Windows side, I can do exactly what I am trying to do under Ubuntu.

Orgelman - Thanks, also. I'll go back and look again there. I wasn't able to find anything before, but I might have missed something. Appreciate your responses.

VA3OG 11-17-2011 06:02 PM

Orgelman - Thanks for pointing me to that section. Everything is working now the way I wanted. I don't know how I missed that section when I was searching before! Doh!
Cheers!

widget 11-17-2011 08:11 PM

Well, I'll be jiggered. That is really neat.

gonzosmoonwomb 12-07-2011 11:19 PM

VA3OG, I'm trying to achieve exactly what you describe - so I went searching for the same solution you found but no luck... can you please let me know how you achieved this?


All times are GMT -5. The time now is 01:46 PM.