LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Help Slackware user try Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/help-slackware-user-try-ubuntu-331765/)

kornerr 06-09-2005 03:12 AM

Help Slackware user try Ubuntu
 
Ubuntu5.04

How to login as "root"? It didn't ask me for root password during installation.
I can only login as "kornerr", so that I can't even mount my Slackware partitions.

It doesn't have kernel sources? So far I found only *.deb packages, which I know nothing of.

What is a Debian package? Does it contain sources? Can I extract 'em?

Thanks.

scuzzman 06-09-2005 03:14 AM

You need to use "sudo" to change the root password:
Code:

sudo passwd

intense 06-09-2005 04:25 AM

I've been using slackware too for a few years and I installed ubuntu couple of weeks ago.
anyway, if you want to you can create a password for root so you can use su.
open a terminal and type:
Code:

sudo passwd
then type the password you want for your root account.

greetz

kornerr 06-09-2005 07:31 AM

Thanks, scuzzman, intense.
Well, to use sudo, I had to enter root password which I didn't know.
And suprisingly it appeared that Ubuntu've set my root password to "kornerr":D

But I'm a bit angry with its "/etc/inittab" where there's only one single user mode to start without GNOME. All multyuser modes seem to start only with X.
Can you tell me how to start multyuser mode without X?

And no one answered yet the question if *.deb packages contain sources. And if I can extract the possible sources.
I want to recompile Ubuntu's standard kernel to fit my needs.

Thanks.

XavierP 06-09-2005 08:36 AM

The sudo command works with your password - I think they did it that way so that you don't need to use Root or it's password.

As far as the kernel goes, you'll need to get (via apt or synaptic) the kernel-sources package and then you should be able to change it as you would in Slackware.

codec 06-09-2005 07:59 PM

take a look of /etc/sudoers
you can see that ubuntu give admin group for root power. You just have to enter your password and that's all.

I am having some weird network problems, so I would also like to enter the "slack" mode to solve the problems. I don't know how to do it yet.

Slackware packages is REALLY easy, Take a look of debian package building:
http://www.ibiblio.org/pub/Linux/doc...ing-HOWTO.html
(Note that it is binary package, I think there are also source package)

kornerr 06-09-2005 10:13 PM

I tried to install nVIDIA drivers and failed. It didn't find find kernel sources.
I don't see 'em in Package Manager. To be honest, Mdk9.2 didn't have kernel sources too.
Ubuntu was free at all, even shipping for free.
Although I find Slackware to be constructed much clearly.
I can turn off "hotplug", "pcmcia", etc with no problem in Slack. Here I'm at a loss.
I haven't seen any reason of using Ubuntu instead of Slackware, sorry.
And I don't like packages at all:) I like sources.

Thanks for help anyway.

codec 06-10-2005 07:21 AM

You can get the nvidia diver from apt. However, it's for the default 386 kernel, if you have fetched the 686 kenrnel. You may need to install the kernel source and nvidia driver manually.

The initial script in ubuntu is more complicated but probably more standard. You may need to take a look or the /etc/init.d.

ubuntu has some problems. in my case, they are.:
1) I have to "adduser cupsys shadow" or else the cups doesn't connect even if the daemon isn't loaded.
2) in one of my client in the local network, it take forever to load because of some mistery of network. have to "ifup eth0" and "ifup lo" manually.
3) nvidia driver only work default kernel and stupid like me take forever to realize it.

I used to fight a lot with things like that in freebsd and slackware so it's ok for me. You can get some answers from ubuntuguide and ubuntuforums. Good luck!

correction in 1) It was because loopback is not configurated

codec 06-10-2005 07:00 PM

I found this article extremely helpful, ubuntu would act really weird without the correct setup of network.

http://www.aboutdebian.com/network.htm


All times are GMT -5. The time now is 06:42 PM.