LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 04-03-2006, 11:56 PM   #1
manishsingh4u
Member
 
Registered: Oct 2005
Location: Pune, India
Distribution: OpenSUSE 11.0
Posts: 422

Rep: Reputation: 30
help me - removed main user account in kubuntu


Hello,
I am using Kubuntu 5.10 (Breezy Badger). I was just playing around with my distro and was having problems login to Gnome with my main user account after I changed some panel settings for it.
I was able to login as root and the other user account to gnome. Anyway I was least bothered about gnome as I could login to KDE and I like it much. Still, my mind was going towards gnome as I don't feel comfortable if there's anything in my OS that has problems. So, I deleted the main user account and created a new one with the same name.
Wow, now I could login to gnome again. But now, there are more problems. No sound, and I couldn't even use sudo. Neither in gnome nowr in KDE.

Code:
sh-3.00$ sudo apt-get update
Password:
sh-3.00$
Can anyone suggest, what I should do to make it work?
 
Old 04-04-2006, 12:13 AM   #2
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
To fix Sudo, add the following line to /etc/sudoers (as root):
Code:
user ALL=(ALL) ALL
Replace user with your user name.

I hope this helps
--Ian
 
Old 04-04-2006, 12:27 AM   #3
manishsingh4u
Member
 
Registered: Oct 2005
Location: Pune, India
Distribution: OpenSUSE 11.0
Posts: 422

Original Poster
Rep: Reputation: 30
thanks

Quote:
Originally Posted by IBall
To fix Sudo, add the following line to /etc/sudoers (as root):
Code:
user ALL=(ALL) ALL
Thanks IBall,
U r a genius. sudo is fixed now.
Now the only visible problem is the sound.
Every time I login now, I am getting this message ->
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (Permission denied)
The sound server will continue, using the null output device.
 
Old 04-04-2006, 12:35 AM   #4
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
I had this problem with the sound before, but I cannot for the life of me remember how to fix it. Try and google it, and see what comes up.

I seem to remember that it had something todo with the permissions of /dev/dsp - try "chmod 666 /dev/dsp" as root, and see if that fixes the problem.

Also, try adding you user to the "audio" group. I think you do something like "adduser user audio" - see man adduser for details.

I hope this helps
--Ian

Last edited by IBall; 04-04-2006 at 12:40 AM.
 
Old 04-04-2006, 12:41 AM   #5
manishsingh4u
Member
 
Registered: Oct 2005
Location: Pune, India
Distribution: OpenSUSE 11.0
Posts: 422

Original Poster
Rep: Reputation: 30
thanks

I finally fixed it.
1) logged in as root.
2) Selected "Users and Groups"
3) Selected my username

There was a list of checkboxes for this users access permissions. One of them was "audio". I checked those boxes as per my requirements.

4) Logged out.
5) Logged in as my user.

And the problem is gone. Thanks for ur help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
system account or user account??? yenonn Linux - Newbie 6 05-10-2006 07:49 PM
is it legitimate and allowed and can be done to make another user account set uid and gid to null 0 to make another root account with different name and possibly not damage the debian system creating and using that new account BenJoBoy Linux - Newbie 12 01-29-2006 10:02 AM
Bringing Mandrake user accounts to Kubuntu Cinematography Linux - Distributions 4 05-21-2005 10:18 AM
My user account mfo6463 Linux - Newbie 9 05-13-2004 05:34 PM
ftp user account? marri Linux - Software 0 05-05-2004 06:45 AM


All times are GMT -5. The time now is 01:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration