LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-01-2008, 01:36 PM   #1
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Rep: Reputation: 15
Help editing fstab to mount hard drives [solved]


trying to mount a few hard drives with editing this fstab file, i did follow the instructions on tuxfiles but cant seem to get anywhere with this. the changes are in bold. do i need to add the UUIDs? where do i find those out? thanks in advance.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=abdf0e72-f64f-4fe3-a203-12d40f1c637e / ext3 defaults,errors=remount-ro 0 1
# /dev/sda5
UUID=391406a0-660a-4c97-a423-d075e4476511 none swap sw 0 0

#start changes
/dev/sdb1 /media/Disk_3 / ntfs defaults,errors=remount-ro 0 1
/dev/sdc1 /media/Disk_4 / ntfs defaults,errors=remount-ro 0 1
/dev/hdd1 /media/Disk_5 / ntfs defaults,errors=remount-ro 0 1
/dev/hdd2 /media/Disk_6 / ntfs defaults,errors=remount-ro 0 1

#end changes

/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0

Last edited by ChootarLaal; 03-08-2008 at 03:43 PM.
 
Old 03-01-2008, 01:46 PM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
For some reason you've added an extra "/" in each of those lines (the one between the mount point and the filesystem type).
 
Old 03-01-2008, 02:04 PM   #3
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
after removing the "/", i do the following

Code:
 sudo mount -a
but it gives the following errors

mount: mount point /media/Disk_3 does not exist
mount: mount point /media/Disk_4 does not exist
mount: mount point /media/Disk_5 does not exist
mount: mount point /media/Disk_6 does not exist
 
Old 03-01-2008, 02:06 PM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
The solution to this is obvious really: create the mount points.
 
Old 03-01-2008, 02:49 PM   #5
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
how do i know which option to use? this is the error msg.


mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mount: wrong fs type, bad option, bad superblock on /dev/hdd2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
 
Old 03-03-2008, 10:36 AM   #6
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
should it not be "ntfs" type? they are drives from a previous xp box but contain nothing but data files.
 
Old 03-03-2008, 10:48 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,063

Rep: Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761
errors=remount-ro is not a valid option for a NTFS file system . See the mount man pages for more information.

Try:
/dev/sdb1 /media/Disk_3 ntfs defaults 0 0


I would use ntfs-3g. You can install it if not already done so via apt-get.

Last edited by michaelk; 03-05-2008 at 07:17 PM.
 
Old 03-04-2008, 10:24 AM   #8
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
looks like im not getting those errors now with michelk's correction but i still cant mount. ill install the ntfs-3g once i figure out how to work the apt-get app, thanks for the help, ill post my results tonite.
 
Old 03-05-2008, 07:19 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,063

Rep: Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761
Is it the same error message?
 
Old 03-05-2008, 07:58 PM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
As a general rule, if these are removable drives, then use the "UUID=" type of device entry. If not using the /dev/sdXN form is fine. The /media directory is for automounted devices. It would be better to use /mnt/ instead.

If these are removable drives, make sure you use the "noauto" option as well. Also you didn't include options like fmask, dmask, uid= and gid=. The "utf8" option is also recommended for ntfs partitions.

Read the "mount" and "mount.ntfs" manpages. It doesn't seem that you have.

Look at the output of "sudo file -s /dev/sdb1" to verify that the filesystem is ntfs.

Make sure your kernel supports ntfs. You may need to modprobe the ntfs kernel module before mounting the partitions.
"lsmod | grep ntfs".

If you do go with "ntfs-3g", then also make sure the "fuse" package is installed and modprobe the fuse module.

When trying to mount a partition, the log in /usr/log/messages may contain more detailed information on what went wrong. Open up another terminal and run "sudo tail -f /var/log/messages" before trying to mount a partition in the first terminal.
 
Old 03-06-2008, 07:03 PM   #11
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
these are NOT removable drives.

this is the output of
Code:
sudo file -s /dev/sdb1
sudo file -s /dev/sdc1
sudo file -s /dev/hdd1
sudo file -s /dev/hdd2
/dev/sdb1: x86 boot sector, code offset 0x52, OEM-ID "NTFS ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 63, dos < 4.0 BootSector (0x80)

/dev/sdc1: x86 boot sector, code offset 0x52, OEM-ID "NTFS ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 63, dos < 4.0 BootSector (0x80)

/dev/hdd1: x86 boot sector, code offset 0x52, OEM-ID "NTFS ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 63, dos < 4.0 BootSector (0x80)

/dev/hdd2: x86 boot sector, code offset 0x52, OEM-ID "NTFS ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 268430085, dos < 4.0 BootSector (0x80)

i will read the man on mount again.

Last edited by ChootarLaal; 03-06-2008 at 07:20 PM.
 
Old 03-06-2008, 07:06 PM   #12
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by michaelk View Post
Is it the same error message?


michael, im not getting any error messages after
Code:
sudo mount -a
but nothing is mounting. i will update the ntfs-3g package, just in the process of doing that currently. ill post if it works or not.

Last edited by ChootarLaal; 03-06-2008 at 07:09 PM.
 
Old 03-06-2008, 07:19 PM   #13
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
here is the result of

Code:
lsmod | grep fuse
fuse 52528 1

Code:
lsmod | grep ntfs
nothing...

Code:
lsmod | grep ntfs-3g
nothing...
 
Old 03-06-2008, 07:24 PM   #14
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,063

Rep: Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761
Did you load the modules? i.e.
modprobe ntfs-3g
 
Old 03-06-2008, 07:28 PM   #15
ChootarLaal
Member
 
Registered: Feb 2008
Posts: 41

Original Poster
Rep: Reputation: 15
ok, for some reason this worked.

Code:
sudo mount -t ntfs-3g /dev/sdc1 /media/Disk_3
what am i doing wrong?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FSTAB Editing to Mount Cruzer Zip Drives MikRose Ubuntu 7 03-03-2009 03:27 AM
new fstab mount option guide for fixed drives - suggestions/mistakes? gregconquest Linux - General 3 04-21-2007 09:55 PM
[mtent] line 7 in /etc/fstab is bad (CD Drives wont Mount) shof515 Linux - Hardware 1 11-24-2005 09:57 AM
How to repair FStab after changin hard drives? Anjin Mandriva 4 03-22-2005 04:04 AM
Editing fstab to mount devices? apachedude Suse/Novell 7 12-03-2004 05:35 AM


All times are GMT -5. The time now is 08:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration