LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 04-08-2007, 10:20 PM   #1
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Rep: Reputation: 30
help! dual boot related, cannot boot windows any more, ubuntu is ok


I have XP and ubuntu 6.10 installed in two separate
SATA drives. I could boot XP and Ubuntu individually
with one of the data/power cables plugged out.
XP has been running on one of the HDs for some time. Ubuntu was installed recently. During installation,
the HD has XP was not powered on. That was because I had problem installing any distro of linux. So I did not want to mess up with XP. Later, I wanted to use dual boot by modifying menu.lst.

title XP
root (hd1,0)
makeactive
chainloader +1

and this is what I got by running fdisk -l:
Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 29654 238195723+ 83 Linux
/dev/sda2 29655 30401 6000277+ 5 Extended
/dev/sda5 29655 30401 6000246 82 Linux swap / Solaris

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 30400 244187968+ 7 HPFS/NTFS

The problem now is that I could not boot XP at all.
I took off the HD containing ubuntu, but still could not boot XP.

So, what am I doing wrong? How to first bring XP back and then modify grub such that I can dual boot my computer? Note, I could not boot this computer by using CD/DVD now since my drive is IDE, have got to
use SATA DVD to boot it. Can read IDE drive though.

Many thanks.
 
Old 04-08-2007, 10:24 PM   #2
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Look at the bottom of the page for a list of threads similar to this one.
 
Old 04-08-2007, 10:32 PM   #3
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Quakeboy02
Look at the bottom of the page for a list of threads similar to this one.
Actually, I have read the following links before
posting my question. But did not find information
directly helping me to at least bring windows back
to work.
 
Old 04-08-2007, 10:42 PM   #4
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Chances are that the best way to do this is to leave ubuntu as your first drive and doze as your second. Have you tried using the following? This assumes that ubuntu is sda and doze is sdb.
Code:
title XP
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1
If this doesn't work, please post the contents of /boot/grub/devices.map. It should look like this. In fact, if it doesn't work, please also post the entire contents of menu.lst, as well.
Code:
(hd0)   /dev/sda
(hd1)   /dev/sdb
 
Old 04-08-2007, 10:58 PM   #5
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Quakeboy02
Chances are that the best way to do this is to leave ubuntu as your first drive and doze as your second. Have you tried using the following? This assumes that ubuntu is sda and doze is sdb.
Code:
title XP
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1
If this doesn't work, please post the contents of /boot/grub/devices.map. It should look like this. In fact, if it doesn't work, please also post the entire contents of menu.lst, as well.
Code:
(hd0)   /dev/sda
(hd1)   /dev/sdb
I believe ubuntu is on my first drive and xp is on
the second. the menu.lst and device.map are exactly
as you suggested. But during boot, I could see doze
was trying to boot, the startup image showed up.
Then the screen went black, the HD had noise for a
little longer but nothing happen eventually.
So my guess is, is it possible that my previous
setup in menu.lst for doze messed up the bootloader
of doze? The reason I guess this way is even I try
to boot doze HD as the only drive, the same thing would happen.
 
Old 04-08-2007, 11:14 PM   #6
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by parv
I believe ubuntu is on my first drive and xp is on
the second. the menu.lst and device.map are exactly
as you suggested. But during boot, I could see doze
was trying to boot, the startup image showed up.
Then the screen went black, the HD had noise for a
little longer but nothing happen eventually.
So my guess is, is it possible that my previous
setup in menu.lst for doze messed up the bootloader
of doze? The reason I guess this way is even I try
to boot doze HD as the only drive, the same thing would happen.
I guess this might be helpful. So I am
attaching the content of boot.ini in doze drive.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
 
Old 04-08-2007, 11:15 PM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Are you using root or rootnoverify? Your post didn't indicate that you were remapping your drives. Are you? Can you please post the exact contents of the files I requested?
 
Old 04-08-2007, 11:23 PM   #8
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Quakeboy02
Are you using root or rootnoverify? Your post didn't indicate that you were remapping your drives. Are you? Can you please post the exact contents of the files I requested?
I tried both root and rootnoverity in fact.

This is the content of device.map
Code:
(hd0)   /dev/sda
(hd1)   /dev/sdb
And this is the content of menu.lst
Code:
default         0

splashimage=(hd0,0)/boot/grub/Ubuntusplash.xpm.gz
timeout         8

hiddenmenu

disable all interactive editing

title           Ubuntu, kernel 2.6.17-11-generic
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.17-11-generic root=/dev/sda1 ro quiet splash
initrd          /boot/initrd.img-2.6.17-11-generic
quiet
savedefault
boot

title           Windows XP
rootnoverify    (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader      +1
 
Old 04-08-2007, 11:30 PM   #9
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Your menu.lst seems awfully sparse. Did you filter out the comment lines "#" before posting, or did you remove them from the file, or are there just none?

Have you tried adding the word "boot" after the chainloader statement?
 
Old 04-08-2007, 11:42 PM   #10
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Quakeboy02
Your menu.lst seems awfully sparse. Did you filter out the comment lines "#" before posting, or did you remove them from the file, or are there just none?

Have you tried adding the word "boot" after the chainloader statement?
This is the entire menu.lst
Code:
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default         0

splashimage=(hd0,0)/boot/grub/Ubuntusplash.xpm.gz
## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout         8

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title         Windows 95/98/NT/2000
# root          (hd0,0)
# makeactive
# chainloader   +1
#
# title         Linux
# root          (hd0,1)
# kernel        /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=f88c0856-22e1-47a6-ba30-6a2d5a77f3ca ro
# kopt_2_6=root=/dev/sda1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title           Ubuntu, kernel 2.6.17-11-generic
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.17-11-generic root=/dev/sda1 ro quiet splash
initrd          /boot/initrd.img-2.6.17-11-generic
quiet
savedefault
boot

title           Ubuntu, kernel 2.6.17-11-generic (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.17-11-generic root=/dev/sda1 ro single
initrd          /boot/initrd.img-2.6.17-11-generic
boot

title           Ubuntu, kernel 2.6.17-10-generic
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.17-10-generic root=/dev/sda1 ro quiet splash
initrd          /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title           Ubuntu, kernel 2.6.17-10-generic (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.17-10-generic root=/dev/sda1 ro single
initrd          /boot/initrd.img-2.6.17-10-generic
boot

title           Ubuntu, memtest86+
root            (hd0,0)
kernel          /boot/memtest86+.bin
quiet
boot

title           Windows XP
rootnoverify    (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader      +1
boot
#

### END DEBIAN AUTOMAGIC KERNELS LIST

Last edited by parv; 04-08-2007 at 11:44 PM.
 
Old 04-09-2007, 12:04 AM   #11
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
About the only thing left is that your windows installation is borked. When you disconnected the ubuntu drive earlier, you did remember to swap the SATA cable on the controller, didn't you?

I can't think of anything else to try. Sorry I couldn't help.
 
Old 04-09-2007, 12:13 AM   #12
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Quakeboy02
About the only thing left is that your windows installation is borked. When you disconnected the ubuntu drive earlier, you did remember to swap the SATA cable on the controller, didn't you?

I can't think of anything else to try. Sorry I couldn't help.
I cannot remember exactly if I swapped the cable right after
disconnecting the ubuntu drive to boot XP. Probably I did that
only after found I could not boot it. Would this be a big problem?
As I said, I indeed can mount sdb1 and see what I have one that drive. If that's the case, do I need to reinstall it or simply
fix doze installation?

Many thanks for all your replies! Have a good night.
 
Old 04-09-2007, 12:29 AM   #13
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
You might try this: Disconnect the ubuntu drive. Move the cable over to the SDA position. Put in your Windows CD and run a repair install after first verifying that windows doesn't boot with the cable switched.

I think I'm headed for bed. It's about 1:30 here and, well I don't have to get up early, but I'd like to read a bit before I head for bed.
 
Old 04-09-2007, 12:31 AM   #14
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Quakeboy02
You might try this: Disconnect the ubuntu drive. Move the cable over to the SDA position. Put in your Windows CD and run a repair install after first verifying that windows doesn't boot with the cable switched.

I think I'm headed for bed. It's about 1:30 here and, well I don't have to get up early, but I'd like to read a bit before I head for bed.
I will try that tomorrow.
Thanks so much. Have a good sleep.
 
Old 04-09-2007, 05:03 PM   #15
parv
Member
 
Registered: Jul 2004
Location: USA
Distribution: Mint, Scientifc Linux, Ubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
problem solved.
turned out that XP was not broke.
Instead, the problem was due to video card.
Installed the latest nvidia driver, set up
bios not to use on-board card and now
everything is OK.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub dual boot ubuntu/windows dellcom1800 Linux - General 1 01-25-2007 06:02 AM
Dual boot Ubuntu-Windows XP vmarian Linux - Software 1 09-13-2006 10:09 AM
Ubuntu/Windows XP dual boot IrishX Ubuntu 2 08-09-2006 09:29 AM
Setting Up a dual boot windows XP and UBuntu Desktop vikpai Linux - General 3 05-22-2006 11:59 PM
How would I dual boot with Ubuntu and WIndows Xp cheetahman Ubuntu 6 07-13-2005 09:05 PM


All times are GMT -5. The time now is 09:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration