LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Hardy won't startup, stops with a "fail" and I have to "ctrl+alt+del" to boot. (http://www.linuxquestions.org/questions/ubuntu-63/hardy-wont-startup-stops-with-a-fail-and-i-have-to-ctrl-alt-del-to-boot-689643/)

brjoon1021 12-10-2008 02:21 PM

startup issue:Mounting local filesystems "fail" - I have to "ctrl+alt+del" to start.
 
*Solved*. This is a known bug with Hardy. The only fix I read about was to let it start and work itself through the holdup no matter how long it takes. Some people waited over 40 minutes. My wait was more like 10 or so. Now it starts perfectly.

8.04 won't start, locks with error message.

*Mounting local filesystems (and the jobs that it seems to be trying to accomplish are):
mount: mount point auto does not exist
mount: mount point <mount point> does not exist
mount: mount point auto does not exist

then it stops there forever with (fail) after these lines and just before *Activating swapfile.
- I am talking about the Linux bootscreen where all of the startup activity is rolling down the screen. I have to strike ctrl+alt+del to get it to complete startup. After I strike ctrl+alt+del I see a message that says:
init: rcs process ... something that suggests it has been canceled
init: rc6 process.... that it has been stopped or canceled as well.
Please help. Even Recovery mode goes the same way. This happened after synaptic update a few days back.


Here is my fstab-

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sdc1
UUID=e1ce3fca-6f34-4653-9483-10a4d2c657e2 / jfs users,relatime,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
# /dev/sda1
UUID=8d4f2d7e-d28c-43f5-9155-324a535cc19b none swap sw 0 0
# /dev/sdb1
UUID=fa2260c0-2012-4f10-b8e6-c78317c8496c none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,utf8,atime,noauto,rw,dev,exec,suid 0 0
/dev/fd0 /media/floppy0 auto user,utf8,atime,noauto,rw,dev,exec,suid 0 0
/dev/sda2/UUE64 /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sda3/cowboy /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sda2/UUE64 /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/mnt auto users,noauto,atime,rw,nodev,noexec,nosuid 0 0
/dev/sda3 <mount\040point> auto nouser,atime,auto,rw,nodev,noexec,nosuid 0 0
/dev/sda7/160 <mount\040point> auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sdb2/MyDocs60 /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sda7/MyDocs160 /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/media auto users,noauto,atime,auto,rw,nodev,noexec,nosuid 0 0
/dev/sda2/UUE64 /media auto users,noauto,atime,auto,rw,nodev,noexec,nosuid 0 0

I am confused by fstab in general, but this looks odd to me - the partition listed as sdc1 is Hardy 32 bit, the very next partition on the disk is Intrepid 64 but it shows up three times in the fstab and it is described as a different disk - sda, not sdc (hardy 32 bit is next to it physically but is described as another disk, hdc). Could that be the problem ?

Thanks,

B

irishbitte 12-10-2008 02:44 PM

Yes, you probably have too many partitions or something. Way too complicated for what I like! I notice you have 2 sets of sda3:

Quote:

/dev/sda3/cowboy /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
and further down:
Quote:

/dev/sda3 <mount\040point> auto nouser,atime,auto,rw,nodev,noexec,nosuid 0 0
These lines do not conform, in my mind, to sensible mounts! I suggest you backup this fstab, then mount only the partitions required for one system, that is the Hardy I presume, by writing a new fstab.

Just to give you an idea, here is my fstab:

Code:

# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda3 :
UUID=4edf45c2-f527-48a4-9d29-33a75a24a544 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda4 :
UUID=a30a1cde-40f5-4d6c-a77b-a64a9bffdb37 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda1 /media/disk ntfs-3g defaults,locale=en_IE.UTF-8 0 0


brjoon1021 12-10-2008 03:36 PM

Thanks for your reply. I am nowhere near able to rewrite or create a new fstab. I did delete the extra lines that referred to the same partition several different times. I still have the same error but two of the lines of error on the splashscreen appear to be resolved.

Now it only says:

*Mounting local filesystems
mount: mount point auto does not exist
...............................................................(fail)


so, if I fixed the other two lines by deleting the extra fstab references, what in my UPDATED fstab copied below should I do to resolve this last error ?

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sdc1
UUID=e1ce3fca-6f34-4653-9483-10a4d2c657e2 / jfs users,relatime,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
# /dev/sda1
UUID=8d4f2d7e-d28c-43f5-9155-324a535cc19b none swap sw 0 0
# /dev/sdb1
UUID=fa2260c0-2012-4f10-b8e6-c78317c8496c none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,utf8,atime,noauto,rw,dev,exec,suid 0 0
/dev/fd0 /media/floppy0 auto user,utf8,atime,noauto,rw,dev,exec,suid 0 0
/dev/sda3/CB /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sda7/160 <mount\040point> auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sdb2/MyDocs60 /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sda7/MyDocs160 /mnt auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/media auto users,noauto,atime,auto,rw,nodev,noexec,nosuid 0 0

***** I want to add that my goal is to have the three Linuxes that I have on one disk to be able to access eachother easily without having to use the command line. I just want to be able to copy files, look at files, etc... Also, over the three hard disks on this computer, I have 3 FAT32 partitions that I use for file storage. I want all of the three OS's (they are all ubuntu variations) to be able to read and write to those FAT32 partitions without me having to open a terminal. I was using a toolbar applet that appeared to work great - it showed a picture of each partition on the computer and gave me the choice to mount or unmount and explore it. Well, a synaptic upgrade fubar'd something and now I have this issue.

Thanks,

b

falcon56215 12-10-2008 03:52 PM

Can you boot from a LiveCD and then take a peek at the fstab to point you in the right direction?

brjoon1021 12-10-2008 04:08 PM

Thanks.

Oh yeah, I have several LiveCD's. Once booted how would that point me in the right direction?

falcon56215 12-10-2008 06:04 PM

Once booted up, you can look at /etc/fstab. A lot of the live distributions will place entries there for existing partitions. Maybe this will give you an idea of what you need in your fstab or will at least give you an idea of what has changed and broken the file.

brjoon1021 12-10-2008 06:39 PM

I think I get you... so you mean that if I can put a live CD in that does exactly what I want - mounts all of my partitions and all are accessible, then, theoretically, I could almost cut and past that fstab in place of the fstabs of the three installed distros, eh ?

falcon56215 12-10-2008 08:46 PM

That's what I was thinking. You may have to make some slight modifications, but at least that will get you started in the right direction. :)

irishbitte 12-11-2008 11:45 AM

I would suggest the same, use a LiveCD, then use a tool like ntfs-config to automatigically create a new fstab for you, with correct mount points and permissions.

BTW, try deleting the last line of your current fstab, then see if it works.

brjoon1021 12-12-2008 12:04 PM

deleting the last line of the fstab removed the last startup screen error related to mounting the partitions. BUT, now I still stop at the very same place?!??! I am wondering if the problem is not with the next task which is "activating swapfile".

Maybe something is wrong with the swapfile or how they are mounted. I have two on two separate disks. They are in the posted fstab, of course.

brjoon1021 12-15-2008 07:29 PM

solved. See my edit to my original post. Ubuntu is weird... had to throw that in. I almost wish something else was the 800 pound gorilla in the Linux world, except Fedora, that is...


All times are GMT -5. The time now is 09:26 PM.