LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-12-2007, 04:28 PM   #1
uncle-c
Member
 
Registered: Oct 2006
Location: The Ether
Distribution: Fedora 14, Ubuntu , Slax 5.1.8, OpenSolaris, Centos 4.8
Posts: 296

Rep: Reputation: 30
Hangup at boot..


Hi,
I'm running Ubuntu Server 7.04 and been having this annoying problem ever since the inital installation. The system boots up fine until the last phase when it reaches Running local boot scripts ( /etc/rc.local) whereupon it just stops. I press enter and the boot process carries on to the login prompt. Now I've checked the rc.local file and it is basically empty with everything commented out except the following on the last line :

Code:
exit 0
I've ran dmesg and do not get any clues. Even deleted "exit 0" from the file but no change.
Any ideas / solutions ??

Thanks again !
Uncle-C

Last edited by uncle-c; 11-12-2007 at 04:29 PM.
 
Old 11-12-2007, 05:53 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
You might see if there are any other Startup scripts that are run at boot. Look at say /etc/rc3.d and rc.5.d and see if there are any files after S99local. Maybe they are the issue. During boot it goes through each runlevel that is needed but not sure on Ubuntu setup. Normally on Redhat type runlevel 3 is multiuser/networking enabled. Where runlevel 5 is multiuser/networking/Xserver. Each one starts in sequence 01 to 99 and aphabetically after the number.

Brian
 
Old 11-13-2007, 03:47 AM   #3
uncle-c
Member
 
Registered: Oct 2006
Location: The Ether
Distribution: Fedora 14, Ubuntu , Slax 5.1.8, OpenSolaris, Centos 4.8
Posts: 296

Original Poster
Rep: Reputation: 30
Thanks Brain. I do not have X installed so am starting at runlevel 3.
I checked the /etc/rc3.d directory and the only file after S99local is S99rmnologin. I renamed S99rmnlogin to D99rmnologin but to now avail.
I think there may be some problems with my startup scripts. I get a Ubuntu login prompt before any of my services start as you can see from the output below :

Code:
* Mounting local filesystems ...
* Activating Swap file ...
* Configuring Network Interfaces ...
* Setting up console font and Keymap ...
* Starting system log daemon ...
Ubuntu 7.04 ubuntu tty1
 
ubuntu login :

* Starting kernel log                           [ok]

* Starting Samba daemons                        [ok]

* Starting OpenBSD Secure Shell Server          [ok]  

* Starting FTP Server : vsftpd                  [ok]  

* Starting the Winbind daemon winbind           [ok]

* Running local boot scripts (/etc/rc.local)    [ok]
Freezes at this point but if I press ENTER I get to my login prompt.

Thanks again,

Uncle.

Last edited by uncle-c; 11-13-2007 at 03:51 AM. Reason: typo
 
Old 11-13-2007, 05:40 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Got no more ideas.

Brian
 
Old 01-26-2008, 01:59 PM   #5
erichwtl
LQ Newbie
 
Registered: Nov 2007
Location: Seattle
Distribution: Ubuntu, 2.6.22
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by uncle-c View Post
Thanks Brain. I do not have X installed so am starting at runlevel 3.
I checked the /etc/rc3.d directory and the only file after S99local is S99rmnologin. I renamed S99rmnlogin to D99rmnologin but to now avail.
I think there may be some problems with my startup scripts. I get a Ubuntu login prompt before any of my services start as you can see from the output below :

Code:
* Mounting local filesystems ...
* Activating Swap file ...
* Configuring Network Interfaces ...
* Setting up console font and Keymap ...
* Starting system log daemon ...
Ubuntu 7.04 ubuntu tty1
 
ubuntu login :

* Starting kernel log                           [ok]

* Starting Samba daemons                        [ok]

* Starting OpenBSD Secure Shell Server          [ok]  

* Starting FTP Server : vsftpd                  [ok]  

* Starting the Winbind daemon winbind           [ok]

* Running local boot scripts (/etc/rc.local)    [ok]
Freezes at this point but if I press ENTER I get to my login prompt.

Thanks again,

Uncle.
Uncle, I have the same problem too. I've tried to do a google search, browse through various linux/ubuntu forums but have to found the answer to this particular problem. Is there anyone else here that may know how to resolve this problem. Thank you in advance.
 
Old 01-30-2008, 10:03 AM   #6
rtcwls
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
I am having the exact same problem

Any help would be greatly appreciated.
 
Old 02-18-2008, 04:35 PM   #7
peppergrower
LQ Newbie
 
Registered: Feb 2008
Distribution: Arch Linux
Posts: 9

Rep: Reputation: 0
I too get a login before many of my services start. It doesn't hang up, per se, but there's no obvious indication that I can enter my user name after the other services run. However, if I just type in my name it will then prompt me for my password and login works like normal. It's just a little annoying. Does anyone know of a fix for this?
 
Old 03-27-2008, 04:40 AM   #8
awalli
LQ Newbie
 
Registered: Mar 2008
Location: Germany
Posts: 2

Rep: Reputation: 0
Lightbulb there is no freeze!

I see the same on my Ubuntu Server 7.10.
In my opinion there is no freeze at all, but the login prompt shows up before all init-scripts are done.
It's cosmetic, but I want to see the login prompt *after* all scripts have finished.
Any ideas?
--
Thomas
 
Old 03-27-2008, 06:46 AM   #9
awalli
LQ Newbie
 
Registered: Mar 2008
Location: Germany
Posts: 2

Rep: Reputation: 0
Thumbs up and now I found the solution

I found the solution at http://forum.wchost.com.hk/viewtopic.php?f=9&t=30

The trick is to start tty1 through an event (Ubuntu uses Upstart) and not by runlevel.

I tried the following and it works!

1. edit /etc/event.d/tty1:

nano /etc/event.d/tty1

Code:
start on runlevel 2
goes to

Code:
# to start at 'the end' of runlevel 2
# use event 'lvl2complete'

#start on runlevel 2
start on lvl2complete
2. create a script in '/etc/rc2.d', call it 'S99zzzlvl2complete' and make it executable:

nano /etc/rc2.d/S99zzzlvl2complete

Code:
#!/bin/bash
initctl -q emit lvl2complete
chmod +x /etc/rc2.d/S99zzzlvl2complete

fortunately there is no risk because we can use tty2 if tty1 does not start
but it does
 
Old 03-28-2008, 01:59 PM   #10
peppergrower
LQ Newbie
 
Registered: Feb 2008
Distribution: Arch Linux
Posts: 9

Rep: Reputation: 0
Oops, I realized I forgot to post the solution I found to this! awalli, thanks for your find as well. When I was looking around for a fix I ran into this thread on the Ubuntu development site, which had a very nice fix. It's worked great for me. All you have to do is change one line in tty1:

Quote:
Originally Posted by Tribaal
I think the most appropriate solution is to delay tt1 only.
This way the boot messages will be displayed in a proper fashion:
- Boot messages
- (All daemons started)
- Show the login prompt

Login via ssh is not affected in any way, and most probably this is how system admins will login to a headless server, so the cosmetic change will only be a change for the better.
In my particular case (I'm building virtual appliances), the cosmetic change makes all the difference in the world in the eyes of my clients (having a tidy login prompt looks more "professional").

I believe the change should be what Dario Berzano suggested:

In /etc/event.d/tty1:
Replace
"start on runlevel 2"
with
"start on stopped rc2"

I think it actually SOLVES the bug, not just works around it: it's the proper way to make sure an upsart daemon starts on the end of rc2.
I really hope this will make it into hardy.

- Trib'
I did this, and it worked perfectly for me. There's even a patch for download at the site I linked to, if you'd rather not do it by hand (though it's quite easy to do so). It looks like this fix may be included in the next version of Ubuntu.
 
Old 04-14-2009, 08:10 PM   #11
markus27183
LQ Newbie
 
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
ubuntu loadup error

I get the same error. Have tried both the fixes above to no avail.
I installed it on a new hard drive on an intel processor and motherboard. Then I transferred it into an AMD machine, then I get this error. It works fine on the intel machine. Could it be a processor/driver error?
 
  


Reply

Tags
boot, scripts, startup, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
boot process hangup marcw Linux - Enterprise 1 09-22-2006 06:32 AM
SELINUX causes new boot to hangup anandt4u Linux - Software 2 06-02-2005 03:56 PM
Boot hangup with Universal Host Controller Interface Driver v2.2 Degei Fedora - Installation 0 08-14-2004 02:32 PM
server hangup wedgeworth Linux - Hardware 3 09-25-2003 04:31 PM
modem hangup swekalle Slackware 4 12-26-2002 06:59 PM


All times are GMT -5. The time now is 08:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration