configure: error: Package requirements (glib-2.0 >= 2.29.14 atk >= 2.1.5 pango >= 1.29.0 cairo >= 1.10.0 cairo-gobject >= 1.10.0 gdk-pixbuf-2.0 >= 2.23.5) were not met:
this is coming from package conf
it is not finding the new versions you installed from source in /opt/GTK3/lib/pkgconfig
it needs to find the *.pc files in that folder
hence the exporting of $PKG_CONFIG_PATH for the non standard location
also with this type of build it is ofter needed to run
---- or if provided ---
after the exports and before "./configure"
that rebuilds the autotool AM macros
but understanding "m4" is a discipline all to is's self
and is one of the reasons i decided a bit back that getting newer versions of glib,"autotools",pkgconfig and alike to build , was just too much work .
Do not get me wrong , it is a very GOOD learning exercise
.And one that most people should learn to do, and do so once or twice .
but it will take a bit of time