gtk+2.0 installation problem(older glib version )
i was trying to install gtk-2.0.i installed the glib,atk,pango,and cairo libraries first.there were some errors but i sorted them out.when i tried ./configure on gtk-2.0,i got:
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.12.0 atk >= 1.9.0 pango >= 1.12.0 cairo >= 1.2.0) were not met.Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
now,i know i have the libraries installed(i did it just now!!).i tried giving PKG_CONFIG_PATH=/usr/lib:/usr/local/lib ./configure
but it did no good.
i then checked synaptics manager to see if gtk+2.0 could be installed using it.but though there were a lot of packages using gtk,there was no gtk package as such.
while checking synaptics i found that i have (strangely)libglib1.2 and libglib2.0-0 both installed on my system.i cant remove libglib1.2(coz it then removes xmms,geda and a lot of other packages that i need).but maybe this is causing ./configure to ignore the newer version of libglib.
being a newbie,i have almost exhausted the whole of my knowledge trying to fix this problem.