LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Grub/Dual boot - Windows partition restored via dd won't boot (http://www.linuxquestions.org/questions/ubuntu-63/grub-dual-boot-windows-partition-restored-via-dd-wont-boot-400283/)

pazzport 01-06-2006 12:37 PM

Grub/Dual boot - Windows partition restored via dd won't boot
 
I am running Ubuntu 5.1 on a dell optiplex GX270. Recently I upgraded the harddrive from the standard 40GB to a 200GB and did the following:

1. Began the Windows XP install process to create a 40 GB partition and completed the first stage of setup so linux would know there is a windows installation
2. Installed Ubuntu on the remainder of the drive
3. Put the old 40GB drive into an external USB drive case and used dd (dd if=/dev/sda2 of=/dev/hda1) to copy it from the USB device to the windows partition (/dev/hda1)

When I reboot and select the windows partion I get the following error:

boot (hd0,0)
Filesystem type unknown partition type 0x7
makeactive
chainloader +1
boot

Since my job requires my PC to be infected with Windows I need to get this up and running. Any suggestions would be greatly appreciated. Thanks in advance.


-- Here is my fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>grub egrub e
proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /media/hda1 ntfs defaults 0 0
/dev/hda3 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

-- Here is my menu from grub:

title Ubuntu, kernel 2.6.12-10-386
root (hd0,1)
kernel /boot/vmlinuz-2.6.12-10-386 root=/dev/hda2 ro quiet splash
initrd /boot/initrd.img-2.6.12-10-386
savedefault
boot

title Ubuntu, kernel 2.6.12-10-386 (recovery mode)
root (hd0,1)
kernel /boot/vmlinuz-2.6.12-10-386 root=/dev/hda2 ro single
initrd /boot/initrd.img-2.6.12-10-386
boot

title Ubuntu, memtest86+
root (hd0,1)
kernel /boot/memtest86+.bin
boot

title Microsoft WindowsXP
rootnoverify (hd0,0)
makeactive
chainloader +1
boot

Flesym 01-06-2006 01:29 PM

Try to switch the addressing method of your drive from 'AUTO' to 'LBA' within your BIOS (if this was set to 'AUTO') Maybe this could help.


All times are GMT -5. The time now is 02:24 AM.