LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 09-29-2007, 04:04 AM   #1
WhiteyDude
LQ Newbie
 
Registered: Feb 2007
Distribution: CentOS, MEPIS
Posts: 19

Rep: Reputation: 0
Unhappy Got the Kubuntu blues... Crashes and drivers and nosound, oh my!


Hi Questioners!


I've recently bought a new PC as I've moved across the country, and have installed Kubuntu Feisty 7.04 on it, via a LiveCD. It's currently dual booting with Vista Ultimate, mainly because my girlfriend wants to use it =/. That aside... I've been having a few issues since I installed Kubuntu a week or so ago.


1) PC will crash randomly. Usually when I'm doing something GPU/CPU intensive (i.e. running WoW under cedega), however sometimes it'll just crash randomly (whilst changing songs on amarok, whilst browsing on firefox...). I'm using a Microsoft keyboard that came with it, and whenever it crashes, the caps lock light starts flashing. Also, the mouse stops responding. I know this isn't much info to go by, but can anyone direct me to some tools that can help me troubleshoot what's causing the problem? And then hopefully I can work out from whatever it tells me what to do, or someone here can point me further the right way with the output :P.


2) NVidia drivers. I have an NVidia GeForce 9600 GT (256MB I think) installed on the PC. As far as I'm aware, I've downloaded the correct drivers for it. I've installed them and they work fine. However, when I reboot the PC X will not start, and when I attempt to use startx, I get an error about incompatibility...

Error: API mismatch: this NVIDIA driver component has version 100.14.19, but the NVIDIA kernel module's version does not match. Please make sure that the kernel module and all NVIDIA driver components have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.



Eep... that took a while to type out =/.

Anyhoot, I can rerun the installer for the NVIDIA drivers I have (NVIDIA-Linux-x86-100.14.19-pkg1.run) and it'll reinstall, rebuild everything, rewrite the X config file, and it'll work a treat... Until I reboot. I wouldn't mind, but because of problem 1 I'm regularly rebooting :P.

N.B. Did also notice just now, that in KInfoCenter->OpenGL->Direct Rendering->Driver->Kernel Module it does say "unknown".


3) A more minor one... But I run WoW under cedega 6.x (not sure which), and it will crash randomly. Not the same crashes as in problem one - just cedega crashing. Has anyone got any tips or tricks with that? Config.WTF settings, cedega settings, different ways of running it, versions that work better, etc? . That'd be really helpful!


Bear in mind, I am a bit of a *NIX noob, however I do know how to use a terminal and I'm happy to try out most things that are suggested (for the right amount of money ).


Specs:



AMD Athlon 64 3500+
A8N-SLI Motherboard
NIVDIA 8600GT PCI-E
1GB RAM (4 x 256MB DDR)
200GB Western Digital HDD
400 watt power supply
Creative SB!Live 5.1 Sound Card and 2.1 Speakers
LG DVD-RW Drive
Dual booting (via grub) Kubuntu Feisty Fawn 7.04/Windows Vista Ultimate
Running:

KDE 3.5.6
X server 11.0
Video Drivers NVIDIA 100.14.19



Relevant outputs:


uname -a
Linux mongrel 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux
dmesg | grep NVIDIA
[ 0.000000] ACPI: DSDT (v001 NVIDIA AWRDACPI 0x00001000 MSFT 0x0100000e) @ 0x00000000
[ 54.377099] nvidia: module license 'NVIDIA' taints kernel.
[ 54.380591] NVRM: loading NVIDIA Linux x86 Kernel Module 1.0-7184 Tue Aug 1 18:38:58 PDT 2006
[ 149.476000] NVRM: loading NVIDIA UNIX x86 Kernel Module 100.14.19 Wed Sep 12 14:12:24 PDT 2007
[ 183.364000] NVRM: loading NVIDIA UNIX x86 Kernel Module 100.14.19 Wed Sep 12 14:12:24 PDT 2007

man women
Segmentation Fault (core dumped)




Thanks guys!



-nfsnobody

Last edited by WhiteyDude; 09-29-2007 at 04:05 AM.
 
Old 09-29-2007, 07:49 AM   #2
angryfirelord
Member
 
Registered: Dec 2005
Posts: 495

Rep: Reputation: 57
Well, I'm not sure why things are randomly crashing, but the reason why the nvidia module is getting reset is because Ubuntu is trying to load one from its linux-restricted package, which is linking to the 9755 driver.

So, type this in:
Code:
kdesu kate /etc/default/linux-restricted-modules-common
Change it so it says:
Code:
DISABLED_MODULES="nvidia"
Now see if it keeps your 3D driver.
 
Old 09-30-2007, 05:17 AM   #3
WhiteyDude
LQ Newbie
 
Registered: Feb 2007
Distribution: CentOS, MEPIS
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by angryfirelord View Post
Well, I'm not sure why things are randomly crashing, but the reason why the nvidia module is getting reset is because Ubuntu is trying to load one from its linux-restricted package, which is linking to the 9755 driver.

So, type this in:
Code:
kdesu kate /etc/default/linux-restricted-modules-common
Change it so it says:
Code:
DISABLED_MODULES="nvidia"
Now see if it keeps your 3D driver.
Thanks for replying angryfirelord .


Tried that, rebooted, same problem


here's my linux-restricted-modules-common file at present:



# This file is sourced from the linux-restricted-modules-common init
# script and is used to disable the link-on-boot feature, one module
# at a time. This can be useful if you want to use hand-compiled
# versions of one or more modules, but keep linux-restricted-modules
# installed on your system, or just to disable modules you don't use
# and speed up your boot process by a second or two.
#
# Use a space-separated list of modules you wish to not have linked
# on boot. The following example shows a (condensed) list of all
# modules shipped in the linux-restricted-modules packages:
#
# DISABLED_MODULES="ath_hal fc fglrx ltm nv"
#
# Note that disabling "fc" disables all fcdsl drivers, "ltm" disables
# ltmodem and ltserial, and "nv" disables both the nvidia drivers.
# You can also name each module individually, if you prefer a subset.

# As per suggestion... http://www.linuxquestions.org/questi...35&postcount=2
DISABLED_MODULES="nvidia"




-nfsnobody
 
Old 09-30-2007, 09:54 AM   #4
angryfirelord
Member
 
Registered: Dec 2005
Posts: 495

Rep: Reputation: 57
Ok, instead of "nvidia", try "nv".

Also, on my Debian system, I had trouble building the module with the latest driver. I used an older one which worked fine. Not sure if it'll make any difference though.
http://www.nvidia.com/object/linux_d...100.14.11.html
 
Old 09-30-2007, 10:41 AM   #5
WhiteyDude
LQ Newbie
 
Registered: Feb 2007
Distribution: CentOS, MEPIS
Posts: 19

Original Poster
Rep: Reputation: 0
Nope, tried both of those seperately, that didn't do it .


I did notice however, that whilst running the NVIDIA driver installer, it asks if I want to connect to the NVIDIA site to download a precompiled kernel. As I use knetworkmanager to manage my wireless network, I'm never online before KDE boots, so I never hit "Yes" on this, I always allow it to compile one itself. Would that make a difference?

Kinfocenter->OpenGL->Direct Rendering->Driver->Kernel module is still "unknown" even after I compile one...


-nfsnobody
 
Old 10-01-2007, 08:33 AM   #6
angryfirelord
Member
 
Registered: Dec 2005
Posts: 495

Rep: Reputation: 57
Nah, connecting to the internet won't help you. I've never come across this "precompiled" thing anyway.

If you've kept your system up-to-date, you may have more than one kernel installed from the security updates. Open up Synaptic, search for linux-restricted, and completely remove (a.k.a. purging) all but the current one. Then, search for linux-image and do that same thing.
 
Old 10-02-2007, 08:05 AM   #7
WhiteyDude
LQ Newbie
 
Registered: Feb 2007
Distribution: CentOS, MEPIS
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by angryfirelord View Post
Nah, connecting to the internet won't help you. I've never come across this "precompiled" thing anyway.

If you've kept your system up-to-date, you may have more than one kernel installed from the security updates. Open up Synaptic, search for linux-restricted, and completely remove (a.k.a. purging) all but the current one. Then, search for linux-image and do that same thing.

Nope . New errors though! Hopefully that helps :P.




dlopen: /usr/lb/libGLcore.so.1: undefined symbol: _nv000043g1
(EE) Failed to load /usr/lib/xorg/modules//libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
(WW) NVIDIA: No matching Device section for instance (BusID PCI:1:0:0) found
(EE) No devices detected.

Fatal server error:
no screens found
X10: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.




Any other ideas guys? . Still got the other problems too :P.




-nfsnobody
 
Old 10-02-2007, 10:28 AM   #8
ssarasin
Member
 
Registered: Jan 2007
Location: South Bend, Indiana
Distribution: Kubuntu 8.04 64bit, 32bit & PPC
Posts: 30

Rep: Reputation: 15
Have you tried the Envy installer yet? It might be worth a look. It will download all dependencies, drivers, etc. and compile/install the drivers for you.

You can find the Envy installer here: http://albertomilone.com/nvidia_scripts1.html

I would read through the info and then give it a shot.
 
Old 10-02-2007, 01:55 PM   #9
cormack
Member
 
Registered: Oct 2005
Location: Scotland, UK
Distribution: Kubuntu 9.10, ubuntu 8.04.2 server
Posts: 156

Rep: Reputation: 30
Envy will install the latest one for you, make sure the current ones are uninstalled 1st tho, and also sudo apt-get install nvidia-glx-new will install the latest nvidia drivers straight from the repositories. I do no a few people that had problems with that tho, but it solved the problem for me, i had exactly the same one you did on my laptop with a 8400. The random crashing may be down to your psu, dont know your exact card but the newest gpu“s need a pretty huge psu to crank them out, so because your comp is dyeing under intense gpu/cpu action this may be it.
Ask the guys at the cedega forums for help there, i expect they may have the answer you are looking for.

ryan
 
Old 10-02-2007, 03:30 PM   #10
angryfirelord
Member
 
Registered: Dec 2005
Posts: 495

Rep: Reputation: 57
Did some digging: http://ubuntuforums.org/showthread.php?t=402185&page=2
Change the link to the current driver you're using. (ex: instead of 9755, it would say 100.14.19 or something like that).
 
  


Reply

Tags
amd, cedega, crash, directx, feisty fawn, geforce, kubuntu, nvidia, power, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help-2.4.33.7+v4l2patch=nosound(sb vibra 16) bmaamba Slackware 5 07-28-2007 09:12 AM
Regular crashes with Kubuntu 6.10 64-bit, need advice pickarooney Linux - Hardware 1 12-23-2006 12:15 PM
Genius Sound Maker 5.1 - Kubuntu Crashes! MomoSempai Linux - Hardware 0 11-19-2006 09:52 PM
quake2 nosound Nille_kungen Linux - Games 1 01-18-2006 07:47 PM
mplayer crashes after awhile in Kubuntu 3.10 tdunne Linux - Software 2 12-14-2005 09:20 PM


All times are GMT -5. The time now is 05:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration