LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-06-2010, 10:43 AM   #1
YetAnotherDave
Member
 
Registered: Feb 2005
Posts: 94

Rep: Reputation: 17
.gnupg directory contents re-appear after deletion ; Ubuntu 9.10


I want to delete my .gnupg directory and everything in it. As soon as I delete the files in this directory, they come back. What could doing this and how do I make it stop?

This is a pretty clean and vanilla "fresh out of the box" 9.10 install.

dave@gobot:~/.gnupg$ ls
pubring.gpg secring.gpg trustdb.gpg
dave@gobot:~/.gnupg$ rm *
dave@gobot:~/.gnupg$ ls
dave@gobot:~/.gnupg$ ls
dave@gobot:~/.gnupg$ ls
pubring.gpg secring.gpg trustdb.gpg
dave@gobot:~/.gnupg$

Thanks to anyone who can shed light on what's going on here.
 
Old 03-06-2010, 11:47 AM   #2
vitorsgoncalves
Member
 
Registered: Mar 2010
Posts: 96

Rep: Reputation: 18
If you want to remove the entire directory, use "rm .gnupg -rf" .
 
0 members found this post helpful.
Old 03-06-2010, 02:07 PM   #3
YetAnotherDave
Member
 
Registered: Feb 2005
Posts: 94

Original Poster
Rep: Reputation: 17
I know how to remove a directory. The problem is that the directory keeps re-appearing after I remove it. What I have been trying to figure out ( so far unsuccessfully ) is: What is recreating these files and how do I disable it?"
 
Old 03-07-2010, 04:08 AM   #4
vitorsgoncalves
Member
 
Registered: Mar 2010
Posts: 96

Rep: Reputation: 18
This is created by the gnupg package (http://www.gnupg.org/)

it is used by various packages like the update-manager, and if you really want to remove it, just uninstall gnupg with synaptic or running sudo apt-get uninstall gnupg in a shell.
 
Old 03-07-2010, 06:59 PM   #5
YetAnotherDave
Member
 
Registered: Feb 2005
Posts: 94

Original Poster
Rep: Reputation: 17
Solved

By trial and error I found out that turning off the "Seahorse Daemon" in the System/Preferences/StartupApplications menu makes this behavior go away.
 
  


Reply

Tags
gnupg, gpg, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deletion of root directory by error sohailkmu Linux - Newbie 1 10-18-2008 02:20 AM
list contents of directory without listing contents baddah Linux - Newbie 2 06-12-2006 04:02 AM
deletion of a recursive directory? captainnico Linux - Software 9 02-04-2006 05:52 AM
gnupg: changing temporary write directory from /tmp to...? mushmaster Linux - Software 0 03-29-2005 07:19 PM


All times are GMT -5. The time now is 04:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration