LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-21-2005, 09:58 PM   #1
eduardo451
LQ Newbie
 
Registered: Mar 2005
Posts: 26

Rep: Reputation: 15
Gnome keeps stealing my desktop from xfce + icewm


I like Gnome, but it is really slow on my older machine (AMD KII 386, 64 MB), so I have installed xfce and icewm. However, whenever I browse files or open a directory, the desktop switches to Gnome, which renders xfce unusable. Also, to get xfce back up, it seems I have to enter 'pkill xfce4-panel' in the terminal, power down the computer, boot back up, log into Gnome, select 'new login' from the menu, and finally log into xfce. The desktop also switches when using IceWM, but is more painless to get back (I just power down, boot back up and log into Ice. From my Googling, it seems that this an issue with Nautilus (though I cannot vouch that this is the real issue), but I have found no real advice on how to fix this. Any suggestions? Would I be best off doing a mini-RAM install without Gnome, or uninstalling Gnome? If so, would I be able to use Synaptic without too much hassle? Thanks!
 
Old 03-21-2005, 10:05 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
it's nautilus. run nautilus and de-select the option in the perferences 'use nautilus to draw desktop" i'm not sure of the exact wording. then log out and back in.
 
Old 03-21-2005, 10:35 PM   #3
eduardo451
LQ Newbie
 
Registered: Mar 2005
Posts: 26

Original Poster
Rep: Reputation: 15
What do you mean by "run Nautilus"? Is it more than selecting Preferences from the Edit menu of a Nautilus shell, because I do not see the option you mentioned there.
 
Old 03-21-2005, 10:48 PM   #4
funkydan2
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: VectorLinux; Ubuntu
Posts: 135

Rep: Reputation: 15
Change the command that is being executed when you click 'Home' or 'File Manager' or whatever.

It should be 'nautilus --no-desktop' rather than just 'nautilus'.

Daniel
 
Old 03-22-2005, 12:19 AM   #5
eduardo451
LQ Newbie
 
Registered: Mar 2005
Posts: 26

Original Poster
Rep: Reputation: 15
Thank you! I was still a little hazy being a newb, but with the input you provided I found the website http://spuriousinterrupt.org/projects/xfce4/index.php Problem solved!
 
Old 03-28-2005, 12:38 PM   #6
Deeze
Member
 
Registered: Dec 2004
Distribution: Debian - Sarge -- Slackware 10.1 - Dropline
Posts: 154

Rep: Reputation: 30
Note that you don't really have to reboot as you were doing, just restart x, which is ctrl-alt-bkspc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome stealing focus, only able to navigate with tab and enter stalefries Ubuntu 2 07-05-2005 02:50 PM
I want icewm as my desktop titanium_geek Slackware 5 06-28-2005 09:48 PM
icewm and xfce themes babyphil Linux - Software 1 06-13-2005 03:11 AM
How to get Icewm as default desktop on SuSE 9.3? n00b_juser Suse/Novell 8 05-23-2005 07:31 PM
xfce desktop is acting like gnome???!!! triet Linux - Software 6 12-06-2004 10:36 AM


All times are GMT -5. The time now is 06:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration