Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 03-19-2005, 05:18 PM   #1
Senior Member
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
freetype failing to load in hoary

Hello all,

I just upgraded warty to hoary via apt-get.

I'm having some problems with recompiling freetype and was curious if anyone else running hoary had the following error in their Xorg.0.log:
(EE) LoadModule: Module freetype does not have a freetypeModuleData data object.
(II) UnloadModule: "freetype"
(II) Unloading /usr/X11R6/lib/modules/fonts/libfreetype.a
(EE) Failed to load module "freetype" (invalid module, 0)
I dual-boot several distros and all of them load freetype by loading, not libfreetype.a, from /usr/X11R6/lib/modules/fonts. Everything worked correctly in warty so I never looked to see how freetype was loaded by X in that release. If anyone wants to look in warty and tell me what is going on there, that would be nice too (of course, it will be XF86Config.log for warty). I'm just looking to see if this is an isolated event due to a bogus upgrade or a common problem with hoary.


Last edited by Franklin; 03-19-2005 at 05:55 PM.
Old 03-20-2005, 04:33 PM   #2
Senior Member
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Well, I decided to download the hoary install iso and try a clean install and everything works fine now.

I guess it was just a frigged upgrade.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
IPtables failing to load: unknown ruleset bureado Linux - Software 3 06-19-2008 10:32 PM Modules Failing to Load on NetBSD Kenji Miyamoto *BSD 0 08-23-2005 07:10 PM
KDE failing to load after x-windows prompt Beeyah Debian 10 10-11-2004 12:14 PM
X can't load freetype - HELP!!!!!!! wackman Linux From Scratch 5 01-18-2003 09:36 PM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 06:14 AM

All times are GMT -5. The time now is 09:35 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration