LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   fluxbox runnint very slowly (http://www.linuxquestions.org/questions/ubuntu-63/fluxbox-runnint-very-slowly-320396/)

curly08 05-05-2005 10:41 AM

fluxbox runnint very slowly
 
For some reason Ubuntu is having major difficulty running fluxbox, and programs inside fluxbox. Any gui's take forever to load (multiple minutes) when I never had this problem before with debian. I found some inforamtion here: http://fluxbox.sourceforge.net/docs/...hp#slowstartup
But i can't seem to find where gdm holds these commands; gdm.conf didn't seem to have the actual exec commands for different xSessions.

Thanks.

curly08 05-05-2005 11:28 AM

I found and changed the gdm file, but it's still slow as hell. Any ideas?

uberNUT69 05-05-2005 10:58 PM

Is this slowness due to heaps of disk activity, or is the
machine thinking about it for too long?

While fluxbox is loading can you still switch to a console
and keep an eye on:
cat /proc/loadavg

curly08 05-06-2005 11:42 PM

It's just thinking too long. Looking at the load average, it never went above .5 for all three values...

uberNUT69 05-07-2005 12:49 AM

Are there any warnings in /var/log/XFree86.0.log?
(you could probably run 'tail -f /var/log/XFree86.0.log' in a separate terminal to keep an eye on what's happening)
Perhaps you could even try keeping an eye on 'ps ax' while.

So there's not a lot of disk activity, the cpu usage is still low (?) ...
must be hanging on something.
Do you have the same problem with other window managers?


errr....
How about the contents of ~/.xsession-errors (in your user's home directory)?

curly08 05-07-2005 01:38 AM

This is the xerrors:

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -
u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "dlux"
/etc/gdm/Xsession: Beginning session setup...
Failed to read: session.titlebar.left
Setting default value
Failed to load groupfile:
apps file failure
BScreen::BScreen: managing screen 0 using visual 0x23, depth 24
Failed to read: session.titlebar.left
Setting default value
Failed to read: session.titlebar.left
Setting default value
Keys: Error on line: 15
> Mod1 e : ExecCommand Eterm -b black -f white --trans --shade 50 --scrollbar fa
lse -x --buttonbar false -g 100x50+15+15
Keys: Error on line: 16
> Mod1 f : ExecCommand firefox

So there are some errors going on. I fixed the key stuff--that was simple. Can someone clue me in as to the other stuff?
Thanks so much!

curly08 05-09-2005 01:01 AM

I just got torsmo working, and it shows on startup that cpu % is 100. So the computer is hanging up on some process. But when I keep an eye on top in another terminal (shift+alt+F2 or whatever), it doesn't show any processes taking up vast amounts of system resources. How do I find out what's going on?

Dead Parrot 05-09-2005 06:28 AM

In terminal window, commands "ps aux", "pstree", and "top" will show you the running processes and their current state.

I suspect that your problem is related either to font settings or network settings, so you should double-check that these are OK. Network settings depend on the type of connection you have (modem, DSL pppoe, or ethernet) but font settings should be easier to troubleshoot. If you've got msttfcorefonts or x-ttcidfont-conf installed, you might want to add the line
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
to /etc/X11/XF86Config-4 . Then do "sudo dpkg-reconfigure libpango1.0-common" and entrust font management to defoma. Then do "sudo dpkg-reconfigure fontconfig" and choose Autohinter. Then reboot to see if things have become any faster in fluxbox. If not, the problem is probably in your network settings.

curly08 05-09-2005 03:40 PM

This is really wierd...I don't have XFree86.conf

. fluxbox sysconfig Xresources xsm
.. fonts X xserver Xwrapper.config
app-defaults gdm xinit Xsession
cursors rgb.txt xkb Xsession.d

What's the deal? And what should I do next?

Dead Parrot 05-09-2005 03:43 PM

Sorry. Ubuntu, of course, uses Xorg so it's /etc/X11/xorg.conf .


All times are GMT -5. The time now is 03:11 AM.