LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 02-01-2007, 01:53 AM   #1
earthmeLon
LQ Newbie
 
Registered: Oct 2006
Distribution: SUSE 10.1(x32)
Posts: 10

Rep: Reputation: 0
Fglrx - dv8000 w. radeon 200M


Ubuntu/Edgy 6.10
HP DV8000

ATI Radeon Xpress 200M
--

I am having a very troublesome time installing FGLRX. I decided to install this because I wanted to install better drivers for my graphics card to play UT (GOTY :]) and I also wanted to try out Beryl.

I've followed many instructions on how to set up FGLRX, but they've all failed. I've tried installing older ATI drivers (a lot of people say that the .24. version is the best to use, but I couldn't get it to create drm files for Edgy) and I've tried the newest version.

With my recent installation of Ubuntu, I was able to do everything that this http://www.ubuntuforums.org/showthread.php?t=321766 guide said to do and when I restarted, it switched to a grey screen where it would normally become the Ubuntu login screen (This happened every time I tried to install FGLRX). This time, instead of just shutting my computer down, I tapped the power button a bunch of times, and then the login screen appeared. I was able to login, and I did:

Code:
meLon@Sleipnir:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series Generic
OpenGL version string: 2.0.6234 (8.32.5)

meLon@Sleipnir:~$ glxinfo | grep direct
direct rendering: Yes
I was really excited, because it seemed that my fglrx or SOME SORT of glx was working.
Well, when I tried to run beryl-manager, I got this error:

Code:
meLon@Sleipnir:~$ Window manager warning: Lost connection to the display ':0.0';
most likely the X server was shut down or you killed/destroyed
the window manager.
XGL Absent, checking for NVIDIA
Nvidia Absent, checking for texture_from_pixmap
texture_from_pixmap Present
beryl: No composite extension
My /etc/X11/xorg.conf displays:

Code:
Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option      "VideoOverlay" "on"
        Option      "OpenGLOverlay" "off"
EndSection
So, my question is:
Does anybody have any clue what is going on?
Is there something else I could do instead to speed up my 3D rendering?



Any help will be greatly appreciated


-meLon
http://neoretro.net



Edit:

I've added some information

Code:
daryl@Sleipnir:~$ sudo dmesg | grep fglrx
[17179599.380000] [fglrx] Maximum main memory to use for locked dma buffers: 928 MBytes.
[17179599.384000] [fglrx] module loaded - fglrx 8.32.5 [Dec 12 2006] on minor 0
[17179601.232000] [fglrx] total      GART = 130023424
[17179601.232000] [fglrx] free       GART = 114032640
[17179601.232000] [fglrx] max single GART = 114032640
[17179601.232000] [fglrx] total      LFB  = 134086656
[17179601.232000] [fglrx] free       LFB  = 115871744
[17179601.232000] [fglrx] max single LFB  = 115871744
[17179601.232000] [fglrx] total      Inv  = 0
[17179601.232000] [fglrx] free       Inv  = 0
[17179601.232000] [fglrx] max single Inv  = 0
[17179601.232000] [fglrx] total      TIM  = 0
/etc/X11/xorg.conf:
http://www.mediafire.com/?8nnyykjzzgn

Last edited by earthmeLon; 02-02-2007 at 12:53 AM.
 
Old 02-05-2007, 01:49 AM   #2
earthmeLon
LQ Newbie
 
Registered: Oct 2006
Distribution: SUSE 10.1(x32)
Posts: 10

Original Poster
Rep: Reputation: 0
I found a newer version of the driver I was trying to use from the ATI site, and after following the same tutorial 3 times, I got it to work. I used the .34. drivers instead of the .33. driver.
 
  


Reply

Tags
ati, beryl, dv8000, fglrx


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 200M fglrx driver How to (Debian Etch) android6011 Linux - Hardware 18 07-28-2007 11:10 AM
Radeon Xpress 200M; TV Out crasslogic Slackware 0 11-14-2006 04:13 AM
Radeon Xpress 200M crasslogic Linux - Hardware 2 11-11-2006 08:24 PM
Issue installing FGLRX for ATI Radeon Xpress 200m under Slackware 10.2 DragonRider Linux - Hardware 1 05-17-2006 01:45 PM
fglrx with radeon xpress 200m on 2.6.15 causes kernel errors when used cwhalen Linux - Hardware 7 01-30-2006 02:50 PM


All times are GMT -5. The time now is 11:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration