LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-03-2008, 05:34 AM   #1
tanveer
Member
 
Registered: Feb 2004
Location: e@rth
Distribution: RHEL-3/4/5,Gloria,opensolaris
Posts: 489

Rep: Reputation: 37
Evolution: prompts password for user account


Hi all,

I have joined an Ubuntu PC in windows 2003 AD. Previuosly, I was having problems in accessing shares of windows file server and evolution but now just stuck on one problem with evolution.
I joined evolution with exchange 2003 and its working.
Now the problem is, after I login with My AD account in Ubunutu and click on evolution it asks for password and after giving it shows the mails. The problem is its asking for the password everytime I open it and I dont want to use "Remember password".

Any idea to resolve this?
Thanks in advance.
 
Old 01-05-2008, 11:08 PM   #2
Caballero del norte
Member
 
Registered: Apr 2007
Location: Sonoran Desert, USA
Distribution: Ubuntu 8.04
Posts: 30

Rep: Reputation: 16
Evolution with Exchange 2003

Now, first of all, that password is to Exchange 2003 (only), right? You also have a (hopefully different) password to get into your account on Ubuntu.

Your Exchange 2003 password gets called for repeatedly because of time-outs on Exchange 2003: a security feature that can be a bother if you are continually (not continuously) accessing Exchange 2003 during an extended Ubuntu session. When you close out of Evolution you will almost surely be re-asked for your Exchange password when you re-open Evolution.

So the problem can perhaps be reframed as:
  1. Would changing the timeouts (or another setting) on Exchange 2003 help you? You'd better have a very friendly SysAdmin if this is what you need.
  2. What is it that prevents you from feeling comfortable storing your Exchange 2003 password into your Evolution user set up?
Sometimes reframing the problem may give a key to its solution.
 
Old 01-06-2008, 12:10 AM   #3
tanveer
Member
 
Registered: Feb 2004
Location: e@rth
Distribution: RHEL-3/4/5,Gloria,opensolaris
Posts: 489

Original Poster
Rep: Reputation: 37
No, that password is for not only Exchange 2003 but also the login password.

As I already told, I joined the Ubuntu PC in our AD. So definitely I login in Ubuntu with the AD username and password not with Ubuntus local account.
So after login I can easily access the windows shares but the problem is when I open evolution, it asks for password that is the same password with which I login i.e., the AD password of the AD account not different.Now If I close evolution and open again then it will ask for password again but not in between.

And, I don't wanna use the remember password option as when the users will change their password they again have to click on the remeber password option and everytime. That will be awkward.

thanks.
 
Old 01-08-2008, 08:33 AM   #4
Caballero del norte
Member
 
Registered: Apr 2007
Location: Sonoran Desert, USA
Distribution: Ubuntu 8.04
Posts: 30

Rep: Reputation: 16
Ugh.

Ugh. I'm thinking it over. I'll get back to you if I find an answer - I suspect that "human engineering" might be the quickest solution.

Good luck.
 
Old 01-08-2008, 08:44 PM   #5
tanveer
Member
 
Registered: Feb 2004
Location: e@rth
Distribution: RHEL-3/4/5,Gloria,opensolaris
Posts: 489

Original Poster
Rep: Reputation: 37
I am using samba+winbind+kerberos+PAM for doing this authentication.
And, I think the solution key lies in the proper configuration of /etc/pam.d directory files like common-auth, common-passwd, etc. Any idea on that.
 
Old 01-21-2008, 07:06 AM   #6
tanveer
Member
 
Registered: Feb 2004
Location: e@rth
Distribution: RHEL-3/4/5,Gloria,opensolaris
Posts: 489

Original Poster
Rep: Reputation: 37
Angry

Below is my configuration files:

PHP Code:
pam.d/common-account
account sufficient      pam_winbind
.so
account required        pam_unix
.so 
PHP Code:
pam.d/common-auth
auth    sufficient      pam_winbind
.so krb5_auth krb5_ccache_type=FILE
auth    sufficient      pam_unix
.so nullok_secure use_first_pass
auth    required        pam_deny
.so 
PHP Code:
pam.d/common-password
password   required   pam_unix
.so nullok obscure md5 
PHP Code:
pam.d/common-session
session required        pam_winbind
.so
session required        pam_unix
.so
session required        pam_mkhomedir
.so umask=0022 skel=/etc/skel 
Now when I login with AD username and passwd its asks for AD password everytime I open evolution. Any help, please.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help to restore my user account in evolution stram Fedora 2 04-20-2007 08:39 AM
maximum password age in a user account mlu Linux - Security 2 04-28-2005 06:35 AM
ftp user account password.... tosszafer Linux - Security 1 10-30-2004 06:05 PM
User account problem (why incorrect password? -- but it is right!!!) namgor Linux - Software 0 07-15-2004 02:17 PM
Forgot my user account password Gilbert Linux - Newbie 1 02-22-2004 11:51 PM


All times are GMT -5. The time now is 10:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration