LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-25-2009, 12:39 PM   #1
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Rep: Reputation: 16
eth0 connects to router but not to Internet(e.g. Google.com)


Hello,

I have been trying to get any sort of networking to run for the past 3 weeks trying every tutorial and how to on the web and these forums to no success. I am trying to get the ethernet to work on my netbook. I am running backtrack 4, not ubuntu, but since backtrack is completely based off of ubuntu now i thought you guys could help I have set up a connection to the router, but that is as far as i get. I can connect to 192.168.1.1 and change the configurations on my router, but when I try google or anything else, i am not connected. Suprisingly I was looking at my ifconfig and i noticed that my eth0 has both ipv4 and ipv6,

Ifconfig eth0
Code:
eth0      Link encap:Ethernet  HWaddr 00:23:8b:d9:e1:b6
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::223:8bff:fed9:e1b6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:964 errors:0 dropped:0 overruns:0 frame:0
          TX packets:766 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:205766 (205.7 KB)  TX bytes:62703 (62.7 KB)
          Interrupt:26 Base address:0x8000
I am not really sure what to try next.

Any help is appreciated,
Thanks
 
Old 07-25-2009, 12:44 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,501

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Can you ping?
Try
Code:
ping 208.69.34.231
If that works, you probably need to add the DNS servers in /etc/resolv.conf.

Code:
nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx
 
Old 07-25-2009, 12:52 PM   #3
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 16
tried pinging google with no success.

About resolv.conf, tried to use cat on it and nothing was in it. Will it still work if i try that?
 
Old 07-25-2009, 12:56 PM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,501

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
So
Quote:
ping 208.69.34.231
doesn't work?
If you can't ping on IP, there is a problem with the configuration of the router or the gateway.
What is the output from
Code:
route -n
(as root)
 
Old 07-25-2009, 12:56 PM   #5
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 16
REPO!!!!!!!!!!

I love you, ha sorry for that just had to get it out!!!!!
It works! thank you sooooooooo mch!!!!
I swear to god, i just fell out of my chair. I love you!
WOW sucess thanks to REPO!!!
 
Old 07-25-2009, 12:58 PM   #6
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 16
I have one more question for you if you have time. How would i go about getting wifi to work if i have a atheros card. Madwifi? or ath5k?

Thank you soooooooooo much
 
Old 07-25-2009, 01:05 PM   #7
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,501

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Did you tried to blacklist, as proposed in this thread?
http://www.linuxquestions.org/questi...8/#post3613865
To blacklist, add the module to
/etc/modprobe.d/blacklist.conf
 
Old 07-25-2009, 01:07 PM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,501

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
For ubuntu, here is a guide
http://hamzakc.wordpress.com/2006/12...-setup-ubuntu/
 
Old 07-25-2009, 01:10 PM   #9
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 16
Well i think it actualy might be a little easier then that. In iwconfig, i already have wlan0 so isnt there just some code like the ethernet to type in to get it working now? or do i have to do all of the blacklisting?
 
Old 07-25-2009, 01:15 PM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,501

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Try to install wicd
To install WICD do the following: (for gutsy, edgy, or dapper replace feisty as needed)
as root:
Code:
echo 'deb http://apt.wicd.net feisty extras' | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install wicd
 
Old 07-25-2009, 01:24 PM   #11
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 16
http://apt.wicid.net/dists/feisty/ex...86/packages.gz gave me a error 302 temporarily moved.
Failed to download?

Why?

Thankyou so much
 
Old 07-25-2009, 01:31 PM   #12
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,501

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Seems to me the archive doesn't exist anymore
Try to download and install manually
open a terminal
type
Code:
wget http://mirrors.kernel.org/ubuntu/poo....5.9-2_all.deb
sudo dpkg -i wicd_1.5.9-2_all.deb
You can remove the line you added to /etc/apt/sources.list
 
Old 07-25-2009, 01:38 PM   #13
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 16
Who ever you are i now idolize you. It worked and my network showed up. Tried to connect and it says required encryption enabled. How would i go about enabling it.

How did you learn all of this? You are very skilled, have you written a guide to linux? WOuld you consider writing one for me? haa.
 
Old 07-25-2009, 01:42 PM   #14
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,501

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Click on the network you want to connect to.
Then click on properties.
Use encryption, choose the encryption you setup on the access point or wireless router, and give the key
 
Old 07-25-2009, 01:46 PM   #15
MadHatter21
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 16
I am now completely on line, what took me 21 days took you an hour. Thank you so much, I was serious about the tutorial though, where did you learn or do you teach, Once again thank you for everything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Realtek8180l card. Connects to router but cannot surf internet The_Sicilian Linux - Hardware 1 12-04-2007 10:58 PM
Wifi card connects to router, but not internet Mbaum Linux - Hardware 7 01-19-2006 03:39 PM
DWL-122 only connects to router not to internet Telluris Linux - Wireless Networking 2 01-11-2006 04:05 PM
Connects to router, but no internet Lee_B_H Linux - Wireless Networking 4 01-08-2005 08:54 PM
weird...wireless connects to router but not internet apu95 Linux - Wireless Networking 4 04-24-2004 10:24 PM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration