LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-05-2007, 07:34 PM   #1
Brian5
Member
 
Registered: Dec 2006
Posts: 34

Rep: Reputation: 15
Error message with RPM, running alien on ubuntu


Hello,

I just installed alien on my computer, ubuntu 6.10.

I’m having a little trouble using this one rpm, though it is my first time trying to use an rpm with alien. When I type: ’sudo alien -i kdelibs-3.3.1-1.i686.rpm.’

I get this error:

’sh: rpm: not found
Error executing “LANG=C rpm -qp –queryformat %{SUMMARY} kdelibs-3.3.1-1.i686.rpm”: at /usr/local/share/perl/5.8.8/Alien/Package.pm line 481′

What can I do to resolve this?

Thanks!
 
Old 01-06-2007, 12:24 PM   #2
exit3219
Member
 
Registered: May 2005
Location: Moldova
Distribution: Kubuntu
Posts: 199

Rep: Reputation: 30
Looks like you don't have rpm installed. sudo aptitude install rpm to install it.
Might I ask why are you trying to install KDE 3.3 from rpms? Why not install the latest KDE 3.5.5 from the Ubuntu repositories?
 
Old 01-06-2007, 04:35 PM   #3
Brian5
Member
 
Registered: Dec 2006
Posts: 34

Original Poster
Rep: Reputation: 15
I'm installing kdelibs 3.3 because its one of the dependencies of a program I'm installing, amarok. Do you think I should/could install 3.5 and still have amarok work?
 
Old 01-10-2007, 04:41 AM   #4
frrossk
Member
 
Registered: Feb 2005
Location: UK
Distribution: Debian jessie
Posts: 33

Rep: Reputation: 16
I'm sure you can - start synaptic, select amarok and it will install every dependecy it needs.
 
Old 01-10-2007, 07:07 AM   #5
IndyGunFreak
Senior Member
 
Registered: Aug 2003
Location: Indpls
Distribution: Desktop- Debian Lenny, Laptops- Ubuntu 8.10, Debian Lenny UMPC- Ubuntu 8.10
Posts: 1,297

Rep: Reputation: 55
Quote:
Originally Posted by Brian5
I'm installing kdelibs 3.3 because its one of the dependencies of a program I'm installing, amarok. Do you think I should/could install 3.5 and still have amarok work?
There's no need to use Alien to install amarok. Very rarely is it necessary to use alien for much of anything.

If you read my post in your other thread, I told you exactly what frosssk did, it will be much easier to use Synaptic.

IGF
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running an RPM package in Kubuntu with ALIEN!!! maverick_awp Linux - Newbie 2 11-21-2006 11:36 AM
how do i use Alien on ubuntu 5.04? kriogenic Linux - Newbie 5 02-15-2006 08:07 PM
Using alien or using RPM?? R00ts Debian 4 07-26-2004 05:48 PM
RPM error message mikeshn Linux - General 3 12-02-2003 12:13 PM
RPM error message. What gives? gomer1701ems Linux - Software 1 06-13-2001 09:53 AM


All times are GMT -5. The time now is 11:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration