LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-03-2011, 10:08 AM   #1
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Rep: Reputation: Disabled
Unhappy edit Xorg.conf in Kubuntu 11.10


Okay..so I've posted a similar question before but the situation is a little different now. I'm running Kubuntu 11.10 and I can't get KDE to save my default display resolution once I've changed it in K.

I'm running an older IBM Thinkpad T30 and my ATI Radeon Mobility 7500 is no longer supported by the proprietary ATI linux driver (so I left it to the default driver..did not try installing ATI one).

I've done a little reading up and I know by default Oneiric Ocelot (11.10) does not have an Xorg.conf file but I can't figure out how to generate one. Or where to copy it to.

Any suggestions? Thanks

P.S. I promise to backup my xorg next time
 
Old 11-04-2011, 02:02 AM   #2
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
See this to generate an xorg.conf file for K/Ubuntu: http://askubuntu.com/questions/4662/...figure-x-there
You can then edit the xorg.conf to your needs.
You can also try using xrandr: https://wiki.ubuntu.com/X/Config/Resolution
You can also try looking into and editing the files located in /etc/X11/xorg.conf.d/. The newer versions of Xorg use those files as well.
I know that this seems more complicated than it used to be when you just had to know about the xorg.conf file. Things are supposed to work automatically nowadays. However, things get more complicated when automatic configuration fails.
 
Old 11-12-2011, 10:36 AM   #3
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Original Poster
Rep: Reputation: Disabled
Unhappy

after booting into recovery mode and running 'X -configure'

I attempt to copy the configuration file using 'cp /root/xorg.conf.new'
to '/usr/share/X11/xorg.conf.d/'

and I receive the error..

'could not create lock file in /tmp/.tX0 -lock'

any advice?
 
Old 11-12-2011, 02:24 PM   #4
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,248

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by starsage77 View Post
after booting into recovery mode and running 'X -configure'

I attempt to copy the configuration file using 'cp /root/xorg.conf.new'
to '/usr/share/X11/xorg.conf.d/'

and I receive the error..

'could not create lock file in /tmp/.tX0 -lock'

any advice?
Were you doing this as root?
 
Old 11-12-2011, 02:42 PM   #5
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Original Poster
Rep: Reputation: Disabled
Unhappy

if I'm in recovery mode do I need to specify root (via 'sudo') or is this the default?
 
Old 11-13-2011, 09:57 AM   #6
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by starsage77 View Post
if I'm in recovery mode do I need to specify root (via 'sudo') or is this the default?
When you boot into recovery mode and drop to the root shell you are root. Therefore you do not need to use sudo.

In my last post I suggested looking at the files in the /etc/X11/xorg.conf.d/ directory. However, on my
Lubuntu 11.10 system I do not even have a /xorg.conf.d/ directory in the /etc/X11/ directory. It seems that this directory is no longer used as far as I can see. I assume this is also true on Kubuntu and Ubuntu as well as on my Lubuntu.
As I suggested in my last post, you can also try using xrandr to set the proper resolution: https://wiki.ubuntu.com/X/Config/Resolution

I am not very familiar with the KDE desktop. There must be some settings that you can adjust in KDE to set the proper resolution. How exactly have you tried setting the proper resolution on Kubuntu 11.10?

Last edited by tommcd; 11-13-2011 at 10:02 AM.
 
Old 11-13-2011, 10:04 AM   #7
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Original Poster
Rep: Reputation: Disabled
Unhappy

it's not a matter of setting my desktop resolution during my session in K
it's a matter of trying to get K to store this new resolution as my default
for each and every subsequent session.

there is an option within the control panel to save as default but this is
just a ruse as the display reverts to maximum resolution on the next session

if this were the old days I could boot as root but Ubuntu won't allow this
 
Old 11-13-2011, 10:20 AM   #8
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by starsage77 View Post
it's not a matter of setting my desktop resolution during my session in K
it's a matter of trying to get K to store this new resolution as my default
for each and every subsequent session.
there is an option within the control panel to save as default but this is
just a ruse as the display reverts to maximum resolution on the next session
This is the problem with all of this automatic (i.e., no xorg.conf needed) configuration. When it works, as it usually does with most graphics cards, it is great. However, when it does not work it can be difficult to override the automatic configuration to set things up the way you want them.

Have you managed to create an xorg.conf file while in recovery mode at all?
If you are still having trouble doing this, try booting to recovery mode and run X -configure. Then reboot to the desktop and run:
Code:
sudo cp /root/xorg.conf.new /etc/X11/xorg.conf
to copy the new xorg.conf to the /etc/X11/ directory. Then edit the xorg.conf file to your needs. Then reboot into (hopefully) your desired resolution.
If you have a known good xorg.conf file saved somewhere from a previous Ubuntu install, you could just use that and it would likely work. Or if you can find one on the internet somewhere, just use that and edit it to your needs.
Have you tried using xrandr as in the tutorial that I linked to? I'm not sure what else I can suggest.

Last edited by tommcd; 11-13-2011 at 10:21 AM.
 
Old 11-13-2011, 11:56 AM   #9
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Original Poster
Rep: Reputation: Disabled
Unhappy

tried running those commands in recovery mode and still received the same error:

'could not create lock file in /tmp/.tX0-lock ddxSigGiveUp: Closing Log'

I'm afraid I'm not that familiar with Xrandr. Will this help to set my default
resolution for each session?
 
Old 11-13-2011, 02:06 PM   #10
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,248

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
That is a strange error to be getting.

Try just booting normally and when you get to the login screen, no matter what it looks like, hit Ctrl+Alt+F2. This should give you a tty login prompt. Log in. Run;
Code:
sudo su
This will give you the same root prompt but maybe (not likely) with different results.

Try this before anything else;
Code:
apt-get update
if that works try;
Code:
apt-get upgrade
if those both work try the your other command.

If not try;
[code]
dpkg-reconfigure -a
[code]
Might help.
 
Old 11-13-2011, 03:08 PM   #11
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Original Poster
Rep: Reputation: Disabled
Unhappy

this isn't going to change my grub menu or anything will it?

the last time I altered my grub config I ended up not being
able to boot to the desktop and didn't know enough command
line to rebuild my grub
 
Old 11-13-2011, 05:23 PM   #12
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,248

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
If any of that effects the grub menu in anyway you have some very large problems indeed.

There is no mention of "update-grub" (a harmless command), "grub-install /dev/sdx" which could cause problems if you don't know the address of your drive. Nope, I don't think it will bother grub.

dpkg-reconfigure -a should make sure that the basic system is within the default rules for that system as seen by the package management tools. Basically are they installed right and some basic configuration.

It is just one of the dpkg commands that I use on package management problems. I like to run it early to see if it works. It has fixed things I didn't think it should. Unfortunately I doubt it will here but it will not hurt any thing.
 
Old 11-16-2011, 05:58 PM   #13
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Original Poster
Rep: Reputation: Disabled
Okay.. so I ran 'apt-get update' and 'apt-get upgrade' the system located and installed updates. I successfully rebooted, went into recovery mode and went through the same process as before and still got the same error..

'could not create lock file in /tmp/.tX0-lock'
 
Old 11-17-2011, 07:45 AM   #14
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, FreeBSD
Posts: 1,329

Rep: Reputation: Disabled
Quote:
Originally Posted by starsage77 View Post
and I receive the error..

'could not create lock file in /tmp/.tX0 -lock'

any advice?
That error message won't appear when you copy files. It can appear when you try to do something silly like startx as root or when there is an .Xauthority problem.

First boot the system normally, then CTRL+ALT+F1, login as your normal user and then do

Code:
sudo invoke-rc.d gdm3 stop
Next WITHOUT root privileges (e.g. no su or sudo)

Code:
rm -rf ~/.Xauth*
To get rid of any stale .Xauthority files.

Then copy your xorg.conf to the correct location as instructed above and then

Code:
sudo invoke-rc.d gdm3 start
Login, what happens - if there are errors post the full details of the error(s).

Last edited by cynwulf; 11-17-2011 at 07:48 AM.
 
Old 11-22-2011, 05:09 PM   #15
starsage77
Member
 
Registered: Sep 2011
Location: Palmyra, NY
Distribution: Kubuntu 14.04
Posts: 59

Original Poster
Rep: Reputation: Disabled
tried 'sudo invoke-rc.d gdm3 stop'

received the error: 'unknown initscript. /etc/init.d/gdm3 not found'
 
  


Reply

Tags
xorg.conf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't edit Xorg.conf Jimbo13 Linux - Newbie 3 04-29-2008 06:49 AM
edit xorg.conf using nano olracdor Linux - Newbie 3 11-21-2007 06:03 AM
Cannot edit xorg.conf Ahner Slackware 6 09-07-2006 12:44 AM
Can't edit Xorg.conf pautasso Linux - Newbie 3 08-14-2004 09:27 AM
xorg.conf > how to edit ? visvent Linux - Software 3 06-07-2004 01:14 PM


All times are GMT -5. The time now is 09:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration