LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Dual Boot Hardy and Slackware - how to set up Legacy grub? (http://www.linuxquestions.org/questions/ubuntu-63/dual-boot-hardy-and-slackware-how-to-set-up-legacy-grub-812245/)

ahzthecat 06-04-2010 10:55 PM

Dual Boot Hardy and Slackware - how to set up Legacy grub?
 
I`m running 8.04 Hardy on an older desktop pc. Works great, but I`ve been itching to get into Slackware as well, so I made a small partition for slack to live in and installed.
Slack uses the Lilo bootloader, and when it came time to install Lilo, the installer detected Ubuntu`s Legacy grub, and installed a grub-friendly lilo.
I poked around in the grub menu.lst to see what needed to be changed to get it to see slack. Also checked the forums here and at Ubuntu, but couldn`t find information on my particular problem.

The question is, how do I get grub to see and boot my slackware partition?

THanks for any light anyone can shed on this issue!

syg00 06-05-2010 12:29 AM

Quote:

Originally Posted by ahzthecat (Post 3992992)
Slack uses the Lilo bootloader, and when it came time to install Lilo, the installer detected Ubuntu`s Legacy grub, and installed a grub-friendly lilo.

:scratch: Explain please - what do you mean ?.
Given you apparently didn't over-write the MBR (else Hardy wouldn't be booting), you presumably installed lilo to the (boot sector of the) root partition. You can simply chainload to that partition, and will be presented with the lilo menu.

ahzthecat 06-05-2010 01:33 AM

I can`t remember the exact dialog from the slack installer, but seems like that sort of idea. How do I chainload? From my grub menu now all I get as options are ubuntu kernels. How do I get to the point that I can initialize Lilo and boot slack? I`ve never tried to configure or alter bootloaders before, so I`m a little lost...

ahzthecat 06-07-2010 09:01 PM

Found this link in another thread. I`m going to try this when I get a chance, and let folks know how things turn out.
http://www.justlinux.com/forum/showthread.php?t=143973

ahzthecat 06-07-2010 09:06 PM

This thread, also helpful. http://www.linuxquestions.org/questi...ioning-811471/

Just goes to show I should do a bit more research before asking questions. Sorry!

**edit** This link has lots of good information about setting up grub and grub in general. http://www.justlinux.com/forum/showt...282#post861282 Fascinating.**edit**

ahzthecat 06-08-2010 03:43 AM

Perseverance pays off! Turns out what I had done was to instruct Slackware to install Lilo to the Slack partition, thus all I had to do to get it to boot was add the chainloader instructions to my menu.lst file! Easy Easy!

Here is what I added...

Title Slackware 13.1 @sda3
root (hd0,2)
chainloader +1

Now Slackware appears as an option in my grub menu, selecting it starts Lilo, which boots Slack! Posting from my new Slack install! Did I use enough exclamation points????!!!! Still learning my way around these forums, I guess. All I had to do was look....;-)


All times are GMT -5. The time now is 01:07 PM.