LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 12-22-2005, 08:33 AM   #1
lukeprog
Member
 
Registered: Oct 2005
Posts: 92

Rep: Reputation: 15
Disable Ctrl+Alt+Fn


I'm trying to disable virtual terminal switching in my Ubuntu install. I tried adding the following to xorg.conf (not both at the same time, obviously):

Section "Serverflags"
Option "DontVTSwitch" "yes"
EndSection

Section "Serverflags"
Option "DontVTSwitch" "true"
EndSection

Neither of them worked; I could still switch with Ctrl+Alt+F1, etc. How do I disable terminal switching in Ubuntu?
 
Old 12-22-2005, 08:41 AM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Do you already have another Serverflags section in your xorg.conf? If so, you might need to add it there. Did you restart X after each attempt to make sure the config-file was re-read? Did it give any warnings (WW) that might've indicated that there was an error with the config file?
 
Old 12-22-2005, 10:54 AM   #3
lukeprog
Member
 
Registered: Oct 2005
Posts: 92

Original Poster
Rep: Reputation: 15
There was no other "Serverflags" section already existing. I restarted X each time so xorg.conf was re-read. When I tried the first one, nothing unusual happened, except that I was still able to switch virtual terminals as usual. When I tried the second, X wouldn't come up at all until I deleted those lines from xorg.conf with vi.

What is WW?
 
Old 12-22-2005, 11:08 AM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
(WW) is the code X inserts in front of lines containing warnings in its logs. (EE) is the code for errors. Ordinarily, X.org will create a file like /var/log/Xorg.0.log with information about its startup procedure. You could check in there to see if it said anything about that option.
 
Old 12-22-2005, 02:25 PM   #5
lukeprog
Member
 
Registered: Oct 2005
Posts: 92

Original Poster
Rep: Reputation: 15
Nope, no mention of "serverflags" at all in that file.

Has anyone ever disabled the virtual terminal switching in Ubuntu? Or in Debian, perhaps?
 
Old 12-22-2005, 02:30 PM   #6
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
I've found that apparently all you should need is:
Code:
Section "Serverflags"
Option "DontVTSwitch"
EndSection
Give that a try and see if it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change KDE default Ctrl+Alt+K for changing language into Alt+Shift sepetar Linux - General 9 01-04-2006 06:06 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
How To Disable CTRL-ALT-F1 beajedi Linux - Security 6 12-23-2004 11:07 PM
How to disable Ctrl and Alt keys? (and maybe sysrq) bigperk420 Slackware 13 12-07-2004 05:53 PM
Disable CTRL-ALT-DEL dog606 Red Hat 2 04-19-2004 01:25 PM


All times are GMT -5. The time now is 11:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration