LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-04-2005, 06:39 PM   #1
tunasashimi
Member
 
Registered: Jun 2005
Posts: 82

Rep: Reputation: 15
Unhappy /dev/hda4 already mounted or z busy


Latest ubuntu live cd won't mount my Suse 9.1 reiserfs disk, any ideas why?

No, it is not mounted already
No, z where I am trying to mount it is not busy (same for everywhere)

PLEASE HELP!!!
 
Old 07-04-2005, 10:24 PM   #2
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Quote:
No, z where I am trying to mount it is not busy (same for everywhere)

How are you mounting it?

Which commands are you using?

Give some details.
 
Old 07-05-2005, 02:28 AM   #3
tunasashimi
Member
 
Registered: Jun 2005
Posts: 82

Original Poster
Rep: Reputation: 15
mount /dev/hda4 /mnt/z

says its busy

not in mtab
or fstab
and doesnt show up when you type "mount"

mount -f puts it in mtab but its unreadable

mount -v shows "trying reiserfs"

mount /dev/hda4 /mnt/z -t reiserfs -o ro

Useless...

Linux can be so annoying sometimes

HOW about MORE details, like "Invalid filesystem" or Something other than SHIT like
"hdb4 is busy" BAUUHH

I am root, btw.

bozooka
=========== o - o> - - o>
)/
 
Old 07-05-2005, 02:31 AM   #4
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Code:
mount -a
should tell you if there are any bad lines in fstab.
 
Old 07-05-2005, 02:37 AM   #5
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Try this as well.

Code:
sudo /etc/init.d/dbus-1 restart
 
Old 07-05-2005, 02:52 AM   #6
tunasashimi
Member
 
Registered: Jun 2005
Posts: 82

Original Poster
Rep: Reputation: 15
Red face

root@ubuntu:/mnt # ls -l x
total 0

root@ubuntu:/mnt # l
total 1
drwxr-xr-x 2 root root 1024 2005-07-05 07:44 x

root@ubuntu:/mnt # /etc/init.d/dbus-1 restart
* Stopping Hardware abstraction layer: [ ok ]
* Stopping system message bus: [ ok ]
* Starting system message bus: [ ok ]
* Starting Hardware abstraction layer: [ ok ]

root@ubuntu:/mnt # mount /dev/hda4 x
mount: /dev/hda4 already mounted or x busy

root@ubuntu:/mnt # mount
/dev/mapper/casper-snapshot on / type auto (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
/dev on /.dev type unknown (rw,bind)
none on /dev type tmpfs (rw,size=5M,mode=0755)

root@ubuntu:/mnt # fdisk /dev/hda
Command (m for help): p

Disk /dev/hda: 80.0 GB, 80026361856 bytes
16 heads, 63 sectors/track, 155061 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 131 65992+ 83 Linux
/dev/hda2 * 132 262 66024 83 Linux
/dev/hda3 263 783 262584 82 Linux swap
/dev/hda4 784 155061 77756112 83 Linux

Command (m for help): q

root@ubuntu:/mnt # **PULL HAIR FROM HEAD***

PS hda1 and hda2 are ext2 and mount just fine

Last edited by tunasashimi; 07-05-2005 at 02:54 AM.
 
Old 07-05-2005, 06:43 AM   #7
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Let some expert help you. I won't interfere anymore.
I can't deal properly with frustrated people.
 
Old 07-05-2005, 06:09 PM   #8
ubuntu
LQ Newbie
 
Registered: Jul 2005
Posts: 9

Rep: Reputation: 0
Thanks for trying... Hmmm.. interesting reply. I still havent figured it out.
 
Old 07-12-2005, 08:00 AM   #9
StianLangvann
LQ Newbie
 
Registered: Jun 2005
Posts: 10

Rep: Reputation: 0
http://www.linuxquestions.org/questi...t=ubuntu+mount
The exactly same problem
Anyways. Try to strace the problem
(strace mount /dev/hda4) - and put it here or some other place.

Last edited by StianLangvann; 07-12-2005 at 08:02 AM.
 
Old 07-14-2005, 09:00 AM   #10
Waerner
Member
 
Registered: May 2005
Location: Írebro, Sweden
Distribution: Ubuntu 6.06
Posts: 92

Rep: Reputation: 15
Are you sure it ain't mounted already? I know that my old Mandrake-distro mounted everything into /mnt/, but my Ubuntu-distro mounted my NTFS-disks into the /media/-folder...
 
Old 07-20-2005, 08:28 PM   #11
viza
LQ Newbie
 
Registered: Jul 2005
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by Waerner
Are you sure it ain't mounted already? I know that my old Mandrake-distro mounted everything into /mnt/, but my Ubuntu-distro mounted my NTFS-disks into the /media/-folder...
I updated to latest kernel using apt-get and am now also having this issue. Something is wrong with ubuntu/debian. I have been a linux server administrator (RH 6.2 on) for a very long time now. I have mounted a lot of drives ; ) Tried to mount drives that were busy too. This one's not...

I am trying to mount /dev/sdb to /media/windows. It mounted under redhat fine.

From the ubuntu site:
Code:
Q: How to mount Windows partitions (NTFS) on boot-up, and allow all users to read only?

   1. Read General Notes
   2. Read How to list partition tables?
   3.

e.g. Assumed that /dev/hda1 is the location of Windows partition (NTFS)
     Local mount folder: /media/windows

   4.

sudo mkdir /media/windows
sudo cp /etc/fstab /etc/fstab_backup
sudo gedit /etc/fstab

   5. Append the following line at the end of file

/dev/hda1       /media/windows  ntfs    nls=utf8,umask=0222 0       0

   6. Save the edited file (sample)
   7. Read How to remount /etc/fstab without rebooting?
-------
I am using SATA drives so mine are /dev/sda and /dev/sdb. It's not a mirror set.

$sudo mount -a produces:
Code:
viza@anon:/$ sudo mount -a
mount: /dev/sdb already mounted or /media/windows busy
$sudo mount produces:
Code:
/dev/sda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev on /.dev type unknown (rw,bind)
none on /dev type tmpfs (rw,size=5M,mode=0755)
usbfs on /proc/bus/usb type usbfs (rw)
so it's not mounted

here is fstab (only one partition so no number necessary)

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/sda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sdb       /media/windows  ntfs    nls=utf8,umask=0222 0       0
If I tack on a 0 to /dev/sdb in fstab and rerun mount -a

Code:
viza@anon:/$ sudo mount -a
mount: special device /dev/sdb0 does not exist
lsof | grep windows produces:
Code:
viza@anon:/$ sudo lsof | grep windows
viza@anon:/$
So windows isn't busy.
And the good old mount command produces:
Code:
mount: /dev/sdb already mounted or /media/windows busy
Code:
viza@anon:/$ uname -a
Linux anon 2.6.11-1-686 #1 Fri Feb 11 15:59:02 UTC 2005 i686 GNU/Linux
As well Nautilus now locks entire computer up requiring a cold reboot. Good thing I am a fluxbox user ; ). The default ubuntu gnome desktop freezes computer. According to logs it's a kernel panic. As well, I needed to increase the apt-get cache size considerably. I think something's bad on this kernel build, and it's some sort of disk IO thing.

Code:
update---
started up using 2.6.10 i386 and nautilus issue cleared up
mount is still busy. No more kernel panics tho...
If anyone knows what's going on here or has seen this, I would love to hear from you. I could mount this drive under dedrat fine.

thx,
viza

Last edited by viza; 07-20-2005 at 08:44 PM.
 
Old 08-01-2005, 06:20 AM   #12
Waerner
Member
 
Registered: May 2005
Location: Írebro, Sweden
Distribution: Ubuntu 6.06
Posts: 92

Rep: Reputation: 15
Okay, that's too heavy for me
 
Old 09-06-2005, 10:35 AM   #13
ablewisuk
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
If anyone is still reading this thread: I had the same problem after installing a custom kernel and solved it by doing 'sudo apt-get remove evms'. It is apparently caused by the enterprise volume management service. This may remove some other packages, so be careful.

See here for more info: http://lists.debian.org/debian-user/.../msg00388.html
 
Old 09-06-2005, 01:55 PM   #14
tunasashimi
Member
 
Registered: Jun 2005
Posts: 82

Original Poster
Rep: Reputation: 15
Woohoo months later...

Fan bloody tastic.. will report back if I can still find that drive....

Thanks...

Wonder why...

-----------------------------------------------------------------
Windows, Linux, Unix, BSD, DOS, OSx.... = all crap.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vmware says /dev/fd0/ is busy ? dolphans1 Mandriva 2 06-13-2005 12:09 PM
Any problem to install Linux in my /dev/hda4? enemorales Linux - General 5 03-13-2005 01:52 PM
/dev/hda4 Couldn't find ext2 superblock a10392 Linux - Hardware 1 11-17-2004 11:01 AM
Why is my /dev/dsp always busy ? mnguyen Linux - Software 1 03-22-2004 02:13 AM
Quake 3 , /dev/dsp busy :( juby Linux - Software 3 03-28-2003 11:19 PM


All times are GMT -5. The time now is 08:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration