LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-14-2010, 03:02 PM   #1
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
Dependency problems when installing compiz-fusion-plugins-extra in 11.04 Pre-Alpha


Code:
kenny_strawn@kenny-AOA110:~$ sudo apt-get install compiz-core compiz-fusion-plugins-extra
[sudo] password for kenny_strawn: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
compiz-core is already the newest version.
compiz-core set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 compiz-core : Breaks: compiz-fusion-plugins-extra (< 0.9) but 0.8.6-0ubuntu1 is to be installed
 compiz-fusion-plugins-extra : Depends: compiz-core-abiversion-20091102
E: Broken packages
kenny_strawn@kenny-AOA110:~$
Please help me here. Is there any PPA that has version 0.9 of compiz-fusion-plugins-extra? If so, please point me to it.
 
Old 11-14-2010, 05:34 PM   #2
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
Filed a bug about this
 
Old 11-23-2010, 09:41 AM   #3
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by Kenny_Strawn View Post
Please help me here. Is there any PPA that has version 0.9 of compiz-fusion-plugins-extra? If so, please point me to it.
I build it from the 0.9.2 source (on 11.04), but none of the extra-plugins show up in CCSM. I guess that I have to rebuild CCSM also, but I wouldn't think that this would be necessary. I will try later and get back to you.
 
Old 11-24-2010, 10:43 PM   #4
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
Yes, I think building it from source may be my only option then. Is there a Compiz Git repository? If so, I will be glad to clone from it.
 
Old 11-25-2010, 07:19 AM   #5
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by Kenny_Strawn View Post
Yes, I think building it from source may be my only option then. Is there a Compiz Git repository? If so, I will be glad to clone from it.
http://gitweb.compiz.org/ http://cgit.compiz.org/ or the 0.9.2 tarballs
http://releases.compiz.org/0.9.2/
 
Old 11-26-2010, 10:42 AM   #6
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
I didn't notice before that there is a 0.9.2.1
http://releases.compiz-fusion.org/0.9.2.1/

I did figure out what I was doing wrong.
While building with:
Code:
mkdir build && cd build
cmake .. 
make
sudo checkinstall
After the cmake .. step you need to go into the build directory and edit the CMakeCache.txt file
and change
Code:
//Install path prefix, prepended onto install directories.
CMAKE_INSTALL_PREFIX:PATH=/usr/local
to
Code:
CMAKE_INSTALL_PREFIX:PATH=/usr
so ccsm can find the plugins. EDIT: once I loged out and back in all the plugins work properly.

Last edited by andrewthomas; 11-27-2010 at 05:15 PM. Reason: extra-plugin info
 
1 members found this post helpful.
Old 12-09-2010, 08:03 PM   #7
felixonmars
LQ Newbie
 
Registered: Dec 2010
Distribution: Ubuntu
Posts: 1

Rep: Reputation: 0
Hi Kenny_Strawn,
I followed your steps but after a logged out and open ccsm again, no extra plugins showed up, could you plz help me find the problem?
EDIT: after a fresh installation the problem was solved...

Last edited by felixonmars; 12-09-2010 at 08:14 PM. Reason: SOLVED
 
  


Reply

Tags
ubuntu+1104, compiz fusion


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to Install Extra Compiz Fusion Plugins devinmcelheran Linux - Newbie 7 04-23-2009 03:02 PM
compiz fusion plugins oguejiofor obiora Linux - Software 1 12-17-2008 04:37 PM
Help needed in installing unsupported compiz fusion plugins (Atlantis,Snowglobe) .B. Linux - Software 0 12-11-2007 06:49 PM
compiz fusion plugins BCarey Slackware 5 08-04-2007 03:26 PM
Compiz - How do I include the compiz-extra plugins? lostinpurdy Linux - Desktop 2 05-29-2007 02:00 AM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration