LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-31-2006, 09:24 AM   #1
Dark Carnival
Member
 
Registered: Jun 2003
Posts: 166

Rep: Reputation: 30
Dapper Drake + XGL + NVIDIA == Horrible artifacts :/


Hello

I use a Dell XPS M170 which is equipped with a Geforce GO 7800GTX which is equipped with 256mb ram

I've previously had XGL running on an ubuntu install (the version before dapper drake) and I've also had it running without complaints under SuSE 10.1 ... However after following the guide at:
http://www.tectonic.co.za/view.php?id=916

Which basically made me do the following:

*Create an .Xsession file and write the following into it:
Code:
#!/bin/sh
# Start up Xgl, compiz, and GNOME
# Run Xgl server on :1, on top of normal X
Xgl :1 -fullscreen -ac -accel xv:fdo -accel glx:pbuffer &
# Tell subsequent X programs to access the Xgl server at :1
DISPLAY=:1
# Start Compiz window manager
gnome-window-decorator &
compiz gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher &
# Start GNOME 
exec gnome-session
*apt-get install compiz compiz-gnome xserver-xgl
* chmod +x ~/.Xsession

I choose the default session so that the .Xsession file is run and I get the checkered background followed by a blue'ish background which is apparantly an indication of XGL and compiz starting.
However.. I'm getting a, excuse my french, crapload of artifacts once inside the gui.. Whenever I expand a menu something happens, the main window gets all unreadable and so on....

I've tried running with the (outdated) 77.76 driver that ubuntu provides and currently I'm using the latest and greatest from Nvidia - 87.74
But every time I try to start the XGL/compiz session, I get this horrible artifact hell and it's completely unuseable

Any ideas? Anyone who had the same stuff happen ? I'd rather not compile too much stuff by hand as it's sort of a development machine and so the installation is meant to last for a while
 
Old 09-01-2006, 06:46 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,745
Blog Entries: 1

Rep: Reputation: 224Reputation: 224Reputation: 224
I'm not a *buntu user, but have you tried the official unoffical Ubuntu Wiki HOWTO?

You may also want to eyeball the unofficial compiz forum. I know there are threads there that talk about getting rid of artifacts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: 3D Xgl Eye Candy for Ubuntu/Kubuntu Dapper and NVidia LXer Syndicated Linux News 1 09-14-2006 07:19 PM
No sound in Dapper Drake dittyman1 Ubuntu 3 08-27-2006 11:16 AM
Dapper Drake and nVidia- X crashes spiffytech Ubuntu 4 08-17-2006 02:50 PM
Dapper Drake brianthegreat Ubuntu 19 06-06-2006 05:11 AM
Xgl, artifacts left behind... mike160 Suse/Novell 1 05-16-2006 09:03 PM


All times are GMT -5. The time now is 09:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration