LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-30-2005, 09:01 PM   #1
jlacroix
Member
 
Registered: Nov 2003
Posts: 184

Rep: Reputation: 15
Unhappy Custom Kernel, Error Messages, But It's Working, Confused.


Hello everyone, after a rather extreme battle, I was able to compile a custom kernel, 2.6.13 with Ubuntu Hoary. 2.6.13 is a vanilla kernel from www.kernel.org.

Since installing this kernel, my system is snappier and faster than ever. Its still just as if not more stable, too.

However, during boot, I get a screen full of error messages. These error messages must not mean anything as the system works fine, but they scare me nonetheless.

The errors I remember are:

Not finding the file system devfs
And a ton of error removing (service name) device or resource busy

I checked the logs but none of them match the boot message so I don't know what log file to provide to you guys for assistance. Which is a good log to show these errors exactly?
 
Old 08-31-2005, 04:31 AM   #2
mschutte
Member
 
Registered: Jan 2005
Location: Innsbruck, Austria
Distribution: Debian GNU/Linux Lenny
Posts: 68

Rep: Reputation: 15
Open a shell and type:
$ dmesg | less
You can browse the kernel messages then.
 
Old 08-31-2005, 11:20 PM   #3
jlacroix
Member
 
Registered: Nov 2003
Posts: 184

Original Poster
Rep: Reputation: 15
The errors that I seen don't show up there.
 
Old 09-02-2005, 07:43 PM   #4
mlomker
Member
 
Registered: Aug 2005
Location: Saint Paul, MN
Distribution: Kubuntu
Posts: 34

Rep: Reputation: 15
That's because they relate to Ubuntu's start and shutdown scripts. I also installed a 2.6.13 kernel and get a few strange errors on start-up...it's because I compiled in a number of things that use to start as modules and removed other components that they are probably trying to start. Sometime, when I'm feeling ambitious, I'll sort through and customize all of the /etc/rc*.d scripts to resolve that.
 
Old 09-17-2005, 02:46 PM   #5
FiSz
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
same situation i my case
mount: unknown filesystem type 'devfs' x2 while booting fresh 2.6.13.1
it has definitely something to do with removal of devfs from the 2.6.13 kernel
How to find the cause of those errors?
 
Old 09-17-2005, 06:24 PM   #6
mlomker
Member
 
Registered: Aug 2005
Location: Saint Paul, MN
Distribution: Kubuntu
Posts: 34

Rep: Reputation: 15
Quote:
How to find the cause of those errors? [/B]
grep devfs /etc/*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel-Patch Debian Logo 2.6.2 not correctly working for custom kernel 2.6.11 smp deepclutch Debian 3 06-27-2005 03:59 AM
USB wireless mouse not working w/ custom RH kernel cellist Linux - Laptop and Netbook 0 12-24-2004 03:12 PM
kernel panic error message --What do i do?? :confused: linuxnut2003 Red Hat 7 02-20-2004 10:50 PM
ACPI is working but have some odd error messages acmilanlover Linux - General 1 08-16-2003 11:13 PM
Custom MySQL 4 error messages bad_cmd/filenam Programming 3 05-29-2003 05:50 AM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration