LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-03-2008, 10:25 AM   #1
KPryor
Member
 
Registered: Nov 2006
Distribution: Linux Mint, Ubuntu 10.10 Desktop and Server
Posts: 36

Rep: Reputation: 15
Constant hard drive reads


I have a dual boot AMD Turion laptop with 1.5 gb ram and 100 gb HD. When I boot into Ubuntu 8.04 the system seems to keep accessing the HD about every half second. Literally, it's just read/off read/off read/off showing on the HD light. GKRELLM shows at least 164k and occasionally more for disk activity, however, so I'm not sure what is going on. Any suggestions would be appreciated, as listening to it read and seeing the light flashing on and off constantly is driving me nuts. It doesn't seem to do this when I boot to the Windows XP side of the machine.
Thanks!
KP

Last edited by KPryor; 09-03-2008 at 10:28 AM. Reason: Corrected a mistake
 
Old 09-03-2008, 10:36 AM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,754

Rep: Reputation: Disabled
It was an issue with an earlier version of Ubuntu. The solution was to put in a script in /etc.

In your case check up serviceconfig first.
 
Old 09-03-2008, 10:44 AM   #3
KPryor
Member
 
Registered: Nov 2006
Distribution: Linux Mint, Ubuntu 10.10 Desktop and Server
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks amani. I have to admit I'm not really sure what to check. I opened the services and don't see anything obvious that would be causing this, but will confess I don't know all that I need to in Linux yet. Thanks for you help!
KP
 
Old 09-03-2008, 11:01 AM   #4
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,754

Rep: Reputation: Disabled
Full Solution (from a big thread):


----------------------------

(Poster Pneuma)

1) Enable laptop mode. This will ensure that the laptop-mode-tools program will actually be able to run.
Go to Applications -> Accessories -> Terminal and type in
"sudo gedit /etc/default/acpi-support", then your password when prompted. Search for where it says "ENABLE_LAPTOP_MODE" and set it from "ENABLE_LAPTOP_MODE=false" to "ENABLE_LAPTOP_MODE=true". Then save it and exit.
2) Get laptop-mode-tools and install it.

3) Set laptop-mode-tools to run even when on AC Power, otherwise you'll still have clicking when you're plugged in. Go back to the Terminal and type "sudo gedit /etc/laptop-mode/laptop-mode.conf" and give the password if prompted. In gedit, search for "ON_AC". You should change "ENABLE_LAPTOP_MODE_ON_AC=0" to "ENABLE_LAPTOP_MODE_ON_AC=1" so that laptop-mode-tools will work even when your laptop is on AC power. Save and quit.
4) Turn on laptop-mode-tools. Go back to the Terminal and type "sudo /etc/init.d/laptop-mode start". This should start up laptop-mode. You can check to make sure that laptop-mode is on by typing "sudo /etc/init.d/laptop-mode status". A nonzero value after where it says “/proc/sys/vm/laptop_mode” indicates that it's activated. Now, in my case the "start" command reassured me that laptop-mode was on, but then the "status" command gave me a 0 value. That was because I was on AC power, and I hadn't done step 3. Yours should be a nonzero value.
5) The clicking sound should have stopped by now. Now just set it so that laptop-mode will come on every time you boot. To do this, go to System -> Preferences -> Sessions, then click "Add" to add a new startup program. In the "Command" field, put "/etc/init.d/laptop-mode start". For "Name" or "Comment", put whatever you want.

-------------------------------

Last edited by amani; 09-03-2008 at 11:08 AM.
 
Old 09-03-2008, 11:22 AM   #5
KPryor
Member
 
Registered: Nov 2006
Distribution: Linux Mint, Ubuntu 10.10 Desktop and Server
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks amani! I followed the directions, but it's still doing it. My machine already had laptop-tools installed as it turned out, but I followed all other directions and it's still doing it. I'm just baffled as to what is causing this.
KP
 
Old 09-03-2008, 01:00 PM   #6
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 3,860

Rep: Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768
Are you sure its not something indexing the hard disk? There are various programs (beagle/Kerry beagle/Updatedb/locate/slocate/...) that help you find files, but they have to index the disk first. What usually happens is that this settles down after a while if you let it run to completion.

You might want to look for which programs are using up lots of processor time and see if they seem to be doing this kind of thing. (Try top/ksysguard/...and I've forgotten what the gnome system monitor program is called. System Montor, maybe?)
 
Old 09-03-2008, 01:05 PM   #7
KPryor
Member
 
Registered: Nov 2006
Distribution: Linux Mint, Ubuntu 10.10 Desktop and Server
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks for the suggestions, salasi. I thought about the indexing too, but can't imagine it needs to continue doing that for hours upon hours. I've had Ubuntu running on this machine for awhile now, so I wouldn't think indexing would still need go on that much, but I don't know. I'll take a look at top and see what it says.
Thanks!
KP
 
Old 09-03-2008, 11:23 PM   #8
KPryor
Member
 
Registered: Nov 2006
Distribution: Linux Mint, Ubuntu 10.10 Desktop and Server
Posts: 36

Original Poster
Rep: Reputation: 15
I am pleased to say I finally found the problem. Through trial and error I found the culprit to be the klogd computer activity logger.
KP
 
Old 09-10-2008, 02:58 PM   #9
nowshining
Member
 
Registered: Dec 2007
Distribution: Ibex
Posts: 93

Rep: Reputation: 15
hehe klogd is what cuased ubuntu 8.04 for me to hang so I switch back to 7.10 & kubuntu
 
Old 09-10-2008, 03:31 PM   #10
KPryor
Member
 
Registered: Nov 2006
Distribution: Linux Mint, Ubuntu 10.10 Desktop and Server
Posts: 36

Original Poster
Rep: Reputation: 15
That's really odd. You wouldn't think that would cause such trouble, but it clearly has a problem somewhere. Thanks for the info!
KP
 
Old 09-29-2008, 12:05 PM   #11
jgallo
Member
 
Registered: Sep 2008
Posts: 39

Rep: Reputation: 15
is it installed automatically? i dont want to run into the same problem

Linux Archive

Last edited by jgallo; 10-12-2008 at 01:55 AM.
 
Old 10-04-2008, 07:53 PM   #12
nowshining
Member
 
Registered: Dec 2007
Distribution: Ibex
Posts: 93

Rep: Reputation: 15
yes klogd is by default installed...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Constant hard drive activity when optical drive is in use the trooper Linux - Hardware 5 08-15-2008 06:25 PM
Hard drive led showing constant activity when not in use 0p3r4 Linux - Hardware 8 07-21-2006 03:55 PM
x86 Linux that reads Mac formatted hard drives? Kushan Linux - Newbie 1 12-26-2005 03:37 PM
Constant hard drive access Nishtya Linux - General 6 10-07-2005 05:49 PM
My dvd drive reads cd's but not dvd's malcolm Linux - Newbie 8 01-23-2003 04:35 PM


All times are GMT -5. The time now is 08:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration