LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-25-2008, 06:37 PM   #1
sharky
Member
 
Registered: Oct 2002
Posts: 396

Rep: Reputation: 37
compiz compiz-fusion and beryl


Using kubuntu 8.0.4 with KDE 4.1 installed. Nvidia 6200 with dual monitors (1280x1024 lcd and 1440x900 lcd)

Trying to install/activate some of the advanced features of compiz or beryl or whatever it's called. I can do some of the silly tricks like transparancy and wobbly windows but I don't know if this a standard part of KDE 4.1 or not. I can't get the "cube" to work so I don't know if something else needs to be setup.

regards,
 
Old 08-25-2008, 06:53 PM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
What plugins have you got enabled? Open up CSSM (CompizConfig Settings Manager). There should be an arrow marked Preferences on the left side near the bottom. Click it, then click the Plug List. The stuff on the right is enabled, the left is disabled. Move the item you want to enable to the right. You need Desktop Cube and Cube Rotate enabled.
 
Old 08-25-2008, 10:17 PM   #3
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by camorri View Post
What plugins have you got enabled? Open up CSSM (CompizConfig Settings Manager). There should be an arrow marked Preferences on the left side near the bottom. Click it, then click the Plug List. The stuff on the right is enabled, the left is disabled. Move the item you want to enable to the right. You need Desktop Cube and Cube Rotate enabled.
I don't see a CompizConfig Settings Manager.
 
Old 08-26-2008, 08:20 AM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Open a konsole and type 'ccsm' without the quotes, that should launch it. You can make a desktop icon, or add it to your menu.
 
Old 08-26-2008, 08:22 PM   #5
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by camorri View Post
Open a konsole and type 'ccsm' without the quotes, that should launch it. You can make a desktop icon, or add it to your menu.
Started 'ccsm' and it the same gui I get when I select 'Advanced Desktop Effects Settings' from the menu.

Anyway, lots of items are showing up in the Disabled and Enable Plugins. There was also a warning when I turned off 'Automatic plugin sorting'.
 
Old 08-27-2008, 07:23 AM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Have you managed to get the cube rotating?
 
Old 08-27-2008, 12:34 PM   #7
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by camorri View Post
Have you managed to get the cube rotating?
Nope. There are some 'cube*' settings in the disabled column but because of warnings that some options are incompatible I didn't muck with it.
 
Old 08-27-2008, 02:05 PM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
I have 3 items enabled in Desktop. They are: Desktop Cube, Cube Rotate, and Viewport Switcher. That is it, the cube rotates. You could disable anything else, and only enable these to see if the cube will work. Not sure what else to suggest.
 
Old 08-27-2008, 02:08 PM   #9
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by camorri View Post
I have 3 items enabled in Desktop. They are: Desktop Cube, Cube Rotate, and Viewport Switcher. That is it, the cube rotates. You could disable anything else, and only enable these to see if the cube will work. Not sure what else to suggest.
That's actually a good suggestion. I'm at work now but I'll try that later today.

thx,
 
Old 08-28-2008, 12:01 AM   #10
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by sharky View Post
That's actually a good suggestion. I'm at work now but I'll try that later today.

thx,
No affect. Is there a module or some setting required in the xorg.conf?
 
Old 08-28-2008, 12:33 AM   #11
Mr. ameya sathe
Member
 
Registered: Jul 2007
Distribution: RedHat Enterprise 5 Server Edition; Ubuntu 8.04 ; RHCE Certificate number: 805008741034103
Posts: 78
Blog Entries: 7

Rep: Reputation: Disabled
Go to these links ->

1. http://www.compiz-fusion.org

2. http://ubuntuforums.org/showthread.php?t=809695
 
Old 08-28-2008, 12:13 PM   #12
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by Mr. ameya sathe View Post
The second link looks very enlightening (no pun intended). I'm tempted to leave work early and go home and try it.


thx,
 
Old 08-28-2008, 11:29 PM   #13
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Works in gnome

I switched window managers to gnome and compiz and emerald work like a charm. There's something I'm doing wrong in kde 4.1 but I don't have a clue what the problem is.

I changed no other settings other than switching to gnome.
 
Old 08-29-2008, 01:18 AM   #14
sharky
Member
 
Registered: Oct 2002
Posts: 396

Original Poster
Rep: Reputation: 37
Switched to compiz in kde4.1

Found an option in the system settings that let's me switch from kwin to compiz in kde 4.1. Tried it and now there are no window decorations. Switched by to kwin and still no window decorations. That kinda sucks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Skydome background doesn't work with compiz/gnome unless I use the compiz fusion icon The_Trooper Linux - Software 1 07-21-2008 01:08 PM
beryl or compiz-fusion on fluxbox LinuxNewbie999 Linux - Newbie 2 04-10-2008 08:11 AM
Beryl/ Compiz-fusion FlushingSkt Linux - Newbie 1 02-26-2008 10:05 PM
Which nvidia card works best with beryl and.or compiz fusion? dv502 General 4 07-31-2007 01:42 PM
LXer: Installing Beryl Or Compiz Fusion On A Fedora 7 Desktop LXer Syndicated Linux News 0 07-03-2007 01:31 PM


All times are GMT -5. The time now is 07:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration