LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 02-01-2011, 01:32 PM   #1
kc8hr
Member
 
Registered: Sep 2006
Location: Inkster, MI USA
Distribution: Ubuntu
Posts: 31

Rep: Reputation: 15
Question Changing virtual console screen resolution


Hi All,

I am using Ubuntu 10.10 on a Dell Optiplex GX270, with the Intel video chip. I have a problem with my virtual consoles/terminals (<ctrl-alt>F1-F6). The default screen resolution was set to 1600x1200 at installation, which results in a nearly microscopic, unreadable font.

I posted the problem on this thread on ubuntuforums.org, where they suggested adding GRUB_GFXMODE=640x480 and GRUB_GFXPAYLOAD_LINUX=640x480 to /etc/default/grub and /etc/grub.d/00_header. Still no joy--the console screen resolution still was 1600x1200.

I have noticed that the screen resolution changes three times during boot; it starts at standard VGA, 640x480, then switches to 1600x1200, then finally to 1024x768, which is my preferred resolution in X. But, if I switch to a virtual console, the resolution shoots up to 1600x1200 again.

Is there any solution to this problem? There are times when I like to use virtual terminals, and I would like to avoid eyestrain.

Thanks,
Tim
 
Old 02-01-2011, 04:38 PM   #2
petebow4
LQ Newbie
 
Registered: Sep 2005
Location: West Hartford, CT
Distribution: Ubuntu
Posts: 19

Rep: Reputation: 2
Take a look at: http://ubuntuforums.org/showthread.php?t=215566 Similar to what you were doing, but it might give you better results.
 
Old 02-02-2011, 09:59 AM   #3
kc8hr
Member
 
Registered: Sep 2006
Location: Inkster, MI USA
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Unhappy

Quote:
Originally Posted by petebow4 View Post
Take a look at: http://ubuntuforums.org/showthread.php?t=215566 Similar to what you were doing, but it might give you better results.
Hi Pete,
Thanks, but that solution is for the original grub, Ubuntu 10.10 uses grub2, which uses completely different config files that are not compatible. I have already tried installing the old version of grub and using that solution, but it didn't work either.

This is really kicking my butt!
Thanks,
Tim
 
Old 02-02-2011, 09:04 PM   #4
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by kc8hr View Post
Thanks, but that solution is for the original grub, Ubuntu 10.10 uses grub2, which uses completely different config files that are not compatible. I have already tried installing the old version of grub and using that solution, but it didn't work either.
For grub2, you could try adding those vga options to the /etc/default/grub file. Add them to either the GRUB_CMDLINE_LINUX line, or the GRUB_CMDLINE_LINUX_DEFAULT line.
See this tutorial on grub2: https://help.ubuntu.com/community/Gr...b%20%28file%29
Be sure to run: <sudo update-grub> after making any changes to the /etc/default/grub file so that the changes take effect on the next reboot.

Last edited by tommcd; 02-02-2011 at 09:06 PM.
 
Old 02-02-2011, 09:56 PM   #5
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
To be more specific, you would add:

Code:
GRUB_GFXMODE=1024x768
to /etc/default/grub, then run:

Code:
sudo update-grub
for the changes to take effect.
 
Old 02-03-2011, 10:12 AM   #6
kc8hr
Member
 
Registered: Sep 2006
Location: Inkster, MI USA
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Angry

Hi Kenny,

Quote:
Originally Posted by Kenny_Strawn View Post
To be more specific, you would add:

Code:
GRUB_GFXMODE=1024x768
to /etc/default/grub, then run:

Code:
sudo update-grub
for the changes to take effect.
Thanks, tried that--still doesn't work. Here is my /etc/default/grub:

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=640x480
GRUB_GFXPAYLOAD=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Something somewhere in the boot process is fixing the virtual console resolution at 1600x1200 and nothing I add to /etc/default/grub seems to make any difference.

I am very annoyed.
 
Old 02-03-2011, 06:51 PM   #7
sunnydrake
Member
 
Registered: Jul 2009
Location: Kiev,Ukraine
Distribution: Ubuntu,Slax,RedHat
Posts: 288
Blog Entries: 1

Rep: Reputation: 41
x)quick and dirty use vbetool hardcoded in some init.d scripts to setup mode
x) someone suggest add to grub conf lines
insmod gfxterm
insmod vbe
set gfxmode=1024x768x24
and in kernel menuentry add
set gfxpayload=keep

Last edited by sunnydrake; 02-03-2011 at 06:57 PM.
 
Old 02-03-2011, 07:57 PM   #8
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by kc8hr View Post
Thanks, tried that--still doesn't work. Here is my /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
Your /etc/default/grub file that you posted shows that nothing has been added to either the GRUB_CMDLINE_LINUX_DEFAULT="" line or the GRUB_CMDLINE_LINUX="" line. Try adding what Kenny suggested in between the quotes at the end of either of those 2 lines. Then run
Code:
sudo update-grub
Then reboot and see if it works.
 
Old 02-04-2011, 01:11 PM   #9
kc8hr
Member
 
Registered: Sep 2006
Location: Inkster, MI USA
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Question

Sorry guys, those suggestions didn't work.

I tried adding

insmod gfxterm
insmod vbe
set gfxmode=1024x768x24

to /etc/default/grub, but when I ran 'sudo update-grub' it said "insmod: can't read 'gfxterm': No such file or directory" and it said the same for 'insmod vbe'.

Here is my /etc/default/grub:

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="set gfxpayload=keep"
GRUB_CMDLINE_LINUX="ro"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
# GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=640x480
GRUB_GFXPAYLOAD=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
I am really stumped!
 
Old 02-06-2011, 02:43 PM   #10
kc8hr
Member
 
Registered: Sep 2006
Location: Inkster, MI USA
Distribution: Ubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
Yippee! I found the fix here: http://lkml.indiana.edu/hypermail/li...1.2/02116.html The magic words are:

Quote:
GRUB_CMDLINE_LINUX="video=VGA-1:640x480"
in /etc/default/grub. I now have a set of usable virtual consoles.

Thanks to everyone for the help.

Later--
Tim
 
Old 02-07-2011, 01:14 PM   #11
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by kc8hr View Post
Yippee! The magic words are:

GRUB_CMDLINE_LINUX="video=VGA-1:640x480"

in /etc/default/grub. I now have a set of usable virtual consoles.
Glad you found the right VGA resolution that works for you!
I knew that the place to add the resolution would be the GRUB_CMDLINE_LINUX= line in /etc/default/grub.
I just did not know what particular "magic words" to add there that would solve your problem.

Last edited by tommcd; 02-07-2011 at 01:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem changing the video adapter setting and changing the screen resolution habiblove Linux - General 3 02-18-2006 05:10 PM
Changing Console Resolution awj78 Linux - Newbie 1 02-02-2006 10:20 AM
Better Virtual Console Resolution Needed koby *BSD 0 12-14-2004 06:14 PM
Changing Console (CLI) Resolution overbored Linux - Software 0 09-07-2004 08:33 PM
changing screen resolution for text (shell) console Repeater Linux - Newbie 13 08-30-2004 09:30 AM


All times are GMT -5. The time now is 01:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration