LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 07-20-2014, 04:09 PM   #1
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Rep: Reputation: 30
Cant open Windows Disk form desktop (GUI only)


Whenever I click on the windows disk icon on the desktop, instead of file manager, file manager preferences opens. (see screenshot)

https://www.dropbox.com/s/kgm5j9j6pf...ileManager.png

When I try to navigate in File Manager to location where disk is mounted (automatically /media/{username}/) I got error: Permission Denied.
And that is sooo wrong because in CLI I can easly navigate there/copy/past/delete etc.
I can also mount it manually and then it works good (though desktop icon is gone)


It looks like this disk icon on my desktop is not associate with File Manager itself but with its File Manager Preferences.

Any ideas how to change it/fix it* ?
*yes - I have tried right click on disk icon > Aplications > Accessories > File Manager. This will open File Manager in my home dir and again if I try to navigate to mount point I will see Permission Denied.

Last edited by czezz; 07-20-2014 at 04:10 PM.
 
Old 07-20-2014, 05:04 PM   #2
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,094

Rep: Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809
If that is a windows operating system on a separate partition, I would not expect to be able to do more than read files there as a normal user. You should be able to read/write to it as root, using sudo. In order to do that as a user, you need to mount with that parameter or put an entry in /etc/fstab with those permissions.
 
Old 07-20-2014, 08:37 PM   #3
steez2002
LQ Newbie
 
Registered: Dec 2010
Location: WV
Distribution: Ubuntu 14.04
Posts: 14

Rep: Reputation: 5
Cant open Windows Disk form desktop (GUI only)

if Windows isn't shutdown completely it won't let you access the partition. had the same issue on a multiboot Vista 7 8 ubuntu
 
Old 07-21-2014, 04:35 AM   #4
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Original Poster
Rep: Reputation: 30
It is Windows partition.
It is shutdown completly
I have full RW access under CLI (as I have written). Disk icon on the desktop does not work. Does anyone know how to fix it ?
 
Old 07-21-2014, 09:09 AM   #5
ondoho
Senior Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 1,217

Rep: Reputation: 170Reputation: 170
Quote:
Originally Posted by czezz View Post
I have full RW access under CLI
are you positive this is without super user rights? as a normal user?
what are the excat commands you use to access the drive?

...maybe it's just a problem with the file/desktop manager.

personally i would mount internal drives via fstab, as was suggested before.
 
Old 07-21-2014, 06:14 PM   #6
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Original Poster
Rep: Reputation: 30
@ondoho - u are right. I double checked and in fact I need to be root to have access this partition.
Though this only if this partition mounted automatically.

I tried to add this partition in /etc/fstab. Result:
- disk icon is gone form desktop
- i can navigate in File Manager and access this partition (R/W) as regular user.

Removing my entry from fstab or umounting it, restores icon on the desktop, but the disk is not accesiable "Permission denied" :/
Also note: after fresh installation it was possible to access this partition just by clicking that icon. (Icon was created automatically by installation).

Last edited by czezz; 07-21-2014 at 06:20 PM.
 
Old 07-23-2014, 06:33 PM   #7
ondoho
Senior Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 1,217

Rep: Reputation: 170Reputation: 170
yes, with the fstab method the drive just shows up as a regular folder where you mounted it.

but now you have r/w permissions so i guess it's good, no?

i know there's a longer explanation why you sometimes get the r/w access for the drive icon, and sometimes not, but i cannot give it.
 
Old 12-13-2014, 06:08 AM   #8
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Original Poster
Rep: Reputation: 30
Hi, let me please take up this issue again.

Please look at Screenshot0: https://www.dropbox.com/s/0ya5p0zqg8...shot0.png?dl=0
Here you can see default view of the Xubuntu desktop after fresh installation.
Please mind about 2 disk icons: OS and 294 GB Volume.

These 2 disk icons represent my Windows partitions. Since always clicking on one of these disks I had an easy access to them over File Manager.

However, sometime ago by accident I clicked something wrong with files associations and since that moment every time I try to open disks by clicking on the them, it opens File Manager Preference.
Please see Screnshot1: https://www.dropbox.com/s/vts539l97a...shot1.png?dl=0
It also shows that disk is not mounted yet.
However if you look more closer it shows it is not anymore transparent and if you look at Screenshot2 it also shows it is mounted! https://www.dropbox.com/s/xkg4pfuir9...shot2.png?dl=0
But instead of that only File Manager Preference is opened and I have no access to this disk
Even opening File Manager manualy and navigating to the mount point prevents me to see the content.

Last edited by czezz; 12-13-2014 at 06:16 AM.
 
Old 12-13-2014, 04:33 PM   #9
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,344

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
This is interesting.

Do you have that device in the fstab file?

Have you checked the configuration in the Thunar preferences gui under the "Advanced" tab? Is Volume Management enabled?

If it is you need to click on the link below that box to make sure the first 2 boxes on that screen are checked.

This is a bit difficult for me to deal with. I use Xfce but not Xubuntu. Xubuntu doesn't use, at least under 12.04 it didn't, xfwm to manage the desktop. It uses nautilus to do that.

If you check you will find that nautilus is installed. While I think this is simply silly you may find it handy to try using it and see what it does with that file system.

The admixture of so many Gnome packages in Xubuntu gives you a lot of strange config problems. The Gnome tools don't quite work right and the Xfce tools don't either. You have to poke at them to see which will do the job.
 
Old 12-15-2014, 01:29 PM   #10
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Original Poster
Rep: Reputation: 30
Hi, thank you for reply.

This is my fstab: # cat /etc/fstab
Code:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=1b163e46-26d6-490b-b58f-2bbe14745a64 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda7 during installation
#UUID=be002599-24d9-49fd-90b2-2560909464c3 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0
I have checked Thunar as well. All you written is checked - see screenshot: https://www.dropbox.com/s/w3u2q9knv2...hot4..png?dl=0

I installed Xubuntu because I was hoping to have easy to maintain Linux Desktop...
 
Old 12-16-2014, 06:39 AM   #11
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,344

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Linux is easy to maintain. It is not maintained the same way Windows is maintained.

There is, for instance, no way you will ever read data from ext4 on a Windows OS. One of the things I like about ext4.

Do you have;
A>ntfs-3g
B>ntfs-config

packages installed. Ntfs-3g is the driver for reading ntfs files. Hard to get things to work if you don't have that. This is, however, a default install on almost all installs from all distros. But you should check that.

Post the results of this command, run as root;
Code:
blkid
from that we can put the MS partition in the fstab file and have it mount on boot up.

You should be able to see, from that command what "device" that partition is.

Running, as root;
Code:
mkdir /media/Win
and then, again as root;
Code:
mount /dev/sdxy /media/Win
where x is the drive and y is the partition should mount the bugger on /media/Win.

Running, as root,
Code:
chown -R 1000:1000 /media/Win
will give you, as user, ownership of anything mounted in that directory assuming you are workign as the first created users (during the install of your system).

That includes system files you can't even look at in Win so don't delete them by accident. This is not hard to avoid but the warning does need to be given.

Linux has been the choice of Win system rescue disks forever. Still is. Those disks all run as a single user system, just root, so this is not uncommon to do. A lot of Win users run as administrator and think they can do anything. They can't but can still completely screw their system. You can as root on your Linux install.

If you chown that directory, which I would surely do, when we put the thing in the fstab file it will not be neccessary to do anything else to access the Win system from Thunar at any time once you have rebooted so that root can mount the system from that fstab file.

I have a Debian 7 installed on my Dreaded Mother in Laws computer, Vista is on that box as the OEM install. It is in the fstab file so I could back up her files, mainly photos of grandkids and friends, on a safer Linux formated partition.

While Vista is still on there, I removed the menu entry for it custom menu entries). She is running Debian 7 now. Vista will be removed when she is sure she is not having troubles with Debian. I have been sure for some months now but I am not in my late 70s yet either as she is.

Your configuration of Thunar looks fine, not sure why a file system on an internal drive is not being mounted. You should see it in Thunar and be able to click on it and get a prompt for the password for root (only root can mount file systems), give it and have it open. Pain in the ass but it works.

Putting it in the fstab file is the way to go.
 
1 members found this post helpful.
Old 12-17-2014, 06:36 AM   #12
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Original Poster
Rep: Reputation: 30
Hi Widget,
at first I want to thank you very much for your help and I really appreciate that.

I got this. The problem was in permissions.
Windows/Disk shortcuts are mounted in /media/my_username
I noted only now that this location was owned by root.
I changed permissions to this dir with chown and it works back again.

Last edited by czezz; 12-17-2014 at 02:14 PM.
 
Old 12-18-2014, 02:51 AM   #13
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,344

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Yes, having permission to use things generally does help.

Glad it is working for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Locking Desktop / GUI Screen iin Linux cf. Windows Hi_This_is_Dev Linux - Desktop 1 09-11-2009 09:56 PM
how can view open terminal in gui desktop sankarperis Linux - Desktop 3 11-19-2008 06:26 AM
program windows that safe session jut like linux desktop gui? hottdogg General 1 04-15-2008 05:04 AM
LXer: Open Source Vendors and Projects Unite to Form Open Management ... LXer Syndicated Linux News 0 05-10-2006 12:12 AM
How to use GUI to view contents of Windows disk myfokkinnick@yahoo.i Ubuntu 5 05-09-2006 11:58 AM


All times are GMT -5. The time now is 01:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration