LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Can't Install Wine - conflict with other installed software (http://www.linuxquestions.org/questions/ubuntu-63/cant-install-wine-conflict-with-other-installed-software-630451/)

gwynn 03-25-2008 07:18 AM

Can't Install Wine - conflict with other installed software
 
Hi all.

I've downloaded Ubuntu Gutsy Gibbon and have installed it on a spare machine. Luv-it-to-death!

When installing Wine I get the message:

Cannot Install "wine"
This application conflicts with other installed software.
To install "wine" the conflicting software must be removed first.

Switch to the Synaptic Package Manager to resolve this conflict.


I've looked around inside Synaptic Package Manager but I'm not altogether sure what I should be looking for.

I'd be grateful for any advice/guidance you can give me folks.

Gwynn.

b0uncer 03-25-2008 07:32 AM

It would be nice to know what it's referring to; I've never had trouble installing Wine because of "conflicting software". I wonder why apt-get didn't tell the trouble-maker's name..

You can, however, try the same with Synaptic: open it up, wait until the list is loaded, click Refresh (to fetch new package lists, to make sure you have recent enough lists), then hit CTRL+F (to bring up a Find dialog), find "wine" (or just scroll to it in the package list, which is long). Once you find it, right-click it and mark it to be installed, then hit Apply, wait and see what it tells you. Hopefully something more than you already know..

TITiAN 03-25-2008 07:35 AM

I think it wants you to try to install wine via synaptic, so synaptic solves the problem. (Take a look on what packages are to be deleted, so you don't mess up your installation).

TITiAN 03-25-2008 07:47 AM

Quote:

I wonder why apt-get didn't tell the trouble-maker's name..
@b0uncer and @gwynn: gwynn doesn't tell what program is used, so I think it's that own of Ubuntu (which is - as far as I know - apt-compatible). apt-get would perhaps "tell the trouble-maker's name", but it's not graphical and so Ubuntu directs you to Synaptic, which can hopefully solve the problem. I recommend aptitude for Debian, but maybe it works not that well under Ubuntu.

If you can't solve things with all four programs (that of Ubuntu, Synaptic, aptitude and apt-get), here's where you can ask ;) .

gwynn 03-25-2008 03:31 PM

Thanks for your responses. I f-disked and reinstalled, this time with the web connection active, that's made a difference but I don't know why - anyways, Wine is now installed without a hitch.

All that's left to do now is find out how to install Adobe InDesign using Wine. It';s not as obvious as I thought it might be.

Don't you just love a learning curve? :-)

jimmy0349 04-15-2008 04:36 PM

how do i install the code for ubuntu dvd player

gibbs1984 04-28-2008 05:08 PM

Hi, I get the same message with regards to installing Wine.

Well actually I get two:

When going from the website winehq .org/site/download-deb I get the following error message:

Quote:

Can not install 'wine' (E: Unable to correct problems, you have held broken packages.)
So went to Add/Remove programs and tried installing through that way and get the following:

Quote:

Cannot install 'wine'

This application conflicts with other installed software. To install 'wine' the conflicting software must be removed first.

Switch to the 'synaptic' package manager to resolve this conflict.
Well I go to synaptic and mark for installation I get the following:

Quote:

Could not mark all packages for installation or upgrade.

The following packages have unresolvable dependencies.
Make sure that all required repositories are added and enabled in the preferences.

wine:
Depends: binfmt-support (>=1.1.2) but it is not installable
Depends: libaudio2 but it is not installable
Depends: libldap-2.4-2 (>=2.4.7) but it is not installable
PreDepends: dpkg (>=1.14.12ubuntu3) but 1.14.5ubuntu16 is to be installed
Just to add that I am a complete new comer to Ubuntu.

Steve

fragos 04-28-2008 06:32 PM

Some packages call out specific versions of libraries. If you install from other than an Ubuntu repository library versions not in Ubuntu might be required. To install these new libraries any package that calls out a different library version will be presented to uninstall.

gibbs1984 04-29-2008 02:24 PM

Quote:

Originally Posted by fragos (Post 3135980)
Some packages call out specific versions of libraries. If you install from other than an Ubuntu repository library versions not in Ubuntu might be required. To install these new libraries any package that calls out a different library version will be presented to uninstall.

Sorry to sound stupid but how do I install these different libraries?

Think I need a beginners guide :o

gibbs1984 04-29-2008 02:39 PM

Quote:

Originally Posted by gibbs1984 (Post 3136897)
Sorry to sound stupid but how do I install these different libraries?

Think I need a beginners guide :o

Here's what I get:

Quote:

steve@Steve-Gibbs-Computer:~$ wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
OK
steve@Steve-Gibbs-Computer:~$ sudo wget http://wine.budgetdedicated.com/apt/...t.d/hardy.list -O /etc/apt/sources.list.d/winehq.list
--19:25:29-- http://wine.budgetdedicated.com/apt/...t.d/hardy.list
=> `/etc/apt/sources.list.d/winehq.list'
Resolving wine.budgetdedicated.com... 81.171.111.184, 81.171.111.184, 81.171.111.184
Connecting to wine.budgetdedicated.com|81.171.111.184|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 180 [text/plain]

100%[====================================>] 180 --.--K/s

19:25:29 (18.54 MB/s) - `/etc/apt/sources.list.d/winehq.list' saved [180/180]

steve@Steve-Gibbs-Computer:~$ sudo apt-get update
Get: 1 http://security.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://security.ubuntu.com gutsy-security/main Translation-en_GB
Get: 2 http://gb.archive.ubuntu.com gutsy Release.gpg [191B]
Hit http://gb.archive.ubuntu.com gutsy/main Translation-en_GB
Ign http://security.ubuntu.com gutsy-security/restricted Translation-en_GB
Ign http://security.ubuntu.com gutsy-security/universe Translation-en_GB
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-en_GB
Get: 3 http://wine.budgetdedicated.com hardy Release.gpg [191B]
Ign http://wine.budgetdedicated.com hardy/main Translation-en_GB
Hit http://security.ubuntu.com gutsy-security Release
Get: 4 http://archive.ubuntu.com gutsy Release.gpg [191B]
Hit http://archive.ubuntu.com gutsy/universe Translation-en_GB
Hit http://gb.archive.ubuntu.com gutsy/restricted Translation-en_GB
Hit http://gb.archive.ubuntu.com gutsy/universe Translation-en_GB
Hit http://gb.archive.ubuntu.com gutsy/multiverse Translation-en_GB
Get: 5 http://gb.archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://gb.archive.ubuntu.com gutsy-updates/main Translation-en_GB
Ign http://gb.archive.ubuntu.com gutsy-updates/restricted Translation-en_GB
Ign http://gb.archive.ubuntu.com gutsy-updates/universe Translation-en_GB
Ign http://gb.archive.ubuntu.com gutsy-updates/multiverse Translation-en_GB
Hit http://security.ubuntu.com gutsy-security/main Packages
Hit http://wine.budgetdedicated.com hardy Release
Hit http://archive.ubuntu.com gutsy/multiverse Translation-en_GB
Hit http://archive.ubuntu.com gutsy/restricted Translation-en_GB
Hit http://archive.ubuntu.com gutsy/main Translation-en_GB
Hit http://archive.ubuntu.com gutsy Release
Hit http://gb.archive.ubuntu.com gutsy Release
Hit http://gb.archive.ubuntu.com gutsy-updates Release
Hit http://security.ubuntu.com gutsy-security/restricted Packages
Hit http://security.ubuntu.com gutsy-security/universe Packages
Hit http://security.ubuntu.com gutsy-security/multiverse Packages
Hit http://archive.ubuntu.com gutsy/universe Packages
Ign http://wine.budgetdedicated.com hardy/main Packages
Hit http://gb.archive.ubuntu.com gutsy/main Packages
Hit http://gb.archive.ubuntu.com gutsy/restricted Packages
Hit http://gb.archive.ubuntu.com gutsy/universe Packages
Hit http://archive.ubuntu.com gutsy/multiverse Packages
Hit http://archive.ubuntu.com gutsy/restricted Packages
Hit http://gb.archive.ubuntu.com gutsy/multiverse Packages
Hit http://gb.archive.ubuntu.com gutsy-updates/main Packages
Hit http://gb.archive.ubuntu.com gutsy-updates/restricted Packages
Hit http://wine.budgetdedicated.com hardy/main Packages
Hit http://archive.ubuntu.com gutsy/main Packages
Hit http://archive.ubuntu.com gutsy/universe Sources
Hit http://archive.ubuntu.com gutsy/main Sources
Hit http://archive.ubuntu.com gutsy/restricted Sources
Hit http://archive.ubuntu.com gutsy/multiverse Sources
Hit http://gb.archive.ubuntu.com gutsy-updates/universe Packages
Hit http://gb.archive.ubuntu.com gutsy-updates/multiverse Packages
Fetched 5B in 0s (9B/s)
Reading package lists... Done
steve@Steve-Gibbs-Computer:~$ sudo apt-get install wine
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
wine: Depends: libldap-2.4-2 (>= 2.4.7) but it is not installable
PreDepends: dpkg (>= 1.14.12ubuntu3) but 1.14.5ubuntu16 is to be installed
E: Broken packages
steve@Steve-Gibbs-Computer:~$


All times are GMT -5. The time now is 10:27 PM.