LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Can't get my GF6600GT dual head to work for the life of me!!! (http://www.linuxquestions.org/questions/ubuntu-63/cant-get-my-gf6600gt-dual-head-to-work-for-the-life-of-me-450978/)

TruANTOlogy 06-02-2006 01:58 PM

Can't get my GF6600GT dual head to work for the life of me!!!
 
Ok, I know this is a big topic around here, but I have looked all over, and nothing I have tried has worked. Here's my issue:



I have a GeForce 6600GT (PCI-express model). It has 1 DVI plug and one VGA plug. I have a VGA adaptor on the DVI plug. I have updated the nvidia drivers. Used nvidia-xconfig --enable-all-gpus, still...I can't get my secondary monitor working at all!

I can't even get JUST the second screen working! Please tell me what in dogs name I am doing wrong!

Thanks in advance,
TruANT

Below is the output for my configs:

LSPCI -v:
Code:

0000:01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0140 (rev a2) (prog-if 00 [VGA])
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at f4000000 (32-bit, non-prefetchable) [size=64M]
        Memory at d8000000 (64-bit, prefetchable) [size=128M]
        Memory at fa000000 (64-bit, non-prefetchable) [size=16M]
        Capabilities: [60] Power Management version 2
        Capabilities: [68] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [78] #10 [0001]

And my wonderful XORG.CONF:
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon May 15 13:23:42 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

        # paths to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/CID"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
    Load          "i2c"
    Load          "bitmap"
    Load          "ddc"
    Load          "extmod"
    Load          "freetype"
    Load          "glx"
    Load          "int10"
    Load          "type1"
    Load          "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc104"
    Option        "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "Emulate3Buttons" "true"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
        Identifier        "Monitor 0"
        VendorName        "Dell"
        ModelName        "M991"
        HorizSync        30-96
        VertRefresh        50-160
        Option                "DPMS"
EndSection

Section "Monitor"
        Identifier        "Monitor 1"
        VendorName        "Envision"
        ModelName        "EN7100s"
        HorizSync        30-80
        VertRefresh        55-75
        Option                "DPMS"
EndSection

Section "Device"
        Identifier        "Card 0"
        VendorName        "nVidia"
        Driver                "nvidia"
        Option                "NoLogo"
        BusID                "PCI:1:0:0"
        Screen                0
EndSection

Section "Device"
        Identifier        "Card 1"
        VendorName        "nVidia"
        Driver                "nvidia"
        Option                "NoLogo"
        BusID                "PCI:1:0:0"
        Screen                1
EndSection

Section "Screen"
        Identifier        "Screen 0"
        Device                "Card 0"
        Monitor                "Monitor 0"
        DefaultDepth        24

        SubSection        "Display"
          Depth                1
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                4
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                8
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                15
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                16
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                24
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "Screen"
        Identifier        "Screen 1"
        Device                "Card 1"
        Monitor                "Monitor 1"
        DefaultDepth        24

        SubSection        "Display"
          Depth                1
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                4
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                8
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                15
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                16
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection

        SubSection        "Display"
          Depth                24
          Modes                "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

#Section "ServerLayout"
#        Identifier        "Default Layout"
#        Screen                "Screen 0" 0 0
#        InputDevice        "Generic Keyboard"
#        InputDevice        "Configured Mouse"
#EndSection

Section "ServerLayout"
        Identifier        "Dual Head Layout"
        Screen 0        "Screen 0" LeftOf "Screen 1"
        Screen 1        "Screen 1" 0 0
        InputDevice        "Generic Keyboard"
        InputDevice        "Configured Mouse"
        Option                "Xinerama" "on"
        Option                "Clone" "off"
EndSection


brianthegreat 06-02-2006 03:47 PM

I have never attempted this but have you read through the Nvidia forums at their website?

Other links:
www.google.com/linux

TruANTOlogy 06-02-2006 05:16 PM

actually, i just configured my mouse, and restarted X and all of a sudden it worked! crazy stuff, but thanks still the same!

please delete this topic?

thanks!


All times are GMT -5. The time now is 11:46 PM.