LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Cannot Upgrade 9.10 Packages (http://www.linuxquestions.org/questions/ubuntu-63/cannot-upgrade-9-10-packages-792211/)

Tim_Olaguna 02-28-2010 06:35 PM

Cannot Upgrade 9.10 Packages
 
I have not been able to upgrade any of my 9.10 karmic packages for about a week now. I have attempted to do so using both the Update Manager Gnome tool and the terminal command "sudo apt-get upgrade". Using the terminal command gives me (at the end of the resulting process) the following:

"dpkg: unrecoverable fatal error, aborting:
" syntax error: unknown group 'Debian-exim' in statoverride file
"E: Sub-process /usr/bin/dpkg returned an error code (2)"

I have tried:

#sudo apt-get update
#sudo apt-get check
#sudo apt-get upgrade

The first two of the above 3 steps work as expected. I get the reported failure message after the last (3rd) step every time.

The last thing I remember doing before I started having this problem was to upgrade Firefox to version 3.6 and Thunderbird to version 3.0.

Any ideas about how I can get out of my current fix?

reed9 02-28-2010 07:29 PM

Should do it:

Code:

sudo dpkg-statoverride --remove /etc/exim4/passwd.client

Tim_Olaguna 02-28-2010 07:57 PM

Quote:

Originally Posted by reed9 (Post 3880421)
Should do it:

Code:

sudo dpkg-statoverride --remove /etc/exim4/passwd.client

Yes! Thank you. That did the trick. I really appreciate it.


All times are GMT -5. The time now is 04:24 AM.