LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-17-2007, 10:57 PM   #1
narcispy
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Rep: Reputation: 15
cannot enable desktop effects


I recently installed ubuntu and after many many hours of configuring I finally got it up and running correctly. The problem is I don't think it's running the correct ATI linux driver for my card, I attempted to install it (I know how it's supposed to be installed I've done it on Fedora a few times) anyways it goes though the installation process and acts like it was installed but never pops up with the installation window after running the sh ./filename command. Anyways, the problem is because that driver isn't recognizing I beleive it's just running the default driver so it won't let me enable the desktop effects like it should. Oh and my graphics card is an ATI radeon X850XT PE. Thanks for any help in this situation.
 
Old 06-19-2007, 08:10 AM   #2
bneal
Member
 
Registered: Jun 2007
Location: Oklahoma City, OK
Distribution: RHEL 4; Suse 10.1, 10.2, FC6, Fedora 7
Posts: 57

Rep: Reputation: 15
Check your Xorg to verify what driver it is using

if it's anything like when you install the driver on Suse then you have to enable the desktop effects from cammand line, you cannot enable it from the GUI
I don't use Ubuntu so I'm not sure what the command would be
if you are trying to enable from the command line then post whatever error you are getting when you try
 
Old 06-19-2007, 05:55 PM   #3
narcispy
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bneal
Check your Xorg to verify what driver it is using

if it's anything like when you install the driver on Suse then you have to enable the desktop effects from cammand line, you cannot enable it from the GUI
I don't use Ubuntu so I'm not sure what the command would be
if you are trying to enable from the command line then post whatever error you are getting when you try
Um... It's using the default ATI driver according to the dpkg-reconfigure program, which doesn't allow you to enable 3d effects. I think it's a software driver as well. I keep trying to change it to the other one (the one your supposed to use, can't remember the name) but it just blanks out the screen when it loads past grub. I have been reading up on the ATI x series cards and ubuntu and it seems like it's really hard to get both of them working correctly together. I might be looking for a new distro.
Section of my xorg.conf

Section "Device"
Identifier "Generic Video Card"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Last edited by narcispy; 06-19-2007 at 07:09 PM.
 
Old 06-20-2007, 08:05 AM   #4
bneal
Member
 
Registered: Jun 2007
Location: Oklahoma City, OK
Distribution: RHEL 4; Suse 10.1, 10.2, FC6, Fedora 7
Posts: 57

Rep: Reputation: 15
here is some instructions I found on Ubuntu's Site

http://ubuntuforums.org/showpost.php?p=423584
 
Old 06-20-2007, 10:27 AM   #5
narcispy
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bneal
here is some instructions I found on Ubuntu's Site

http://ubuntuforums.org/showpost.php?p=423584
Yeah I have seen that guide and went though it. Problem is when I enter those commands it can't find the driver, it says 0 changed so it really didn't change anything in the config file. If I manually select the fglrx file in the configuration when I boot past grub it still blanks out. Near the bottom of that it says that when you enter the fglrxinfo command I have entered mine in once before and gotten a response, normally doesn't say anything but it said the driver was Mesa. What's weird is if I run ubuntu as a live cd I can enable 3d effects, not sure which driver it is using but they work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
desktop effects could not be enabled wuchee Linux - Desktop 7 06-19-2007 08:13 AM
How do I enable desktop effects in Xubuntu? coolblue Ubuntu 1 04-20-2007 09:29 PM
I canīt enable desktop effects skullhunterph Fedora 3 04-01-2007 06:30 PM
Desktop-Effects zmanods Fedora 6 02-23-2007 08:53 AM
Help Please: FC6, Nvidia 96.29, Lose window frames when i enable desktop effects RottenMutt Fedora 13 02-05-2007 11:15 PM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration