LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-02-2006, 01:42 PM   #1
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Rep: Reputation: 31
cannot access my windows partition


Here is my Fstab on ubuntu 5.10 breezy:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / reiserfs notail 0 1
/dev/hda1 /media/hda1 ntfs defaults 0 0
/dev/hdb1 /media/hdb1 vfat defaults 0 0
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0


I have an hda1 icon on my desktop that just showed up after the install, but I get an error informing me that I do not have permission to access this partition!

Its Crazy...

The last install of ubuntu that I performed, I had to manually add hda1 and hdb1 to my fstab.

After that I could access either one!

THIS time, hda1 and hdb1 were ALREADY mounted but NOW I cant access hda1!

I think that I just noticed a possible symptom! The first install, I used 'ext3' file system.

On this install, I used rieserfs! Ya Think?

Last edited by randell6564; 06-02-2006 at 01:45 PM.
 
Old 06-02-2006, 01:55 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
The root filesystem shouldn't matter.

Are you having problems mounting it or accessing it as a specific user?

Can you post the output from the following as root:
mount
ls -l /media/hda1 | head
 
Old 06-02-2006, 01:57 PM   #3
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
UPDATE:

I went and added 'root' to 'system>administration>users and groups.

THEN I went to 'System>administration>login screen setup,

clicked on the 'security' tab and selected, "Allow root to login with GDM".

In root, I can now access hda1, BUT...

I would like to be able to access it as default user!
 
Old 06-02-2006, 02:04 PM   #4
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
It is mounted already.

I cant access it as default 'user'

Here is the "output"

root@Home:~# mount
/dev/hda2 on / type reiserfs (rw,notail)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
tmpfs on /lib/modules/2.6.12-10-386/volatile type tmpfs (rw,mode=0755)
/dev/hda1 on /media/hda1 type ntfs (rw)
/dev/hdb1 on /media/hdb1 type vfat (rw)
tmpfs on /dev type tmpfs (rw,size=10M,mode=0755)
root@Home:~# ls -l /media/hda1 | headls -l /media/hda1 | head


root@Home:~# ls -l /media/hda1 | head
total 1309600
-r-------- 1 root root 32 2006-05-27 11:19 ALCSetup.log
-r-------- 1 root root 0 2006-05-27 10:14 AUTOEXEC.BAT
-r-------- 1 root root 211 2006-05-27 10:07 boot.ini
-r-------- 1 root root 0 2006-05-27 10:14 CONFIG.SYS
dr-x------ 1 root root 4096 2006-05-27 10:19 Documents and Settings
-r-------- 1 root root 535351296 2006-06-02 02:29 hiberfil.sys
-r-------- 1 root root 0 2006-05-27 10:14 IO.SYS
-r-------- 1 root root 0 2006-05-27 10:14 MSDOS.SYS
-r-------- 1 root root 47564 2004-08-04 05:00 NTDETECT.COM


Note: I Have NO problem with accessing vfat. just hda1.

Last edited by randell6564; 06-02-2006 at 02:06 PM.
 
Old 06-02-2006, 02:14 PM   #5
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
I'm a linux 'newb' but I'm pretty good with DOS and I see somthing familiar!

-r
-r
-r...

The output shows hda1 as a NO READ!

I need to change permissions, Correct?
 
Old 06-02-2006, 02:56 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
If you want to access it as a normal user/users you'll need to supply uid and umask values to the options column in the fstab file.

Do you just want to allow read only access to 1 user?
 
Old 06-02-2006, 03:00 PM   #7
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
I am the only user.

I want full access as user.

Is that possible?

I dont want to keep logging in as root.

What are these "values"?
 
Old 06-02-2006, 04:25 PM   #8
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,395
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
In /etc/fstab, change

Code:
/dev/hda1 /media/hda1 ntfs defaults 0 0
to

Code:
/dev/hda1 /media/hda1 ntfs uid=your_user_id,gid=your_user_id,rw,umask=0000,fmask=777,dmask=777 0 0
You might not need the gid setting, or the dmask setting. You might only need fmask=700 & dmask=700. Use the least permissions that still allow you to work.

--- rod.
 
Old 06-02-2006, 06:08 PM   #9
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
Thank You!
 
Old 06-03-2006, 07:33 AM   #10
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
Sorry...

But I still cant get in as user!

Here is my fstab now:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / reiserfs notail 0 1
/dev/hda1 /media/hda1 ntfs uid=scott,gid=scott,rw,umask=0000,fmask=777,dmask=777 0 0
/dev/hdb1 /media/hdb1 vfat defaults 0 0
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0


Does the spacing between text matter?
 
Old 06-03-2006, 02:00 PM   #11
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,395
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Hmmm. Your fstab looks good to me. There should be no spaces,tabs, other whitespace within any of the fields.

What are the permissions on the mountpoint? Is there any feedback when you do 'mount -a' (as root)? What are the permissions in the mountpoint after the ntfs filesystem is mounted?

--- rod.
 
Old 06-03-2006, 11:32 PM   #12
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
When I am logged on as root, the permissions are as follows:

'Owner' is 'Execute' only. And it will not allow me to change it!

'Group' is 'read only'

and 'Others' is 'read only'!

When I try to check 'read/write boxes, I get this error:

Couldn't change the permissions of "hda1" because it is on a read-only disk

I'll log on as user and give you the response to "mount -a"
 
Old 06-03-2006, 11:43 PM   #13
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
ok...

as user, I get the following message when typing 'mount -a' in terminal:

scott@Home:~$ mount -a
mount: only root can do that


It's kinda crazy that I cant have 'read/write' permissions as 'Root'!

The first time that I installed breezy, I had to add hda1 and hdb1
to my fstab.

But after adding them, I had no problem accessing hda1 as user!

Then just for giggles, I reinstalled breezy (the exact same way that it was installed the first time) and THIS time hda1 and hdb1 were already mounted but I could only access hdb1!

Oh yeah, I forgot to mention that I can only read and execute as user
in hdb1 which is just my fat32 storage drive!

I usually like to transfer my music onto hdb1 and any important files and now I cant without doing it as root!

weird!
 
Old 06-04-2006, 12:11 AM   #14
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
Quote:
Originally Posted by randell6564
ok...

as user, I get the following message when typing 'mount -a' in terminal:

scott@Home:~$ mount -a
mount: only root can do that
You're supposed to do
Code:
sudo mount -a
Quote:
It's kinda crazy that I cant have 'read/write' permissions as 'Root'!
Read this:
http://www.psychocats.net/ubuntu/permissions

and this:

http://www.psychocats.net/ubuntu/mountwindows
 
Old 06-04-2006, 01:20 AM   #15
randell6564
Member
 
Registered: Nov 2005
Location: California USA
Distribution: Ubuntu,(Feisty Fawn) Windows XP(Home Edition)
Posts: 634

Original Poster
Rep: Reputation: 31
thanks!

I'll go and check that out!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot access windows partition from fedora. MuncherOfSpleens Linux - Newbie 8 06-10-2005 05:36 AM
How can I access files in my Windows 98 partition from my Linux partition, /w BASH? Fabyfakid Linux - Newbie 4 09-17-2004 11:05 PM
Can't Access Windows Partition nostrum Linux - Newbie 8 06-18-2004 11:17 PM
Access to windows partition? DeadlySin3 Linux - Newbie 2 05-05-2003 10:46 AM
Again, how to access windows partition MrPolite Linux - General 26 06-29-2002 02:34 AM


All times are GMT -5. The time now is 03:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration