LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2008, 09:33 PM   #1
tidiman07
Member
 
Registered: Apr 2006
Distribution: Kubuntu 8.04
Posts: 129

Rep: Reputation: 15
Unhappy Can't startx; FreeFontPath: FPE log message


Yesterday my system broke! I reboot to get to windows to take care of something and when i tried to boot back into Kubuntu Gutsy it goes to login manager. I had automatically set it to login and all.
When i type in the user and pass, it flashes screen like its starking the Desktop but then it goes back to login window.
I proceeded to a console session to figure things out. The last thing i installed was skype before i rebooted, so i purged it- still no fix.
When i do startx, it flashes Desktop for a sec then goes back to console. I took a look at /var/log/Xorg.0.log and found this:
....
Quote:
(II) I810(0): xf86UnbindGARTMemory: unbind key 5
(II) I810(0): xf86UnbindGARTMemory: unbind key 6
(II) I810(0): xf86UnbindGARTMemory: unbind key 7
(WW) I810(0): Successfully set original devices (2)
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.
searching forums told me that the last line was not significant to cause X to stop so i purged all xserver-xorg applications and reinstalled them. Tried startx, nothing, flashes like it normally does to start the Desktop, but goes back to console. I have not made changes to xorg.conf or anything. I've been scanning the log file and cant find nothing our of line.

Please help me out, I've exhausted my knowledge base.

Thanks,
 
Old 03-19-2008, 04:06 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Look at the kde log
 
Old 03-19-2008, 11:37 PM   #3
tidiman07
Member
 
Registered: Apr 2006
Distribution: Kubuntu 8.04
Posts: 129

Original Poster
Rep: Reputation: 15
Thanks comprookie2000. When I looked at it was a dbus error.
Turns out its an Xorg bug, i was missing a directory, session.d.
I just
Quote:
$ sudo mkdir /etc/dbus-1/ session.d
Then startx,

Thanks,
 
Old 10-30-2008, 10:59 AM   #4
federicodemaria
LQ Newbie
 
Registered: Oct 2008
Posts: 7

Rep: Reputation: 0
i have the same problem
i tried, but...


$ sudo mkdir /etc/dbus-1/ session.d

mkdir: no se puede crear el directorio 'etc/dbus-1/' : el fichero ya existe

username@systemname:~$


(((in english:
mkdir: impossible to create directory 'etc/dbus-1/': the file already exists)))

And now?

thanx
f
 
Old 10-30-2008, 02:55 PM   #5
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Going to need a lot more information. What distro? What Desktop Manager?
Did you look at /var/log/Xorg.0.log ?
 
Old 10-31-2008, 04:57 AM   #6
federicodemaria
LQ Newbie
 
Registered: Oct 2008
Posts: 7

Rep: Reputation: 0
well, i'm a very beginner, so...
- kubuntu 7.04
- Desktop manager, i don't know. Might it be kdm?
- What is /var/log/Xorg.0.log?
I removed /tmp/.X0-lock

my complete story at
http://www.linuxquestions.org/questi...-loop.-679948/


i do appreciate your help,
sorry for the ignorance :->

fede
 
Old 10-31-2008, 06:03 AM   #7
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
What happens when you try startkde as a regular user not root.
 
  


Reply

Tags
dbus


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
neat command not working azx_get_response timeout message in /var/log/message ninadshaha Red Hat 1 02-19-2008 03:32 PM
Strange Repeating Error message in /var/log/message lucktsm Linux - Security 2 10-27-2006 09:29 AM
Slackware 10.0: Error message after giving startx command Fozmo Slackware - Installation 1 05-31-2006 10:38 PM
message, message.1 in /var/log/ can be deleted for space? phpsharma Linux - Newbie 4 11-17-2004 01:23 PM
/var/log/kern.log message dimkal Linux - Hardware 1 05-08-2004 07:57 AM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration