LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2006, 03:33 PM   #1
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Rep: Reputation: 15
Can't determine DISPLAY. Aborting.


After I installed some upgrades, and new packages on my ubuntu Dapper computer it will not start up a desktop session. I previously was running breezy, but I upgraded to dapper. Everything ran fine for a month before now. When I switch to a terminal and try starting kde by running the folloing command

Code:
kdesktop
I get this error

Code:
ERROR: KUniqueApplication: Can't determine DISPLAY. Aborting.
Then the computer goes back to command line.

When I am in the kdm login manager, it starts up fine. Thin when I type in the user name and password, everything goes blank for a little bit, and then the computer goes back to the log-in manager.
 
Old 05-16-2006, 03:45 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try running "startx" instead of "kdesktop".
 
Old 05-16-2006, 09:16 PM   #3
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
FYI -- if you update the display driver and it fails in some way. Your system will only boot to level 3, command line. If you update included a kernel update, you will need to re-install 3D support such as that from Nvidia. I wouldn't be surprised if the same wasn't true for ATI cards.
 
Old 05-17-2006, 09:59 AM   #4
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Original Poster
Rep: Reputation: 15
Ok, I tried running startx from the command line and this is the error that it popped up.

dlopen: /usr/lib/xorg/modules/extensions/libGLcore.so: undefined symbol: __glXLastContext

(EE) Failed to load /usr/lib/xorg/modules/extensions/libGLcore.so

(EE) Failed to load module "GLcore" (loader failed, 7)

waiting for X server to shut down FreeFontPath: FPE "/usr/share/X11/fonts/misc/" refcount is 2, should be 1: fixing.
 
Old 05-17-2006, 10:20 AM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
There is a problem with your glx settings. You can disable glx in /etc/X11/xorg by changing
Code:
Load         "glx"
to
Code:
#Load         "glx"
You will be able to log into X, but you will have no 3d acceleration. What graphics card are you using. If its nvidia, try reinstalling the driver and then enabling glx.
 
Old 05-18-2006, 09:53 AM   #6
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Original Poster
Rep: Reputation: 15
I tried doing a complete removal of all the xserver stuff and then reinstalling it. Now I get this error when I run startx from the command line.

Code:
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: May 18 10:31:50 2006
(==) Using config file: "/etc/X11/xorg.conf"
(EE)xf86OpenSerial: Cannot open device /dev/wacom
       No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE)xf86OpenSerial: Cannot open device /dev/wacom
       No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE)xf86OpenSerial: Cannot open device /dev/wacom
       No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE)xf86OpenSerial: Cannot open device /dev/wacom
       No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE)xf86OpenSerial: Cannot open device /dev/wacom
       No such file or directory.
Error opening /dev/wacom : No such file or directory
(EE)xf86OpenSerial: Cannot open device /dev/wacom
       No such file or directory.
Error opening /dev/wacom : No such file or directory

waiting for X server to shut down FreeFontPath: FPE "/usr/share/X11/fonts/misc" refcount is 2, should be 1; fixing.
 
Old 05-18-2006, 01:48 PM   #7
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Wacom pads are a special case and we don't know if you have one. X thinks you do and can't find the mount point for it. Odds are you don't actually have one and installing X out of context gave this result. Probably fixable by editing wacom out of "/etc/X11/xorg.conf".
 
Old 05-18-2006, 02:15 PM   #8
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
I don't think there was any need to remove and reinstall xorg. You could have resolved your problem by following what I said above. Anyway, you now need to reconfigure X using xorgconfig or "dpkg-reconfigure xorg-x11".
 
Old 05-18-2006, 02:45 PM   #9
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Original Poster
Rep: Reputation: 15
reddaz: I did try what you said, but it still wouldn't work.

Here is a link to a copy of my xorg.conf file.

I tried running dpkg-reconfigure xserver-xorg, and that didn't do any good either. I do not have a wacom pad.

So what should I change in my xorg.conf file?
 
Old 05-18-2006, 02:53 PM   #10
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Original Poster
Rep: Reputation: 15
Ok, here is a link to what I changed my xorg.conf file to

Now when I try to run startx it still won't start, and this is the message it has:

Code:
waiting for X server to shut down FreeFontPath: FPE "/usr/share/X11/fonts/misc refcount is 2, should be 1; fixing.
 
Old 05-18-2006, 02:56 PM   #11
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
I found a wacom tablet specified 3 times in your xorg.conf. Delete the following lines from xorg.conf and it may now work:

-<start of delete>-
Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection
-<end>-
 
Old 05-18-2006, 02:58 PM   #12
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Original Poster
Rep: Reputation: 15
fragos: yea, I did get that figured out, I just put # in front of those lines, and that error is no more. but it still doesn't work.
 
Old 05-18-2006, 03:07 PM   #13
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
seashell11: Perhaps someone wiser than I can help you repair this. I'm primarily a SuSE user that has tried Ubuntu 6.06 a few weeks back. I had none of your problems. If it was me, I'd first verify the install disk and then re-install. It may not make a difference but I tried the Ubuntu live 6.06. It has an icon on the desktop to install from the live CD.
 
Old 05-18-2006, 03:42 PM   #14
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Original Poster
Rep: Reputation: 15
Ok, found out how to make it work. I was using the kdm login manager, before. Now from the command line I just typed in gdm, loaded the gdm login manager, I chose kde for the session type and everything works fine. So it must be something wrong with kdm.
 
Old 05-18-2006, 03:46 PM   #15
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
The first error was about GLX and thats the one I was referring to in my previous post. Since you managed to solve the wacom stuff, whats the exact problem that you are currently facing. Saying "it doesn't work" is not helpful since it lacks any detailed info about the problem.
 
  


Reply

Tags
xorg, xserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Caught signal 11. Server aborting Gosa Debian 4 02-27-2007 02:03 AM
kdeinit: Aborting. $DISPLAY is not set holdmejesus Linux - Software 1 10-26-2005 11:04 AM
z600 Lexmark driver is always aborting KasperLotus Linux - Hardware 1 10-07-2005 09:59 PM
Aborting with an error when i use pbuilder sakulaqi Debian 0 08-07-2005 08:42 AM
"can't determine DISPLAY" pingu Debian 4 04-12-2005 03:46 AM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration