LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 10-29-2011, 11:19 AM   #1
jay_pablo_69
Member
 
Registered: Dec 2009
Posts: 60
Blog Entries: 3

Rep: Reputation: 1
Can't Access Partition After GParted Install


Hi,

I installed 'GParted' on my Ubuntu 11.10, and now on boot all my partitions are not showing up on Nautilus even though they are mounted, as shown on GParted and also Terminal.

I ran
Code:
$ sudo chown -R username /media/Cine
and it displayed:
Code:
chown: changing ownership of `/media/Cine': Read-only file system
And
Code:
$ sudo chmod -R 755 /media/Cine
and got the same thing.

Then, I ran 'fsck' and got this:
Code:
$ sudo fsck /dev/sda7
fsck from util-linux 2.19.1
fsck: fsck.ntfs: not found
fsck: Error 2 while executing fsck.ntfs for /dev/sda7
I searched the web and someone wrote that the partition has to be unmounted as 'read-only' and remounted as 'read-write', so I typed and got this:
Code:
$ sudo mount -o rw,remount /media/Cine
mount: warning: /media/Cine seems to be mounted read-only.
When I execute
Code:
sudo mount -o rw /media/Cine
it says the partition has been mounted as 'read-only'.

And also I don't know why, but now when I plug in a USB drive and try to copy files into it, I get a notification that the drive is 'read-only'.

Pls how do I resolve this USB problem, change the partition permission and get the partition to show on Nautilus as before?

Thanks.

Last edited by jay_pablo_69; 10-29-2011 at 11:25 AM.
 
Old 10-29-2011, 08:34 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
You can only fsck an unmounted device, otherwise you destroy the contents. For an NTFS device, you should be checking it on Windows, not Linux. There is a very basic ntfsfix command, but if you like your data I don't recommend using it.
 
Old 10-29-2011, 09:10 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,487

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
I'd be guessing you don't have ntfs-3g installed, and are using the in-kernel NTFS support.
And yes, NTFS fsck is (deliberately) of only limited use.
 
Old 10-30-2011, 09:16 AM   #4
jay_pablo_69
Member
 
Registered: Dec 2009
Posts: 60
Blog Entries: 3

Original Poster
Rep: Reputation: 1
Thanks guys for your replies.
I just installed NTFS-3G and changed the FSTAB 'ntfs' handler for the partitions to 'ntfs-3g' and now the HDD partitions are all mounted and placed on Nautilus. However, I still have the USB problem. All connected USB drives are auto-mounted with 'ntfs' as 'read-only', so I cannot write to it.

This is the printout of [ $ sudo mount ]:

Code:
/dev/sda9 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/sda5 on /media/abc12 type fuseblk (rw,allow_other,blksize=4096)
/dev/sda6 on /media/abc34 type fuseblk (rw,allow_other,blksize=4096)
/dev/sda7 on /media/abc56 type fuseblk (rw,allow_other,blksize=4096)
/dev/sda8 on /media/abc78 type fuseblk (rw,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/USERNAME/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=obiora)
/dev/sdb on /media/My2GBFlashDrive type ntfs (ro,nosuid,nodev,allow_other,blksize=4096,default_permissions)
I tried this: [ $ sudo ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs ] and here's the result:
Code:
/dev/sdb on /media/My2GBFlashDrive type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
It did change the handler to 'ntfs-3g' (fuseblk) but when I try to copy files into it I get an error message:
Quote:
Error while copying <filename>
There was an error while copying the file into /media/My2GBFlashDrive
Under "Show more details":
Quote:
Error opening file '/media/my2GBFlashDrive/<filename>': input/output error
Pls how do I resolve this USB issue? How do I change the USB handler from 'ntfs' to 'ntfs-3g'?

Thanks for your assistance.

Last edited by jay_pablo_69; 11-01-2011 at 08:48 AM.
 
Old 10-30-2011, 10:25 AM   #5
jay_pablo_69
Member
 
Registered: Dec 2009
Posts: 60
Blog Entries: 3

Original Poster
Rep: Reputation: 1
Also after shutdown and startup, on Ubuntu splash screen, it says:
Quote:
Error mounting partitions
Press S to skip mounting this partition or M to manually mount this partition
I skipped the step.

Then boot and login, the partitions show up on Nautilus but when I click on any one (for example, if I click on 'abc12' partition) it says:
Quote:
Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sda5 on /media/abc12
Pls I need some help.

Thanks.
 
Old 10-30-2011, 12:22 PM   #6
jay_pablo_69
Member
 
Registered: Dec 2009
Posts: 60
Blog Entries: 3

Original Poster
Rep: Reputation: 1
Quote:
Also after shutdown and startup, on Ubuntu splash screen, it says:
Quote:
Error mounting partitions
Press S to skip mounting this partition or M to manually mount this partition

I skipped the step.

Then boot and login, the partitions show up on Nautilus but when I click on any one (for example, if I click on 'abc12' partition) it says:
Quote:
Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sda5 on /media/abc12


This error has been fixed.

But the USB problem above still remains.

Pls any assistance is appreciated.

Last edited by jay_pablo_69; 11-01-2011 at 04:26 PM.
 
Old 11-10-2011, 01:57 AM   #7
poly_s
Member
 
Registered: Sep 2011
Distribution: Arch
Posts: 46

Rep: Reputation: Disabled
Hi

Don't know if its too late for you but I had this problem as well.

I installed ntfs-3g AND ntfsprogs and it worked like a charm after.

Good luck
 
Old 11-11-2011, 01:01 AM   #8
jay_pablo_69
Member
 
Registered: Dec 2009
Posts: 60
Blog Entries: 3

Original Poster
Rep: Reputation: 1
poly_s.... I can't thank you enough. THANK YOU! THANK YOU! THANK YOU!
 
Old 11-11-2011, 11:05 AM   #9
poly_s
Member
 
Registered: Sep 2011
Distribution: Arch
Posts: 46

Rep: Reputation: Disabled
YAY

Thats the first time I've helped someone in the linux community. Im so happy.

THANKYOU for the bash wallpaper on your blog

Take it easy.
 
Old 11-28-2011, 10:39 AM   #10
bigcam87
LQ Newbie
 
Registered: Nov 2011
Posts: 1

Rep: Reputation: Disabled
how to install both...?

I am having the same problem with my ntfs drives being read-only after installing gparted on 11.10.

When I try to install ntfs-3g or ntfsprogs from synaptic package manager or via terminal the other one is removed.

How can I have both installed?
 
Old 01-25-2012, 04:49 AM   #11
amerllica
LQ Newbie
 
Registered: Jan 2012
Location: Great Persia
Distribution: Ubuntu 11.10
Posts: 1

Rep: Reputation: Disabled
Angry Please

Quote:
Originally Posted by jay_pablo_69 View Post
poly_s.... I can't thank you enough. THANK YOU! THANK YOU! THANK YOU!
I've same problem, i installed ubuntu 11.10 a month ago, and i have full access on my hard disk drive and USB hard disks, but one day i setup GPARTED and from this day all of my hard disks have Read-Only permission, i use power codes in linux shell but my problem does not solve... last night i cut and create a new partition bye gparted, i have a drive that has 100G volume, i cut 70G and format it to EXT4, i know it is unbelievably, but the EXT4 drive that has 70G volume, was Read-Only .. !!!!!!
i think this problem is form Windows FileSystem, but last night i found that all partition that create by Gparted will be Read-Only...
i read this page and i guess if i install "ntfs-3g" package, the ntfs drives will be Read\Write permission, how i can solve the problem about EXT4 drives,
Furthermore... Why Gparted kill my Hards, Why Gparted Betrays Linux ?!! x-(
I thought Gparted is a unique application for partition management, but at now, i think this application work as VIRUS... i wanna report this bug but i don't know how... if you can't solve my problem show a way to me for reporting this bug.

Last edited by amerllica; 01-25-2012 at 05:46 AM. Reason: Bad Title, I forgot write Title completely
 
  


Reply

Tags
gparted, partition, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost (access to?) Windows partition after Gparted wiped the old Linux one! pofadda Linux - Newbie 13 03-22-2011 07:49 PM
Invalid partition table for swap partition that I moved with Gparted keith9e Linux - Hardware 16 02-10-2010 01:21 PM
Gparted: Joining 2 partition ext3 within one partition (data saved) Davno Linux - Software 1 12-11-2009 05:24 PM
canīt access the newly created EXT3 partition by GPARTED in kubuntu mehdiee Linux - Newbie 3 02-15-2008 04:04 PM
Gparted for a new partition mcbenus Linux - Software 10 09-09-2007 09:37 PM


All times are GMT -5. The time now is 08:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration