LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 08-01-2006, 10:40 AM   #1
mcnearcj
LQ Newbie
 
Registered: Mar 2005
Posts: 5

Rep: Reputation: 0
Broken packages


I'm trying to run scorched3d but I keep getting this error when I run it.

scorched3d: error while loading shared libraries: libSDL_net-1.2.so.0: cannot open shared object file: No such file or directory

When I try to install the libraries I get this error from apt

libglib2.0-dev: Depends: libglib2.0-0 (= 2.10.2-1ubuntu3) but 2.10.3-0ubuntu1 is to be installed
 
Old 08-01-2006, 10:56 AM   #2
fourchannel
LQ Newbie
 
Registered: Jul 2006
Location: Tuscaloosa, AL - USA
Distribution: Gentoo
Posts: 29

Rep: Reputation: 15
Can you post the output from running these 2 commands?
Code:
sudo apt-get -s install libsdl-net1.2
Code:
sudo apt-get -s install scorched3d
_____
EDIT:

It looks like you need to install libsdl-net1.2 at first glance, try this and if that doesn't work, then post the output from those commands.
Code:
sudo apt-get install libsdl-net1.2

Last edited by fourchannel; 08-01-2006 at 10:59 AM.
 
Old 08-01-2006, 01:40 PM   #3
mcnearcj
LQ Newbie
 
Registered: Mar 2005
Posts: 5

Original Poster
Rep: Reputation: 0
now i get the error

error while loading shared libraries: libwx_gtk-2.4.so.1
 
Old 08-01-2006, 02:56 PM   #4
fourchannel
LQ Newbie
 
Registered: Jul 2006
Location: Tuscaloosa, AL - USA
Distribution: Gentoo
Posts: 29

Rep: Reputation: 15
hm... well try running this command, its everything scorched3d depends on.

Code:
 sudo apt-get install libc6 libfreetype6 libgcc1 libgl1-mesa libglu1-mesa libsdl-mixer1.2 libsdl-net1.2 libsdl1.2debian libstdc++6 libwxgtk2.4-1 zlib1g scorched3d-data scorched3d
and answer yes to install any extra packages.

See if that fixes your problem, if not could you copy and paste the exact output of the command.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A lot of broken *-common packages? Tons of Fun Debian 1 01-28-2006 02:13 PM
Broken Packages hongman Linux - Software 2 04-13-2005 06:48 AM
what's with all those broken packages darkleaf Debian 8 09-29-2004 02:40 PM
apt-get + broken packages = death ulaoulao Linux - Software 2 09-19-2004 10:55 AM
Broken Packages Kujila Linux - Software 2 02-01-2004 06:07 PM


All times are GMT -5. The time now is 04:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration