LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-12-2007, 11:43 PM   #1
dissolved soul
Member
 
Registered: Sep 2002
Posts: 35

Rep: Reputation: 15
Booting my new ubuntu install = "GRUB GRUB GRUB GRUB GRUB" etc.


I've got 4 hard drives. 2x 160gb SATA drives, 2x 300gb ATA drives. All 4 drives were formatted, and I installed ubuntu on one of the 300 gig drives (the IDE master, drive 0 as the installer recognized).

When i boot up after the install, i just get "GRUB" looping over and over.

I've reinstalled honestly a dozen times a least (trying different configurations with these drives), with no luck. I've followed instructions on this board to reinstall grub to the MBR, which didn't change anything.

menu.lst
Code:
title           Ubuntu, kernel 2.6.17-10-generic
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.17-10-generic root=/dev/hda1 ro quiet splash
initrd          /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title           Ubuntu, kernel 2.6.17-10-generic (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.17-10-generic root=/dev/hda1 ro single
initrd          /boot/initrd.img-2.6.17-10-generic
boot

title           Ubuntu, memtest86+
root            (hd0,0)
kernel          /boot/memtest86+.bin
quiet
boot
device.map (my install is on /dev/hda)
Code:
(hd0)   /dev/hda
(hd1)   /dev/hdb
(hd2)   /dev/sda
(hd3)   /dev/sdb
/etc/fstab
Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/hda1
UUID=56ef1b08-6e5b-4a1d-9741-c7000e107eba /               ext3    defaults,errors=remount-ro 0       1
# /dev/hda5
UUID=dcd8634b-85d6-4425-a013-85b5f96877a0 none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
What am I doing wrong? This is starting to become very frustrating.

edit: I did some google searching and found that a possible cause for this may be having the BIOS auto-detect hard drives, and the solution is to turn that feature off and specify what they are so it doesn't need to detect them. My bios (my mobo is DFI ultra infinity) either allows auto detect to be on, or no drive to be specified. So, basically, if I have auto detect off I have no hard drives.

Anyone have any ideas?

Last edited by dissolved soul; 01-13-2007 at 01:30 AM.
 
Old 01-13-2007, 09:43 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
We need to know what the BIOS thinks is the first HD. (I suppose it is possible that the Linux installer had a different opinion)

One clue: Is there any way that GRUB could be on one of the other 3 drives?---eg if any of then ever had Linux installed.

Another thing to try is to boot from the Ubuntu install CD and either go from there to the Ubuntu install--or just ctrl-alt-F1 to get to a terminal.
From any terminal:
Code:
fdisk -l        to see what partitions are in place and to confirm Ubuntu is on hda1
then, put GRUB on a floppy:
grub         starts the grub shell
root (hd0,0)    This tells grub where "home base" is.  It must be the partition containing /boot.  When you issue this command, grub tells you what the partition type is and what filesystem is there.  Make sure it is the right thing.  If not try different drive and partition #s--remember that grub counts from zero and ALL drives are hd
setup (fd0)   installs grub to a floppy
More options:
disconnect the SATA drives
try installing on one of the SATAs
 
Old 01-13-2007, 12:55 PM   #3
dissolved soul
Member
 
Registered: Sep 2002
Posts: 35

Original Poster
Rep: Reputation: 15
Well, I figured out the problem... figured I'd post it in case someone else comes across the same problem.

Auto detect in my BIOS didn't need to be off. I turned that back ON. In the same section (right below "auto detect") in my bios was a field called "Access Mode". It was set at the default "CHS" for both drives. I changed both of them to auto. Problem solved.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo... grub problems... "/boot/grub/stage1" exists... no halo14 Gentoo 5 02-06-2011 04:50 PM
Grub freezes with "GRUB" text on HP Visualize X-Class trainpic Linux - General 3 10-27-2009 01:32 AM
GRUB dual boot problem: Boot "other" (windows) just restarts GRUB! stevod333 Linux - Software 13 04-06-2006 05:26 AM
GRUB bootloader spits out "GRUB hard disk error" Crampedson Linux - Software 2 01-26-2005 06:34 PM
GRUB GRUB GRUB GRUB "Whats Going on?" Gaweph Linux - Newbie 6 03-26-2004 10:40 AM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration