LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Boot with 'acpi=no'-Ubuntu shows one core,normal boot-kacpid process is eating 70%CPU (http://www.linuxquestions.org/questions/ubuntu-63/boot-with-acpi%3Dno-ubuntu-shows-one-core-normal-boot-kacpid-process-is-eating-70cpu-621431/)

WebEyeX 02-15-2008 02:13 PM

Boot with 'acpi=no'-Ubuntu shows one core,normal boot-kacpid process is eating 70%CPU
 
Hi,
I am facing very strange problem.Ectually its started coming up from first day.At the time of installation i had to use 'acpi=no' boot parameter because without it system just got hang.Now if i boot without 'acpi=no' 'kacpid' process is eating 60%-70% CPU and if i use 'acpi=no' boot parameter Ubuntu is showing only one core of my Dual core processer.

I know acpi is creating some problem.Here is the out put of 'dmesg | grep CPU' command

[ 0.000000] Initializing CPU#0
[ 35.402589] SLUB: Genslabs=22, HWalign=64, Order=0-1, MinObjects=4, CPUs=1, Nodes=1
[ 35.482968] CPU: After generic identify, caps: bfebfbff 20100000 00000000 00000000 0000e49d 00000000 00000001
[ 35.483057] CPU: Trace cache: 12K uops, L1 D cache: 16K
[ 35.483119] CPU: L2 cache: 2048K
[ 35.483156] CPU: Physical Processor ID: 0
[ 35.483193] CPU: Processor Core ID: 0
[ 35.483230] CPU: After all inits, caps: bfebfbff 20100000 00000000 0000b180 0000e49d 00000000 00000001
[ 35.783531] CPU0: Intel(R) Pentium(R) D CPU 3.00GHz stepping 05
[ 35.998415] Brought up 1 CPUs


As you can see it is showing and using only one core of Dual core processor...

How to solve this problem?I searched a lot about this but unable to find any solution.
My system specs are..
Intel Pentium D processor 3.0 Ghz
Intel 945GCNL motherboard
Windows XP + Ubuntu 7.10(Dual boot)

Thanks and Regards

pajoe 02-15-2008 06:26 PM

If I use the Kubuntu, 64 bit desktop cd I get both processors but recently on my system running Kubuntu 32 bit, I only get 1 processor. I posted more details on the ubuntu forums. http://ubuntuforums.org/showthread.php?t=697423. I found your post while looking for possible fix for mine.

WebEyeX 02-16-2008 01:21 PM

Quote:

Originally Posted by pajoe (Post 3058636)
If I use the Kubuntu, 64 bit desktop cd I get both processors but recently on my system running Kubuntu 32 bit, I only get 1 processor. I posted more details on the ubuntu forums. http://ubuntuforums.org/showthread.php?t=697423. I found your post while looking for possible fix for mine.

I searched a lot and found that Ubuntu has this kinda problem with no solution...this need to be sort out.Because we all love Ubuntu...

pajoe 02-16-2008 02:17 PM

I think it has something to do with the kernel, but my wife's laptop is working fine. It took a while, several days over all but I got it working again. I ended up recompiling the kernel, and here is what I posted in the thread: http: //ubuntuforums.org/showthread.php?t=697423

quote:

It wasn't quick and easy, but I recompiled the kernel to 2.6.24.2 using KernelCheck http://kcheck.sourceforge.net/ which worked but I needed to do it several times until I learned you had to go into go into the configuration for Sound Advanced Linus System under PCI devices and select the HD Sound for the iIntel - even though I am not using the intel, in order to get the sound working.

In the process II also selected the "K7" option as I am using an AMD 64 dual core. I also needed to select memory higher than 4 gig so my full 4 gig of memory would be recognized. The first time I thought selecting 4 gig would do it, but had to go with the 64 gig - took several tries to get it all working.

The last compile I used the directions at http://ubuntuforums.org/showthread.p...=master+kernel
because I didn't need to download the source again and I didn't know how to set up kernelcheck to set up and compile without doiwnloading everything. It took a long time, several hours to recompile the kernel several times, I almost gave up and was ready to install the 64 bit version.

I needed to run envy again to reinstall my video drivers and I had to reinstall VirtualBox but it now seems to be working. I hope this helps someone else.


on edit : got "envy" at http://albertomilone.com/nvidia_scripts1.html

manoj_isi 05-18-2008 06:42 AM

solution to kacpid
 
Solution to kacpid which works fine for me :
After booting windows when boot linux kacpid starts, to stop it just cut the power supply to your PC including UPS if any , without shutting down (obviously after saving data) when linux desktop is active. yes i am saying that take the power cord out.

Now switch on the power of ur machine & boot linux, kacpid will not appear.(hopefully)

Happy Linuxing,

manoj_isi 05-18-2008 06:48 AM

solution to kacpid
 
Remember acpi=off will not work on dual core machines , if you use this only one core will get active


All times are GMT -5. The time now is 06:08 PM.