LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 09-21-2006, 11:47 AM   #1
liegerm
LQ Newbie
 
Registered: Feb 2006
Location: Kent, UK
Distribution: Ubuntu, Suse
Posts: 8

Rep: Reputation: 0
Blank screen when I log off or switch to a terminal


Hi,

I'm using Ubuntu Dapper Drake on an Acer laptop. Dapper is bang up to date as of today. Graphics is listed as follows in xorg.conf: 'VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video.'

The problem is that since upgrading from Breezy to Dapper, when I log off or change to another terminal using CTRL+ALT+F1/F2, etc, I just get a blank screen (it actually looks as if the screen loses power). The machine is still alive as the keyboard lights still work and, very occasionally, CTRL+ALT+BACKSPACE will restart X. I have seen other posts here and elsewhere with similar problems, but have not been able to fix it. I have tried using 'vga=normal' and 'vga=791' as kernel options. Inittab has tty entries for starting terminals 1 to 6. Dapper is bang up to date as of today.

Any help would be much appreciated.
 
Old 09-21-2006, 05:40 PM   #2
pda_h4x0r
Member
 
Registered: Feb 2006
Location: somewhere in cyberspace
Distribution: Debian, Familiar
Posts: 380

Rep: Reputation: 30
Quote:
Originally Posted by liegerm
I have tried using 'vga=normal' and 'vga=791' as kernel options
Did you remember to run "sudo grub-install /your/root/partition" after editing /boot/grub/menu.lst? Did you try specifying the options from the GRUB command-line?
 
Old 09-21-2006, 05:46 PM   #3
crash_override_me
Member
 
Registered: Aug 2005
Location: India, New Delhi
Distribution: Debian Etch, Ubuntu
Posts: 342

Rep: Reputation: 30
Quote:
Originally Posted by pda_h4x0r
Did you remember to run "sudo grub-install /your/root/partition" after editing /boot/grub/menu.lst? Did you try specifying the options from the GRUB command-line?
hey, i am having the same problem!!
& we're not talkin about GRUB issues, we are lookin at GDM hang up!!
 
Old 09-22-2006, 06:36 AM   #4
liegerm
LQ Newbie
 
Registered: Feb 2006
Location: Kent, UK
Distribution: Ubuntu, Suse
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pda_h4x0r
Did you remember to run "sudo grub-install /your/root/partition" after editing /boot/grub/menu.lst? Did you try specifying the options from the GRUB command-line?
Thanks for your reply.

I'm by no means an expert, but I didn't think it was neseccary to reinstall Grub just to specifiy a kernel option. If I'm wrong, please tell me. No, I didn't try it on the Grub command line, I edited menu.lst.

Besides that, the system boots and works fine until I log off or try switching to another console (tty1, 2, 3, etc) using CTRL+ALT+F1, etc. Then, the screen just goes blank.
 
Old 09-22-2006, 03:26 PM   #5
pda_h4x0r
Member
 
Registered: Feb 2006
Location: somewhere in cyberspace
Distribution: Debian, Familiar
Posts: 380

Rep: Reputation: 30
Unfortunately, I think that you have to do a grub-install every time you edit /boot/grub/menu.lst to make the changes effective (same thing with LILO).
 
Old 09-23-2006, 11:55 AM   #6
crash_override_me
Member
 
Registered: Aug 2005
Location: India, New Delhi
Distribution: Debian Etch, Ubuntu
Posts: 342

Rep: Reputation: 30
Quote:
Originally Posted by pda_h4x0r
Unfortunately, I think that you have to do a grub-install every time you edit /boot/grub/menu.lst to make the changes effective (same thing with LILO).
I edited my menu.lst in Ubuntu, to get the Windows partition.., but did'nt have to do a grub-install.

also, how can doing so, solve our Blank screen issue( check the 1st post)??
 
Old 09-23-2006, 02:31 PM   #7
pda_h4x0r
Member
 
Registered: Feb 2006
Location: somewhere in cyberspace
Distribution: Debian, Familiar
Posts: 380

Rep: Reputation: 30
Sometimes NOT passing a VGA mode to the kernel prevents it from properly displaying text on the console. Passing "vga=791" to the kernel (or any other VGA mode your monitor supports) fixes it. But to pass it to the kernel, you need to a.) edit your /boot/grub/menu.lst and add the parameter, and b.) reinstall the GRUB bootloader to make that change effective. You did not mention in your origional post that you accomplished part (b), which would explain why it didn't work. Repeat: your bootloader configuration file is MEANINGLESS unless you REINSTALL the bootloader with that altered configuration file.
 
Old 09-23-2006, 06:12 PM   #8
crash_override_me
Member
 
Registered: Aug 2005
Location: India, New Delhi
Distribution: Debian Etch, Ubuntu
Posts: 342

Rep: Reputation: 30
so where do i put this "vga=791" option>>>
in /boot/grub/menu.lst ??
 
Old 09-24-2006, 01:04 AM   #9
pda_h4x0r
Member
 
Registered: Feb 2006
Location: somewhere in cyberspace
Distribution: Debian, Familiar
Posts: 380

Rep: Reputation: 30
You put it at the very end of the "kernel" option, with a space between it and the kernel file.

For example:

kernel /boot/vmlinuz-2.6.17 root=/dev/sda1 ro vga=791
 
Old 09-25-2006, 02:00 PM   #10
liegerm
LQ Newbie
 
Registered: Feb 2006
Location: Kent, UK
Distribution: Ubuntu, Suse
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pda_h4x0r
You put it at the very end of the "kernel" option, with a space between it and the kernel file.

For example:

kernel /boot/vmlinuz-2.6.17 root=/dev/sda1 ro vga=791
Thanks for your advice. But when I put vga=791 at the end of the kernel line, it takes immediate effect the next time I boot with that option - whithout needing to reinstall grub. Either way, it still doesn't get over the actual problem...

Has anyone else seen this problem and managed to cure it?
 
  


Reply

Tags
blank, logoff, screen, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 no logon screen - blank screen with X yorgmeister Fedora 15 01-24-2008 10:35 PM
X: can't switch from tty7 to ttyx to tty7 again: blank screen DaneM Slackware 11 08-26-2005 09:36 AM
Switch to pseudo terminal you didn't log out of? xnomad Linux - General 2 07-19-2005 01:35 AM
Ubuntu log out goes to blank screen?? halo14 Linux - Distributions 0 12-28-2004 10:55 AM
log off blank screen element Debian 2 09-28-2003 05:29 AM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration