LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Blank screen when I log off or switch to a terminal (http://www.linuxquestions.org/questions/ubuntu-63/blank-screen-when-i-log-off-or-switch-to-a-terminal-485663/)

liegerm 09-21-2006 10:47 AM

Blank screen when I log off or switch to a terminal
 
Hi,

I'm using Ubuntu Dapper Drake on an Acer laptop. Dapper is bang up to date as of today. Graphics is listed as follows in xorg.conf: 'VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video.'

The problem is that since upgrading from Breezy to Dapper, when I log off or change to another terminal using CTRL+ALT+F1/F2, etc, I just get a blank screen (it actually looks as if the screen loses power). The machine is still alive as the keyboard lights still work and, very occasionally, CTRL+ALT+BACKSPACE will restart X. I have seen other posts here and elsewhere with similar problems, but have not been able to fix it. I have tried using 'vga=normal' and 'vga=791' as kernel options. Inittab has tty entries for starting terminals 1 to 6. Dapper is bang up to date as of today.

Any help would be much appreciated.

pda_h4x0r 09-21-2006 04:40 PM

Quote:

Originally Posted by liegerm
I have tried using 'vga=normal' and 'vga=791' as kernel options

Did you remember to run "sudo grub-install /your/root/partition" after editing /boot/grub/menu.lst? Did you try specifying the options from the GRUB command-line?

crash_override_me 09-21-2006 04:46 PM

Quote:

Originally Posted by pda_h4x0r
Did you remember to run "sudo grub-install /your/root/partition" after editing /boot/grub/menu.lst? Did you try specifying the options from the GRUB command-line?

hey, i am having the same problem!!
& we're not talkin about GRUB issues, we are lookin at GDM hang up!!

liegerm 09-22-2006 05:36 AM

Quote:

Originally Posted by pda_h4x0r
Did you remember to run "sudo grub-install /your/root/partition" after editing /boot/grub/menu.lst? Did you try specifying the options from the GRUB command-line?

Thanks for your reply.

I'm by no means an expert, but I didn't think it was neseccary to reinstall Grub just to specifiy a kernel option. If I'm wrong, please tell me. No, I didn't try it on the Grub command line, I edited menu.lst.

Besides that, the system boots and works fine until I log off or try switching to another console (tty1, 2, 3, etc) using CTRL+ALT+F1, etc. Then, the screen just goes blank.

pda_h4x0r 09-22-2006 02:26 PM

Unfortunately, I think that you have to do a grub-install every time you edit /boot/grub/menu.lst to make the changes effective (same thing with LILO).

crash_override_me 09-23-2006 10:55 AM

Quote:

Originally Posted by pda_h4x0r
Unfortunately, I think that you have to do a grub-install every time you edit /boot/grub/menu.lst to make the changes effective (same thing with LILO).

I edited my menu.lst in Ubuntu, to get the Windows partition.., but did'nt have to do a grub-install.

also, how can doing so, solve our Blank screen issue( check the 1st post)??

pda_h4x0r 09-23-2006 01:31 PM

Sometimes NOT passing a VGA mode to the kernel prevents it from properly displaying text on the console. Passing "vga=791" to the kernel (or any other VGA mode your monitor supports) fixes it. But to pass it to the kernel, you need to a.) edit your /boot/grub/menu.lst and add the parameter, and b.) reinstall the GRUB bootloader to make that change effective. You did not mention in your origional post that you accomplished part (b), which would explain why it didn't work. Repeat: your bootloader configuration file is MEANINGLESS unless you REINSTALL the bootloader with that altered configuration file.

crash_override_me 09-23-2006 05:12 PM

so where do i put this "vga=791" option>>>
in /boot/grub/menu.lst ??

pda_h4x0r 09-24-2006 12:04 AM

You put it at the very end of the "kernel" option, with a space between it and the kernel file.

For example:

kernel /boot/vmlinuz-2.6.17 root=/dev/sda1 ro vga=791

liegerm 09-25-2006 01:00 PM

Quote:

Originally Posted by pda_h4x0r
You put it at the very end of the "kernel" option, with a space between it and the kernel file.

For example:

kernel /boot/vmlinuz-2.6.17 root=/dev/sda1 ro vga=791

Thanks for your advice. But when I put vga=791 at the end of the kernel line, it takes immediate effect the next time I boot with that option - whithout needing to reinstall grub. Either way, it still doesn't get over the actual problem...

Has anyone else seen this problem and managed to cure it?


All times are GMT -5. The time now is 01:41 AM.