LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 10-27-2007, 09:22 AM   #46
dillesh
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0

hiiii
while iam trying to istall ubuntu 6.10 in my new hp laptop iam getting an error like this.........

Busybox V1.1.3(debian 1:1.1.3-3ubuntu3) buit -in

Enter "Help' for a list of built-in-comands



/bin/sh: can't acess tty: job control tunned off

(initramfs)
i tried in google but i couldnt get a solution.......
 
Old 10-27-2007, 10:44 AM   #47
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,037

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
i tried in google but i couldnt get a solution.......
There are several (different) solutions in this thread, did you try them?
 
Old 11-03-2007, 06:49 PM   #48
defza
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
I get this error when I have two SATA's and 2 PATA HDD's plugged in.
Just having Two SATAs work fine.
1 SATA and 1 PATA work fine too.
Motherboard: Asus PK5-VM
Core2duo CPU
Ubuntu 7.04

A work around is to press CTRL-ALT-F1 when Ubuntu is booting. For me it only seems to happen when the boot screen is showing, pressing Ctrl-Alt-F1 switches to a terminal till Ubuntu is finished booting up and this error doesn't occur.


I think this is a race condition with two cpus or more and having certain PATA drives.

Last edited by defza; 11-03-2007 at 06:55 PM. Reason: added ubuntu version
 
Old 11-04-2007, 01:19 AM   #49
eoinrua
Member
 
Registered: May 2007
Location: Lurgan, Northern Ireland
Distribution: Ubuntu, Xubuntu and Puppy
Posts: 121

Rep: Reputation: 15
Quote:
Originally Posted by emohsain View Post
I too am a newbie who is having a similar problem with Ubuntu 6.10. I am trying to use linux on a sony pcg-c1xs with 64k memory. I was able to load a version of Mandrake 9.2 but it would say I lack resources and load what look like a desk top but no applications.
Sorry folks. I don't want to diss anyone, but I'm really struggling with this one.

Even the meanest distro in the world has to turn its nose up at 64k!

What I would offer as serious advice to those who are trying to use Linux on older hardware is to work from the bottom up and give some of the lower-overhead distros a try first of all.

Feather Linux and Puppy Linux will work on incredibly low-spec machines. I'm a huge Puppy fan - even though it's not my main distro - and always install it on friends' older boxes if they've got limited hardware.

If you want a more polished desktop it might be worth trying Xubuntu, which is a basic version of ubuntu (using the Xfce desktop instead of Gnome or KDE) that runs in a lot less memory.

By the way, if the 64k mentioned above was a mistake and is really 64Mb I can be pretty certain that Puppy will run.

If you use a text-based installer CD Xubuntu will run in 128Mb.

Give Puppy a try first, though.
 
Old 11-07-2007, 03:57 AM   #50
Vipin Das
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
I'm facing th sam problm....Please help me....

My ssm configuation is Intel D 2.8 GHz, 160 GB SATA HDD, 512 MB DDR2 RAM

While installig Ubuntu after loaing t Kernel an screen appears as follows....

Busy Box v1.1.3 (Debian 1:1.1.3-3ubuntu3) Built in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off
(initramfs)[ 35.455613] ata1.00: failed to set xfermode (err_mak=0*4)
[ 70.879270] ata1.0: failed to set xfermode (err_mak=0*40)
[ 106.302912] ata1.0: failed to set xfermode (err_mak=0*40)


How can I solve this problem...Please Help me...hanx in advance...
 
Old 01-01-2008, 04:16 PM   #51
ceton
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 1
Here's what worked for me.

Regarding /bin/sh: Canít access tty; job control turned off

Apparently, there are a bizillion reasons that this error occurs, but in my case, it was because the Ubuntu Live CD couldn't recognize some of the hardware on the machine I was installing to. (I was able to install it successfully on other machines--it was just one troublesome machine).

Here is what worked for me:
  1. When the bootup screen appears, press F6
  2. Type the following: acpi=off irqpoll
  3. Press the Enter key.
  4. View the Live CD and install Ubuntu.

You have to make sure that this problem is resolved when Ubuntu boots, too. To do that:
  1. Boot your computer so that GRUB is displayed.
  2. Press the "e" key to go into edit mode.
  3. Press "o" to add a new line to the script.
  4. Type the following: acpi=off irqpoll
  5. Press the Escape key.

In the event that acpi=off doesn't work try replacing the entry above with one of the following:
  • acpi=force irqpoll
  • nacpitimer irqpoll

You may have to revisit the second set of steps when you upgrade ubuntu.

I hope this helps.
 
1 members found this post helpful.
Old 02-13-2008, 09:14 AM   #52
asprakash
Member
 
Registered: May 2006
Location: Chennai, India
Posts: 74
Blog Entries: 3

Rep: Reputation: 18
Hello ceton. You are really great!
For the last one month I was facing the same problem. I followed ur steps. Now I got solved my problem. Thank you.
 
Old 03-01-2008, 06:29 PM   #53
cleopanther
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
I have an old Toshiba Portege 3480CT that I've used for a couple of years to run Ubuntu successfully until I tried to install v6.10. Now I get the "sh: can't access tty; jog control turned off" error with some messages I haven't fun into in any of the posts on this list.

The first is "You have an unusual or non-standard CD-ROM drive (expecially on certain laptops, which require you to pass parameters to the kernal at boot time." The second is "Can't mount loop back file system."

Here's my system info:

Model:
 
Old 03-03-2009, 09:52 AM   #54
remlapsirhc
Member
 
Registered: Jun 2006
Posts: 48

Rep: Reputation: 15
/static/ash: Can't access tty: job control turned off. is the message I get!

I am a newbie! However... I got this error trying to run the latest Mepis 8 from a live CD. I vaguely remember having this problem before so I opened the case, took the ide cable out of the DVD Rewriter, and plugged it into another DVD ROM. I have now tried both the 32 and 64 versions. Although there are some error messages as it boots, it gets there, seemingly unscathed!

Last edited by remlapsirhc; 03-03-2009 at 09:56 AM. Reason: for clarification
 
Old 01-31-2011, 01:46 PM   #55
aaron88
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
can't access tty: (...) when adding another internal hard drive

Hi,

I'm really new at this, and hoping someone can help me out with this problem. I get that same error:

target filesystem doesn't have sbin/init.
No init found. Try passing init= bootarg.
BusyBox v1.10.2 (Debian 1:1.10.2-2) built-in shell (ash)
/bin/sh: can't access tty; job control turned off

It also says that the system couldn't mount various directories from /root; which i'm assuming they system couldn't find them properly.
I am trying to add a multi-partition SATA hard drive from my old computer as a secondary.

I'm currently running Debian Lenny (5.05).

I'm not sure where to go from here. I've tried most of the options I have read in this post with no luck.
I don't know if it's because it's a windows formated hard drive, or something else.

Thanks in advance. (let me know if there's more info you need to help me solve this problem.)
 
Old 07-23-2011, 11:15 AM   #56
mhitza
LQ Newbie
 
Registered: Jul 2011
Posts: 1

Rep: Reputation: Disabled
I had the exact same issue, but in my case there where some corrupted iNodes which where fixed by running fsck
 
  


Reply

Tags
boot, cant, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Query solutin for tty job control turned off. I'mabadger Linux - Newbie 5 03-04-2006 06:37 PM
sh: can't access tty; job control turned off. shadowsa Suse/Novell 2 11-21-2005 12:13 PM
control job turned off greythorne Suse/Novell 0 08-14-2005 03:58 AM
can't access tty; job control turned off johnnybezak Linux - General 4 02-21-2004 11:49 PM
sh: can't access tty, job control turned off tgardner Linux - Software 1 06-07-2003 01:39 AM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration