LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2007, 04:54 AM   #31
elect
LQ Newbie
 
Registered: Apr 2007
Posts: 15

Rep: Reputation: 0

After discussing along about it on ubuntuforums, I think its a problem with the controller IDE/SATA...

The beta cd of Ubuntu worked for me as for the others, but with the stable release it doesnt work...this is very weird
 
Old 04-29-2007, 05:02 AM   #32
Chapita
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: Disabled
Finally I found a solution, maybe no so "technical" but worked from me: I re-install Ubuntu 6.10 and from there, I upgraded to 7.04 via update-manager -c.

i know is a little bit tricky, but works fine now.
 
Old 04-29-2007, 05:13 PM   #33
medya
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 87

Rep: Reputation: 15
hey I had the same problem I solved this by doing this ...

hope it helps !
 
Old 05-08-2007, 11:27 PM   #34
roboa1983
LQ Newbie
 
Registered: May 2007
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by mduf
I got same error while booting an ubuntu 6.10 machine that worked fine before.

I used the ubuntu live CD to start it. (sorry for those who can't)
and by using:
sudo fdisk -l

I found that mysteriously the name of the hard drive had change.
Before it was hdb and now it is hda

So I mounted the hard drive and corrected the /boot/grub/menu.lst file
I changed
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hdb1 ro quiet splash

for

kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda1 ro quiet splash
Hi. I'm having the same problems, but I uploaded right from 6.10. I have been browsing around the forums for answers, but I honestly have not tried much.
I already mounted my partitions (they're named sda2...), but this is what I get:

title Ubuntu, kernel 2.6.17-11-386
root (hd0,1)
kernel /boot/vmlinuz-2.6.17-11-386 root=UUID=8a175020-0bd8-4cc8-ab7e-552cff9fef42 ro quiet splash
initrd /boot/initrd.img-2.6.17-11-386
savedefault
boot

Therefore, I have no idea, where the mentioning of my partition is. Thanks for all the help.
 
Old 05-18-2007, 03:31 AM   #35
cewan
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
I had the same problem, and it turned out that that UUID thingy was incorrect for me...
simply enter your partition in cleartext for root!

Example:
Replace
Code:
kernel /boot/vmlinuz-2.6.17-11-386 root=UUID=8a175020-0bd8-4cc8-ab7e-552cff9fef42 ro quiet splash
With
Code:
kernel /boot/vmlinuz-2.6.17-11-386 root=/dev/sda2 ro quiet splash
 
Old 06-17-2007, 12:19 PM   #36
developer
LQ Newbie
 
Registered: Jun 2007
Posts: 1

Rep: Reputation: 0
Thanks!

Quote:
Originally Posted by medya
hey I had the same problem I solved this
hope it helps !
Your link worked great, I am unable to paste a URL because I'm new but thank you!
 
Old 06-18-2007, 05:14 AM   #37
medya
Member
 
Registered: Sep 2005
Distribution: Ubuntu
Posts: 87

Rep: Reputation: 15
Quote:
Originally Posted by developer
Your link worked great, I am unable to paste a URL because I'm new but thank you!
the arthour of that article is a student in iran ! and he is so much trouble, you can donate a few bucks to him as thank you
 
Old 06-22-2007, 02:24 AM   #38
jnikolai
LQ Newbie
 
Registered: Jun 2007
Posts: 1

Rep: Reputation: 0
If you're getting this error, and you don't have the option of moving drives around (if you're on a laptop, for instance), try going into your bios and turning off AHCI on the SATA controller. It might be worded differently - disable anything about advanced controllers, enable anything referring to compatibility. YMMV, of course, but it worked for me.
 
Old 07-29-2007, 03:38 PM   #39
moresun
LQ Newbie
 
Registered: Aug 2003
Location: Austira
Distribution: kubuntu 7.04
Posts: 15

Rep: Reputation: 0
Problem Solved for Dell Precision M4300 and kubuntu 7.04

Hi!

I was trying to install kubuntu on my dell laptop but I got the following error message:

BusyBox V1.1.3 (Debian 1:1.1.3 - 3Ubuntu2) built-in shell (ash)
Enter 'help' for a list of built-in commands
/bin/sh: can't access tty; job control turned off
(initramfs)


I used the solution found on https://bugs.launchpad.net/ubuntu/+bug/99757


The solution was using the F6 boot option and adding the string break=top
It looked than like:
.........quiet splash break=top
After you hit than the enter key the error message appears immediatel.
Type than
modprobe piix
exit

The LiveCD starts now. But It won´t start the graphical interface because the nvidia driver are not yet on the system.
You have to change now the driver to the vesa driver by changing the /etc/X11/xorg.conf with sudo vi /etc/X11/xorg.conf
You will find there the driver "nv" or "nvidia" change they to vesa.
After saving the file start the kde with startx

Greetings
Max
 
Old 09-21-2007, 06:33 AM   #40
jon rouse
LQ Newbie
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 6

Rep: Reputation: 0
My son had the /bin/sh: can't access tty; job control turned off problem on a brand new laptop.

He fixed it by installing Mandriva.
 
Old 09-25-2007, 09:25 AM   #41
ozonehole
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Rep: Reputation: 0
I just got one of those new Dell laptops that comes with Ubuntu pre-installed. But like others in this thread, it won't boot the Ubuntu Live CD that came with the machine. I'm getting the same errors that everyone else is experiencing.

However, I did find a workaround. If you download the Ubuntu "alternate install" CD, it will boot. You can then install. The text-mode installer is not difficult to use.

If you want a Live CD, I've found that Kanotix will work fine with this machine.

The problem does appear to be with the Ubuntu Live CD not being compatible with certain hardware. I'm hoping that will be fixed in the next release, which is due out in less than a month, but we'll have to wait and see.

People: please file bug reports when you have problems like this. That's the only way that they'll get fixed. I have done that several times, and almost always got a rapid response from the developers.

best regards,
Oz
 
Old 09-25-2007, 11:08 PM   #42
ozonehole
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Rep: Reputation: 0
I want to add that I went ahead and filed a bug report just now, so the rest of you probably don't have to. I'll post again when I get a response from the developers.
 
Old 10-02-2007, 02:22 PM   #43
jabalsad
LQ Newbie
 
Registered: Oct 2007
Posts: 5

Rep: Reputation: 0
Just thought i'd register to deliver my comments

I had the same problem and someone on another thread mentioned it is hardware incompatibility.

I tried using the text mode installer and when ubuntu tried to mount the dvd-rom i was installing from, it failed. This made me think that it is possibly the optical drive. I swapped it around for another one (I used pioneer at first and am now using LG) and it is installing perfectly.

Hope this helps
 
Old 10-03-2007, 11:31 AM   #44
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
/bin/sh: can't access tty; job control turned off
I had this problem when installing 7.04 on a laptop with a SATA drive.
The (easy) solution is here http://ubuntuforums.org/showthread.php?t=415009&page=14
See hbjason's post, Number 133

Last edited by tredegar; 10-03-2007 at 11:36 AM. Reason: added title reference
 
Old 10-14-2007, 11:39 AM   #45
mithilesh
LQ Newbie
 
Registered: Sep 2007
Posts: 8

Rep: Reputation: 0
ONE MORE SOLUTION FOR THE SAME PROBLEM... it worked for me hope it does for u too...

when the ubuntu screen loads wit all the options like "start or install ubuntu","memtest", n few other options, exit the graphical mode by pressing "ESC" button... then enter the parameters..

boot:live noapic nolapic (then hit enter.. then the live cd loads normally..)

i am using kubuntu 7.04...
 
  


Reply

Tags
boot, cant, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Query solutin for tty job control turned off. I'mabadger Linux - Newbie 5 03-04-2006 05:37 PM
sh: can't access tty; job control turned off. shadowsa Suse/Novell 2 11-21-2005 11:13 AM
control job turned off greythorne Suse/Novell 0 08-14-2005 02:58 AM
can't access tty; job control turned off johnnybezak Linux - General 4 02-21-2004 10:49 PM
sh: can't access tty, job control turned off tgardner Linux - Software 1 06-07-2003 12:39 AM


All times are GMT -5. The time now is 11:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration