LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-23-2010, 12:44 AM   #1
gimpy530
Member
 
Registered: Oct 2007
Posts: 98

Rep: Reputation: 16
Audio stopped working on 9.10 x64


I have a media center box running Ubuntu 9.10 x64 and XBMC. One day sound just stopped working on it. I did not install any updates around the time this happened. I have tried using a known working sound card. I verified the main volume is up and everything else in alsamixer looks OK. I have tried connecting known working headphones. Confirmed the kernel sees the hardware and loads to module for it. Confirmed several audio applications have no sound. I've confirmed it is set to use the correct sound card. I even booted into a live disk of the same version if Ubuntu and audio works fine there.

No errors are produced by any application, they act like they are playing audio just fine. The only entries in the logs about this I can find is below.

What else can I do to get audio working again?

Code:
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
        Subsystem: Micro-Star International Co., Ltd. Device 7585
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
        I/O ports at f000 [size=256]
        I/O ports at ec00 [size=256]
        Memory at fe02d000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: Intel ICH
        Kernel modules: snd-intel8x0
Code:
white@mulberry:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CK804 [NVidia CK804], device 0: Intel ICH [NVidia CK804]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: CK804 [NVidia CK804], device 2: Intel ICH - IEC958 [NVidia CK804 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Code:
white@mulberry:~$ sudo modprobe snd-intel8x0
white@mulberry:~$ echo $?
0
Code:
Relevant entires of /var/log/messages

Jun 23 01:25:33 mulberry kernel: [   20.340054] intel8x0: clocking to 47009
Jun 23 01:25:33 mulberry kernel: [   20.340050] intel8x0_measure_ac97_clock: measured 60720 usecs (2976 samples)
 
Old 06-23-2010, 07:23 AM   #2
halvy
Member
 
Registered: Aug 2005
Location: Boston Massachussets, USA
Distribution: my own Debian creation :)
Posts: 884

Rep: Reputation: 40
I'm not sure what linux you are using, but in debian when you install software there is a program that lists the bugs (known) that are related to any programs or libs that are going to be installed, just to warn you in case you don't want to install them with this new knowledge.

Maybe you installed another program, which changed or otherwise updated some files that are dependencies of your sound systems programs.

I'd try reinstalling all important sound related software, servers, etc... just to see if that helps.

Also either look over your config files (sound) or just reinstall them *fresh* and then tweak them later.

It sounds like a switch has been changed *somewhere*.. but by the time you find it, it may be easier to reinstall the major components of your sound system.

Lettuce know
 
Old 06-23-2010, 07:52 AM   #3
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 286Reputation: 286Reputation: 286
The OP said he was using Ubuntu 9.10.
Gimpy530,
Try the different settings under: system > preferences > sound. Try changing sound from PulseAudio to Alsa there. Try the "test" button with each sound option and see if the test produces sound.
 
Old 06-23-2010, 12:08 PM   #4
halvy
Member
 
Registered: Aug 2005
Location: Boston Massachussets, USA
Distribution: my own Debian creation :)
Posts: 884

Rep: Reputation: 40
well.. thanx for taking the time for correcting me on that very important issue.
 
Old 06-23-2010, 12:24 PM   #5
gimpy530
Member
 
Registered: Oct 2007
Posts: 98

Original Poster
Rep: Reputation: 16
Indeed, Ubuntu 9.10 x64.

tommcd, I went into that and played around with settings while I had a small wav file looping. It still did not work so I decided to look around and changed it so that everything is pointed to the secondary card I added to it to test. Still nothing. I then went back and reverted everything back to the on board card (which they were all set to in the beginning) and the wav started playing. So, it was set to use the internal card to start with but for some reason was not using it. No idea what started the problem as the second card was added later to test with, but it works now.

Thanks for your help.
 
Old 06-24-2010, 11:00 AM   #6
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by gimpy530 View Post
So, it was set to use the internal card to start with but for some reason was not using it. No idea what started the problem as the second card was added later to test with, but it works now.
Glad you got it working. If you have problems again, or would like to use the other sound card, then see this thread from the Ubuntu forums for setting the default sound card when you have 2 sound cards in Ubuntu:
http://ubuntuforums.org/showthread.php?t=922860
You should also be able to run:
Code:
alsamixer -c 0
or:
Code:
alsamixer -c 1
to choose which sound card you want to use. I can't test that since I have only 1 sound card. The cards are numbered starting from zero 0. So if you have 2 cards they would be 0 and 1.

Of course, if you are happy using the onboard sound card, then you could just remove the added pci sound card.

Last edited by tommcd; 06-24-2010 at 11:04 AM.
 
Old 07-11-2010, 11:23 AM   #7
Mountain Man
Member
 
Registered: Jul 2006
Distribution: Ubuntu 11.10 (desktop), lubuntu 11.10 (netbook)
Posts: 73

Rep: Reputation: 15
I just had the same basic thing happen on a desktop running 9.10 x64. After reading this thread, I went into system/preferences/sound and changed the profile on the hardware tab to "none" and then rebooted. When it booted back up I switched it back to analog sterio output and it seems to be working fine now. Hopefully the fix will survive my next reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I've killed sound -- Ubuntu 7.10 x64, Realtek HD Audio MathBluster Linux - Hardware 2 12-02-2007 09:54 PM
"M-Audio Mobile Pre Usb" Soundcard stopped working sonium Linux - Hardware 1 12-21-2006 11:58 PM
audio stopped working on Etch with new kernel upgrade johnMG Debian 5 02-25-2006 03:37 PM
Audio stopped working BBB Linux - Hardware 1 08-05-2004 03:50 PM
Audio CDs stopped working on Fedora C1!? Skorp Linux - Hardware 0 04-21-2004 07:35 PM


All times are GMT -5. The time now is 01:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration