LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-06-2006, 11:18 AM   #1
Fasn8n
Member
 
Registered: Dec 2004
Location: Virginia
Posts: 79

Rep: Reputation: 15
apt-get can't find latest FireFox.


I'm running 1.0.7, I need 1.5. Apt-get is saying I have the latest version Any clue on why it's doing this?
 
Old 03-06-2006, 11:25 AM   #2
brianthegreat
Member
 
Registered: Oct 2005
Posts: 518

Rep: Reputation: 32
You have to install firefox 1.5 by hand.

Just do a google search such as Ubuntu firefox 1.5 and then you should be presented with instructions regarding hte download and install of the firefox 1.5 browser.
 
Old 03-06-2006, 11:27 AM   #3
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
http://ubuntuforums.org/showthread.p...utomatix+howto

Use automatix to help you do this.
 
Old 03-06-2006, 12:59 PM   #4
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
Software doesn't get updated except when it's absolutely necessary for security purposes. In some ways, Firefox 1.5 is a security update, but there are complicated packaging issues with it, so it's going to be included in the next Ubuntu release (Dapper) instead of the current release (Breezy).

In the meantime, it's not that difficult to follow these instructions (just copy and paste):

https://wiki.ubuntu.com/FirefoxNewVersion
 
Old 03-15-2006, 02:48 AM   #5
mozetti
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Slack 10.1
Posts: 37

Rep: Reputation: 15
Quote:
Originally Posted by aysiu
Software doesn't get updated except when it's absolutely necessary for security purposes. In some ways, Firefox 1.5 is a security update, but there are complicated packaging issues with it, so it's going to be included in the next Ubuntu release (Dapper) instead of the current release (Breezy).

In the meantime, it's not that difficult to follow these instructions (just copy and paste):

https://wiki.ubuntu.com/FirefoxNewVersion
What you said is correct, but it's not the reason FFx v1.5 isn't in the repositories. I read about this on the Ubuntu forums. Ubuntu uses FFx as it's browser for Help and Documentation -- replacing FFx v1.0.7 w/ FFx v1.5 would break this. That's why they don't include an updated FFx in the repositories.
 
Old 03-15-2006, 10:27 AM   #6
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
Quote:
Originally Posted by mozetti
What you said is correct, but it's not the reason FFx v1.5 isn't in the repositories. I read about this on the Ubuntu forums. Ubuntu uses FFx as it's browser for Help and Documentation -- replacing FFx v1.0.7 w/ FFx v1.5 would break this. That's why they don't include an updated FFx in the repositories.
That's what I meant by "there are complicated packaging issues with it."
 
Old 03-15-2006, 07:19 PM   #7
brianthegreat
Member
 
Registered: Oct 2005
Posts: 518

Rep: Reputation: 32
All you have to do is complete a search for Ubuntu 5.10 firfox 1.5 and you will be presented with a how-to regarding the installation of the firefox browser.

The install via tarball is not tough.
 
Old 03-15-2006, 08:18 PM   #8
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
https://wiki.ubuntu.com/FirefoxNewVersion

It's copying and pasting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to find latest drivers? slinky2004 Linux - General 2 12-09-2005 06:48 PM
HOWTO: Install the Latest Firefox rykel Ubuntu 3 06-11-2005 07:56 AM
Where to find the latest logfile a1ex_007 Linux - Security 1 03-18-2005 09:58 PM
Firefox died (Fedora Core 1, firefox latest) Brakki Fedora 1 03-05-2004 11:25 AM
Installing latest Mozilla in Debian thru apt-get bureado Linux - Software 1 12-08-2003 01:09 PM


All times are GMT -5. The time now is 09:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration